BIAB cannot see Xtra Pak 9 [Resolved]

Posted by: Don L Turner

BIAB cannot see Xtra Pak 9 [Resolved] - 05/22/20 05:44 PM

Anyone else having this problem? I installed build 721. I installed Xtra Pak 9 and did a rebuild. But the styles do not show up in the picker. The filter shows all the Xtra Style Paks (1-9) but when I select Xtra Pak 9 I don't see any "9" styles. In fact, I see 5 of my personal styles marked as Xtra Pak 9.

I contacted support online and they said it might be a bug.
Posted by: rodipoet

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 02:28 AM

Hi Don, I have the same problem as you have. Installed 721, installed pack 9 , rebuilt my styles, but the new ones don't show up in the stylepicker. Redownloaded and reinstalled, checked if the new files were in the styles directory and still no luck. So I went to my laptop and tried the same but on this one the new styles are visible and usable. So my story so far: one computer install of pack 9 works, the other one does not.
Posted by: VideoTrack

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 03:20 AM

Worked for me with Build 721

Press Clear first to clear the search filter

Do you get these results:



Posted by: rodipoet

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 03:20 AM


Problem seems to be solved: I did a slow styles rebuild in the stylepicker and now my new extra styles 9 are available
Posted by: VideoTrack

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 03:22 AM

Surprising, as this shouldn't need a slow rebuild, but great to know this is working.
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 05:55 AM

THank you for your detailed instructions. As I indicated earlier:

"I installed build 721. I installed Xtra Pak 9 and did a rebuild. But the styles do not show up in the picker. The filter shows all the Xtra Style Paks (1-9) but when I select Xtra Pak 9 I don't see any "9" styles. In fact, I see 5 of my personal styles marked as Xtra Pak 9."

I confirmed that build 721 is installed. Mine does not say "Release 0" like yours. So they may have changed the executable file since you downloaded it. I downloaded that file again and installed it for a second time; no help.

I cleared the filter before selecting Xtra Style Paks. (forgot to mention that earlier)

I have subsequently noticed that a lot of files are in the BB/Styles folder with the date 4/2/2020. Those appear to be the Xtra Pak 9 files. SO it looks like the files are on my computer in the correct folder but BIAB cannot see them.
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 06:14 AM

This is really odd.

I did like you did and ran a slow rebuild yesterday just to see if it helped. It did not help.

This morning I ran the slow rebuild again but left the style filter at Xtra Pak 9. Now BIAB sees the Xtra Pak 9 files.

Problem solved; just don't know why.
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 06:32 AM

Don, about the Release 0. There is a line of code that shows that. Beta testers have it. I’ll see if I can find it later. But it really is of no consequence. You have the one and only 721.

About the Slow Build. The only difference I can find is that Slow finds non-PG Music styles as well. I don’t think there is much difference in execution speed, and I think it would eliminate confusion to just get rid of Fast Build and call Slow Build “Reindex”. I have also pitched the idea of running it automatically as part of each update, based on this kind of question that invariably occurs.
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 06:41 AM

Okay. Beta testers have that version. That makes sense. As I posted earlier, the problem was resolved by a slow rebuild of the styles, in my case, with the Xtra Pak 9 filter on in the style picker; not sure if that last part had anything to do with resolving the problem, but I tried slow rebuild earlier and it did not help.
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 07:17 AM

If you would like to see the release number, and again, it isn't needed, just do this:

Create a text file with one space in it.
Name it ShowReleaseNumber.txt
Save it into your top-level /BB folder.
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 08:08 AM

I misunderstood. It's the same executable file but shows the release number because of ShowReleaseNumber.txt in the BB folder. I tried it and proved what you said. Now I understand.

Thanks.
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 08:25 AM

Originally Posted By: Matt Finley

About the Slow Build. The only difference I can find is that Slow finds non-PG Music styles as well. I don’t think there is much difference in execution speed, and I think it would eliminate confusion to just get rid of Fast Build and call Slow Build “Reindex”. I have also pitched the idea of running it automatically as part of each update, based on this kind of question that invariably occurs.


On my machine, Slow Build takes a lot longer to execute. But I do it occasionally because I create lots of variations on existing Styles.

I like the idea of the Fast Build auto-running during the update process. Makes perfect sense to me. I wonder why that's not already happening.

I still wonder why fast build (tried it three times) did not show Xtra Pak 9, and why the first slow rebuild did not help, but the second slow rebuild (with Xtra Pak 9 in the filter) solved the problem.

And I still have 5 of my Style variations listed as Xtra Pak 9, although I created them long before I bought Xtra Pak 9.

Mysterious to this old mind. But not sure it actually matters.
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 10:12 AM

That last one is surely a bug, showing your older custom styles as being in Xtra pak 9. Send that one to support@pgmusic.com
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/23/20 11:00 AM

I checked and found that a lot of my personal styles show something other than "User" as the set number. I sent an email to support.

Thank you for all your help.
Posted by: Andrew - PG Music

Re: BIAB cannot see Xtra Pak 9 - 05/24/20 10:12 AM

Quote:
I still wonder why fast build (tried it three times) did not show Xtra Pak 9


What is the date of this file:
\bb\data\factory_stylz1.bin
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/24/20 04:28 PM

5/07/2020

Does that explain something about the problem?
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/24/20 05:32 PM

My date is 02/18/2020

And I thought I was completely updated.
Posted by: VideoTrack

Re: BIAB cannot see Xtra Pak 9 - 05/24/20 06:20 PM

Originally Posted By: Matt Finley
My date is 02/18/2020

And I thought I was completely updated.

I understood that I was completely updated too and mine is also February 18. I wonder what the date is expected to be?
Posted by: MusicStudent

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 07:40 AM

Originally Posted By: VideoTrack
Originally Posted By: Matt Finley
My date is 02/18/2020

And I thought I was completely updated.

I understood that I was completely updated too and mine is also February 18. I wonder what the date is expected to be?


05/07/2020 here grin
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 08:01 AM

Over to you, Andrew. Thanks.
Posted by: rodipoet

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 11:49 AM

5/07/2020
Posted by: Andrew - PG Music

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 03:57 PM

Quote:
I checked and found that a lot of my personal styles show something other than "User" as the set number.


If you are making variations of newer styles - in other words, you made a copy of an existing style that was made by PG Music within the last couple years, then Band-in-a-Box is probably picking up the 'Style memo' data embedded in the style. You could open the StyleMaker - ctrl+shift+f9, click MISC -> Style Memos etc. If the extra settings are enabled, you can set the "Styles disk #" to 999. After a slow rebuild, this style should show up as a User Style.

Quote:

5/07/2020
Does that explain something about the problem?


No, I'm not quite sure what the cause of the problem is. This is the correct date (05/07/2020, or later). If you Fast Rebuild (slow rebuild not necessary) after installing Xtra Styles PAK 9, you should definitely see them in the StylePicker.

Quote:

My date is 02/18/2020


Even if you install the Xtra Styles PAK 9? I'm sure you have, I just can't think of a reason why you would have a Feb. file.

Quote:
slow vs. fast rebuild


The only difference is that slow rebuild looks for 'user' (non-PG Music) styles. Perhaps we could state that right in the menu option to make it clear.
Posted by: MusicStudent

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 06:07 PM

The folks reporting the older date all had access to the beta version. When it was released the version number did not change dispite a last minute change in the code. So they never updated to the new final version. I had the beta also, but I updated when it was released. Which is why I have the updated date

Or something else happened. crazy

Dan
Posted by: Don L Turner

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 06:26 PM

Originally Posted By: Andrew - PG Music

If you are making variations of newer styles - in other words, you made a copy of an existing style that was made by PG Music within the last couple years, then Band-in-a-Box is probably picking up the 'Style memo' data embedded in the style. You could open the StyleMaker - ctrl+shift+f9, click MISC -> Style Memos etc. If the extra settings are enabled, you can set the "Styles disk #" to 999. After a slow rebuild, this style should show up as a User Style.


I tried this on a few and it worked fine. I'll try to remember this the next time I do a variation on an existing style.

Thank you.
Posted by: Matt Finley

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 06:28 PM

If Dan is right, it's the reason I keep asking if there are any changes in the public version from the beta version. I always figured that's what the release numbers were for. Even if you make the most minor change, increment the release number.

I do check the file sizes and if they are different, I reinstall the newer one. I didn't in this case yet; will try now.

EDIT: I just installed the public version, and now my date is indeed 5/07/2020. Dan, you called it. I still think this kind of thing, if true, should require a new release number.
Posted by: VideoTrack

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 09:49 PM

Yes, Dan's right on the money here. I upgraded from Build 721 to Build 721 and my date is now May 7

And I also agree that if anything has changed, the build number should reflect that, even if it is from 721 to 721(a) or similar.
Posted by: VideoTrack

Re: BIAB cannot see Xtra Pak 9 - 05/25/20 09:50 PM

Maybe the Beta releases should be 721(b) etc? With the appended letter indicating a Beta release?