DAW plugin won't load BB Songs with accented characters in filename or path

Posted by: Melody_Maker

DAW plugin won't load BB Songs with accented characters in filename or path - 06/11/19 11:59 AM

I've finally found why some of my SGU songs refuse to load in the DAW plugin, giving an error (and pointless) message:
"There was a problem running Band in a Box. Please restart the plugin and try again".

I've noticed that this problem occurs when my SGU songs contain french accents like 'é' or 'è' in their filename or in any portion of the path i.e. For example C:\Eléments\àlaclairefontaine.sgu won't load in DAW plugin because of the 'é' in the path or because of the 'à' in the filename.

I'm running BB (last version) on Windows 10 Home French version (1903, but same problem already occurred with previous Win10 versions).

Some localisation error there, I guess...

If I'm not mistaken, it's up to you, dear Bb developers smile

Best,
Bob

Posted by: Jim Fogle

Re: DAW plugin won't load BB Songs with accented characters in filename or path - 06/11/19 05:25 PM

Bob,

That's impressive. Congratulations on figuring it out.

For the record, what version of the plugin are you using? You can check by selecting File > Preferences > About.
Posted by: Melody_Maker

Re: DAW plugin won't load BB Songs with accented characters in filename or path - 06/11/19 06:15 PM

Thank you Jim for your nice comment.

I'm using Band-in-a-Box DAW VST3 Plugin v1.14.2

Same problem occurs with the VST(2) Plugin.

Best,
Bob