Registry error

Posted by: TRYUK

Registry error - 10/10/19 01:57 AM

I am suddenly getting a registry error when loading via the plugin. This was fine until apple updated both Logic Pro X and Garageband so I am guessing Apple has changed something. If you keep clicking OK on the error message after a while it goes away and the Plugin loads the song. Is anyone else having this problem?

EDIT:

I think that I have worked out why I am getting the Registry error. I have Logic opening by default as 120 BPM in 4/4 Time. The song I try opening is _POPRAMP.STY which is in 3/4 time. This causes the error message, eventually I get the Message in the Plugin that the song is in a different time signature, though it then works. So I tried opening Logic and changing the time signature to 3/4 time, then loading _POPRAMP.STY, the registry error still appears.

Loading various 4/4 time songs at random I do not get the error message. So I believe there maybe a bug in the Plugin perhaps?

Tim.
Posted by: Andrew - PG Music

Re: Registry error - 10/10/19 11:16 AM

Opening a 3/4 style when your project is 4/4 should give you this message:




What is the exact text of the error message you're seeing?
Posted by: TRYUK

Re: Registry error - 10/10/19 12:44 PM

Hi Andrew, It would seem I was chasing a red herring. While working with a file in the main BiaB program I got the registry errors there as well. It didn't take long to find that the songs generating the error used Amplitube. I reinstalled Amplitube and no registry errors at all.

I do indeed get the message shown by you and all seems to be well now. Having loaded a dozen or more tracks in to the main program or via the plugin in the latest version of Logic Pro X (10.4.7) and the latest Garageband (10.3.3)

Tim.