generated realdrums don't line up with tempo map?

Posted by: DaveG

generated realdrums don't line up with tempo map? - 04/17/21 06:02 PM

I'm having troubles doing something in realband that I have accomplished in the past. I'm looking for help figuring out what I am doing wrong.

I've used the chord wizard to analyze 3 tracks that I imported, drums, bass, and an acoustic guitar. They are tracks of a song that a friend of mine recorded using a simple drum pattern from a keyboard. My goal is to have the ACW determine the tempo map (and chords as a bonus) so that I can add realdrums to the mix and have it sound nice.

The chord sheet looks great, the tempo map looks right, the bar lines match up, everything's cool. Then I add a realdrum track and it's like it chose it's own tempo map... Nothing lines up and it sounds like I just mashed two unrelated tracks together.

I know that I haven't done this in a couple of years, but I do recall doing this same thing in the past.... Is there some setting that I'm missing that tells the realdrum generation to use the tempo map?

I appreciate any input.

thanks,
Dave
Posted by: Jim Fogle

Re: generated realdrums don't line up with tempo map? - 04/17/21 06:48 PM

I suspect the drum track is off 2 bars from the audio track. Realband adds two bars for the count-in. Try moving the drum track two bars to the left.
Posted by: rharv

Re: generated realdrums don't line up with tempo map? - 04/18/21 09:04 AM

This has always worked here .. got any more detail, or a screen shot or something that may yield better clues?
Posted by: DaveG

Re: generated realdrums don't line up with tempo map? - 04/19/21 11:59 AM

Originally Posted By: rharv
This has always worked here .. got any more detail, or a screen shot or something that may yield better clues?


You’re right. I’ll put together some screen shots and some more details this evening. Perhaps I’m misunderstanding how the tempo map gets used within realband. Is it per track? Project wide?

I think my previous efforts used a single song track. This multi track effort is confusing things.

Thanks,
Dave
Posted by: rharv

Re: generated realdrums don't line up with tempo map? - 04/19/21 02:54 PM

The Tempo Map should get used on all tracks, unless you opt out of it during certain conversions.
I know of no settings that would cause this.
Like I said, it usually just works here.
Sometimes something weird like bit/rate mismatch can cause issues, but your issue sounds nothing like that.