Warning! BIAB for iPad/iPhone not compatible with IOS upgrade.

Posted by: AlastairLC

Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 05/31/17 09:18 PM

Apple is sending me messages that the latest IOS upgrade will not support BIAB for iPad. I have informed PG Music of this but have received no satisfactory response.
If this is true then my upcoming gigs are in jeapody. I don't understand PG Music's lack of response and resolution.
They should support all their products.
It would also be a good time to make the fixes and improvements I have been recommending in my posts for over a year.
Posted by: Andrew - PG Music

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/01/17 10:18 AM

Yes, we have learned about that issue. Good thing they're notifying people a few months ahead of time!
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/01/17 03:44 PM

Actually, Apple is asking me to upgrade my iPad IOS now! So time has run out.
Posted by: Larry Kehl

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/01/17 06:50 PM

Do I understand this right:

Apple is doing something that BREAKS BIAB on iOS devices and making you update the OS that "breaks" BIAB, and its PG’s fault, or PG is supposed to “stop the presses” until they fix what APPLE broke?

I feel your pain but come on

Larry
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/01/17 07:08 PM

Apple didn't break anything. They're jjust doing one of their regular IOS upgrades. They are warning us that BIAB will not be compatible when they do that and therefore PG Music needs to being it into compliance.
Until that happens I can't do the IOS upgrade without potentially losing BIAB.
Posted by: Andrew - PG Music

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/01/17 09:48 PM

Right, a large number of apps (and older devices too I think) will be incompatible with iOS 11 unless the developers update them, so that's what the warning is about. It seems like a beta iOS 11 might be available soon, but the official version won't arrive until late in the year as far as I understand.
Posted by: Pipeline

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/02/17 04:16 AM

Apple is constantly updating their OS's that screws so many software developers. You see it all the time when downloading Mac software "Not working on OS X XXXX, we are currently working on a new Beta version" then they get it working then Apple screws them again by changing things in yet another OS update.
Then you go to run a download app " Sorry XXX needs 10.9.2 to run you are using 10.9.1"
Then you update to 10.9.2 then you find other apps don't work anymore.

Windows, just always works.
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/02/17 06:46 AM

Andrew, are you saying that BIAB won't be compatible (until changed) with IOS 11, due this fall, but it is compatible with the IOS upgrade that Apple wants me to do now?
Posted by: Andrew - PG Music

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/02/17 07:56 AM

Originally Posted By: AlastairLC
Andrew, are you saying that BIAB won't be compatible (until changed) with IOS 11, due this fall, but it is compatible with the IOS upgrade that Apple wants me to do now?


That sounds right. Well what are the details of the upgrade, and what iOS version do you actually have?
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/02/17 08:19 AM

Thanks Andrew. I have version 10.3.1 (14E304) and they want me to upgrade to 10.3.2. Is it safe for me to do that?
Posted by: Andrew - PG Music

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/02/17 01:00 PM

I installed iOS 10.3.2 and it didn't seem cause any problems with Band-in-a-Box or other apps in my testing.

But I should also mention also that I have not personally seen this warning message, I've only seen references to it on various blogs and news sites. I have no idea why it doesn't appear on my device. Also I can't at the moment find any information directly from Apple about this, either in the Apple Developer area or in fact anywhere on Apple's website. I am likely overlooking something. Either way, we will look into it.
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/07/17 12:21 PM

Thanks Andrew. I waited to get through some recent gigs, then upgraded to 10.3.2 as well. Like you, I found that BIAB ran ok. Phew!
I hope that PG Music will soon make sure to bring BIAB into compliance with the future iOS upgrade that it's not supposed to run on.
That would be an excellent time to make the fixes and improvements I have recommended in my wishlist posts for over a year.
Posted by: Pipeline

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/08/17 01:59 AM

Speak of the Devil:
Apple to Phase Out 32-Bit Mac Apps Starting in January 2018
Posted by: Andrew - PG Music

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/08/17 10:03 AM

Hi Alastair,

So, the Band-in-a-Box apps are already 64bit, and I'm wondering if maybe you have an older version installed. At one point there was an iPad-specific app, which was later replaced with a single app that's for both iPhone and iPad. The older one I believe had "iPad" written on the icon. Perhaps you could try downloading the current one? Then again, if your setup is working well for you right now...
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/08/17 10:28 AM

Andrew,
The version on my iPad says "iPad" on the logo. It is Version 1.0.12 (build 5200). When I go to the App Store, the only version that pops up is Version 1.0.15 with a "download from cloud" icon showing. If I go ahead and download that version, will all the songs I've got on my iPad run on it without having to download them all over again from my PC? Thanks.
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 06/09/17 10:00 AM

Andrew,
I went ahead and downloaded version 1.0.15 from the iCloud. This is the more recent version without "iPad" in the logo. It set up as a separate app from my 1.0.12 version. It doesn't have any of my songs on it, so I would have to download and regenerate them all from my PC to use it. As the "newer" version has none of the fixes I've been recommending, I'll continue to use my older version (which still works, thank goodness).
I hope that the anticipated iOS- compliant version will not require me to download and regenerate all my songs!
Posted by: eddie1261

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/01/17 07:56 PM

Originally Posted By: AlastairLC
Apple didn't break anything. They're jjust doing one of their regular IOS upgrades. They are warning us that BIAB will not be compatible when they do that and therefore PG Music needs to being it into compliance.


"Will not be compatible" and "will not support" can mean 2 different things. Did someone at Apple say in these words "BIAB will no longer run on IOS" are they just not going to make updates with BIAB in mind?

This reminds me of when Microsoft said "We will no longer support XP" and 75% of the world started posting message like "XP won't work anymore!" All that meant in that case is that there would be no further updates for it.

I don't use IOS so this does not apply to me, but I am curious what they actually said because those 2 quoted phrases above do not necessarily mean the same thing. PG will fix it once they see it. Think of it in the same way I saw people scream at Norton Anti-Virus because Norton didn't put out a patch to keep people from initially getting a virus. Well, until they see the virus, how can they do anything to prevent it? PG needs to see what doesn't play well before they can fix it. And they will.

In the meantime, if you really have a potential loss of work, I would dump your songs out to MP3 as a backup and play them as MP3s on a tablet or laptop. At least you can do a gig that way.
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/02/17 07:19 AM

I don't remember the exact wording but I think Apple said the BIAB for iPad app wouldn't be compatible with future upgrades. I've switched to using the BIAB app without the "iPad" in the logo and I'm not getting any warnings from Apple on that.
This is still not satisfactory. I have posting requests for fixes and necessary improvements to this app in the wishlist section for THREE YEARS and only one fix has been made. I still use it, but working around its faults and quirks continues to be very annoying. I pray that some day PG Music will finally upgrade this good app to make it truely great.
Posted by: Matt Finley

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/02/17 11:40 AM

The beta version for iOS 11 is now available, so testing can commence. The last I read, the release date for the public version is expected to be in September.
Posted by: jazzmammal

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/28/17 08:03 AM

Originally Posted By: AlastairLC
This is still not satisfactory. I have posting requests for fixes and necessary improvements to this app in the wishlist section for THREE YEARS and only one fix has been made.


Alistair, you've put this in every post in this thread. What do you think the word "Wishlist" means? It doesn't mean that it's a demand list so that whatever you put there turns into a "MUST DO" list. Quite a few items in the Wishlist have been done over the years and made a lot of folks happy, but quite a few have not as well.

And, it sounds like as far as compatibility issues there really isn't a problem so this whole thread is a mistake? This is how false rumors spread all over the internet because now a search about possible problems with Biab and IOS will turn up this thread and lots of folks won't bother reading the whole thing, they just skim the headline. What does your incorrect headline say? WARNING! Do some due diligence first before posting something like that.

Your basic question itself is legitimate, all you had to do was ask "Is there a problem with this or not?" That's it.

Bob

Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 06:59 AM

These are not "nice to haves" I'm talking about, Bob. They are malfunctions (e.g., highlighter not tracking 3/4 times) or basic functionality needs (e.g., going to next song in a directory). PG Music's Windows/Mac programs have these features and a hundred more. It's only reasonable to expect them to spend a little time bringing their iPad version up to minimal standards.
Posted by: jazzmammal

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 08:23 AM

You do understand that Biab itself does not directly run on an iPad, right? It's a completely different OS than a Mac or PC. Personally I've never understood why someone would be using this app for live work anyway. Just convert all your songs to Wav or MP3's and use your iPad as a player using one of the many great iPad apps designed for that. Take forScore for example. You can link up your charts, lyrics, and actual backing tracks as setlists, use a footswitch to turn pages, lots of different stuff.

Set List Maker is another one so is I Gig Book.

Bob
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 08:54 AM

Thanks Bob. Yes I do understand that. I create and revise all my backing tracks on my Windows version of BIAB and transfer them to my iPad. I like using the iPad version for performances because it fits unobtrusively on my music stand next to my iPad Pro which shows my sheet music. (I also like having a working highlighter as I tend to get lost from time to time.)
I'm not tech savvy enough to know about the other programs you mentioned. If BIAB for iPad doesn't get fixed I guess I'll have to look into them. I like to keep it simple so I hope that I can continue to just use BIAB.
Posted by: Pipeline

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 10:55 AM

It should be more than a Wishlist, more like a To Do List.
A good way is to save your Biab songs to Video Render.
If you do them with a low video bitrate they are not much bigger than an mp3/m4a.
Posted by: jazzmammal

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 05:17 PM

You use two iPads? Well that's pretty cool. IPads are nice devices, lots of players I know use them. You should check out some of those apps though, they work really well. Here's the IGigBook page:

http://www.igigbook.com/

This app does a lot, can't say if it's for you but it's worth a look.

Bob
Posted by: Pipeline

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/29/17 11:37 PM

Here's a video you can try on your pads/tablets.
It has been unfolded (Edit > Song Form > Unfold).
Save As Button > Save as Video
It is set to scroll ahead and show tittle, 640x360.
In BB > Prefs > Display, you can set the number of rows to see on the pad/tablet.
To include Count-in > Audio > Render to Stereo > Include Drum Count-in sound.

Watch https://www.dropbox.com/s/2x8ns7dikxqfgcm/BLEACHER-Demo.mp4?dl=0
https://www.dropbox.com/s/8h0dbe5yz2ndqsr/BLEACHER-Demo-count.mp4?dl=0
Download https://www.dropbox.com/s/2x8ns7dikxqfgcm/BLEACHER-Demo.mp4?dl=1
https://www.dropbox.com/s/8h0dbe5yz2ndqsr/BLEACHER-Demo-count.mp4?dl=1
Click No Thanks Continue at bottom to skip login

Here's a free AVI to MP4 converter
http://www.softpedia.com/get/Multimedia/Video/Encoders-Converter-DIVX-Related/Free-AVI-to-MP4-Converter.shtml
Posted by: AlastairLC

Re: Warning! BIAB for iPad/iPhone not compatible with IOS upgrade. - 08/30/17 12:28 PM

Bob, you can see my two-iPad setup in my first post of "What's Your Setup" in the Recording, Mixing,... forum. Works for me.