Issue with drivers

Posted by: Rich59

Issue with drivers - 03/07/18 10:52 AM

I believe there is a missing file from my operating system. I am using asio4all with BIAB and Realband but I only have input and output on one piece of software at a time. I am getting a message from my Tascam interface that indicates I may have an issue in the OS. I tried to scan and repair windows. I received a message that there were some corrupted files but some cannot be repaired. I do not know if this would include a missing file. Everything was initially working before. I have checked for updates on both the asio4all and the Tascam and re-installed their respective software although I did not uninstall initially, but since the popup message from the Tascam indicates the OS as a possible issue I assume that is where the problem lies. Any help would be appreciated.
Thanks Rich
Posted by: Matt Finley

Re: Issue with drivers - 03/07/18 11:01 AM

Rich, we need more info.

Please give us the exact messages you are receiving.

Why are you using ASIO4ALL? Since you say your Tascam 2x2 device has its own drivers, that should be all you need. You should not use ASIO4ALL if the regular vendor driver works.

If you have to use ASIO (with some exceptions) only supports one device at a time, so that would be normal.

Try the MME driver in BIAB and RealBand. It should work, and this will rule out BIAB or RealBand from the problem.
Posted by: Rich59

Re: Issue with drivers - 03/07/18 02:11 PM

When I updated to BIAB 2018 I was having all sorts of trouble with recording and playback. It was suggested I use asio4all and it has worked perfectly fine with both Realband and BIAB. My current problem is if I set up BIAB with the asio driver I cannot set up realband even though I would not be using them at the same time. I have to keep resetting the drivers depending on which software I am using. Before I did not have this issue.
BIAB playback with MME tascam ok
Realband playback with mme Tascam ok
Neither will record. No input signal showing
with my Podxt and my Tascam interface.
Error message with Podxt "Get buffer size function failed"
Tascam pop up "Did you keep your computer up to date? Errors in the OS may cause any issue".
I was attempting to uninstall this morning, the codex wave synth but could not find it in the programs list. It created a list of microsoft visual C++2005 Redistributable (X64) and X(68) as well as a group of others dated 2008,2012,2013 and 2015. I uninstalled these only after creating a restore point. The restore kept failing. I then went online and downloaded the codex again and got the programs back but the issues are not resolved. I then scanned the hard drive for errors which there were some but they could not all be fixed. I have a log but it will not let me see it offline.
Windows Research protection found corrupt files but was unable to fix some of them.
Details are included in the cbs.log windir\logs\cbs\cbs.log.
Note that logging is currently not supported in offline servicing scenerios.
Posted by: Matt Finley

Re: Issue with drivers - 03/07/18 02:33 PM

This is helpful.

Don't worry about the redistributable C library messages; it's normal for Windows to install those as needed.

I would have done what you did, uninstall and reinstall the Tascam.

From what you've reported, I don't see anything wrong with RealBand or BIAB. I don't use either to record, so perhaps others here can check your steps to record and make sure everything in those programs is set correctly. But it sure sounds like your problem completely resides in the Tascam.
Posted by: Kent - PG Music

Re: Issue with drivers - 03/07/18 02:40 PM

Hi Rich,

"Get buffer size function failed" generally means that you've selected the ASIO driver for an interface that isn't connected to the computer. The driver is trying to connect to the device, and isn't able to. I'd just stick to the Tascam's ASIO driver for now, since the PodXT is an older legacy product. What happens when you select the Tascam's ASIO driver, and which specific model by Tascam are you using?

Regarding Waves Codex, it's a great synth (I love wavetables), but Waves plugins aren't currently supported by our software without using a third party utility. Most plugins have a DLL file for each individual plugin, but Waves use one Shell DLL that connects to all the Waves plugins you have installed. You'll generally find that they only work with the hosts listed as supported on their website:

You may be able to get it working using Shell2VST, but we haven't tested this in-house.

PG Music
Posted by: Rich59

Re: Issue with drivers - 03/07/18 03:18 PM

Thank you. That was the reason I was attempting to uninstall it. I still cannot figure it out. Anyway as a last resort I booted windows in safe mode and then scanned the OS for corrupt files. Strangely it found no issues and after rebooting both Realband and BIAB play and record with no issues. I had already ubimstalled asio4all as well but that was not the issue because I tested everything before booting into safe mode. The pod works also. I just have to leave the driver's set to the Tascam because I am going into that from the Pod anyway. Never thought about that before. No need to change drivers.
Thanks for taking the time to help out. Much appreciated.
Posted by: Pipeline

Re: Issue with drivers - 03/09/18 04:09 PM

Sorry I didn't read all the posts here as my eyes are too sore, but if you want multiple ASIO get Voice Meeter Banana, VB Cable and HiFi Cable.

All here

You can set windows default playback to VB Cable and in the Hardware input 1 of Voice Meeter and HiFi Cable to Input 2, then you can set Biab to ASIO VoiceMeeter and RealBand or other apps to ASIO VoiceMeeter AUX
Set the Hardware Output of Voice Meeter to your main audio device or onboard audio.
Have Voice Meeter run at startup !

Someone reminded me the other day the I made a tutorial for Shell2VST, just do a site search up the top pipeline Shell2VST