Styles not found!

Posted by: jbtaj

Styles not found! - 11/18/20 08:23 AM

Help please, I have UltraPack installed, in the style folder there are 7,603 styles, but in the Stylepicker I only have 5,733. Run the rebuild fast/low but no more styles found.

What could be going on?
Posted by: etcjoe

Re: Styles not found! - 11/18/20 08:41 AM

Check to make sure you are not filtering for any styles. I sometimes forget that I have only a certain group of styles showing like 4:4 or 3:4 timing etc.
Posted by: VideoTrack

Re: Styles not found! - 11/19/20 04:05 AM

Yes, press the Clear button first, and see if that makes a difference.
Posted by: jcland

Re: Styles not found! - 11/19/20 05:39 AM

Also go to Help, What Add-ins Do I Have and see if you are missing any that should have been included in the UltraPak.

I have used BIAB since the inception eon's ago and in my collection I have 13,012 files with the .STY extension in my styles directory but I only show 9,307 in StylePicker. That is quite a few missing styles in StylePicker and I have never figuured it out.

One day I'll export the list as a text file and then compare what I have with the list that StylePiker shows and then try and load some of the missing styles to see what happens.

As it stands I have 3,705 styles on the hardrive that are not showing up in StylePicker even have doing a slow rebuild numerous times.

This is an old problem that has never been resovled by PGMUSIC
Posted by: jford

Re: Styles not found! - 11/19/20 12:59 PM

Some of the STY files are substyles files (part markers C/D, E/F, etc) which aren't listed in StylePicker as standalone styles, so StylePicker will always have fewer entries than the number of STY files.

My computer has 10,028 STY files in the BB\Styles folder. StylePicker shows 9,690, leaving 338 unaccounted for. Of those, there are 154 substyles files (they're the ones that end in a "+" in the filename. That leaves 184 not accounted for. I have a bunch I've downloaded from the web over the years,so it is possible some of them might be corrupt or unreadable.
Posted by: jbtaj

Re: Styles not found! - 11/19/20 02:32 PM

thank you all for your valuable feedback!
Posted by: axlchang

Re: Styles not found! - 11/27/20 06:21 PM

So problem happened to me. I'm 2020 UltraPak, user, Mac.

On Styles Charts, there is an option of

Other - "show all styles that are found/not found" - "show all styles including n/a styles"

by choosing this option, I should have 7,642 styles, however, only 5,272 styles are available.

For the "not available" styles, I'm able to listen to the demo, that means the .m4a file exist. For example, I'm gonna use "-500 WATT" which is perfect for "Mary has a little lamb" of SRV, but when I click "OK" to use, 3 out of 4 tracks are not available but the drums track.

So anyone inside or outside PG can tell me what had happened? I even reinstall the relative sets, that didn't work. I don't know where have the disappeared tracks gone... Need help, thank you in advance.
Posted by: DSM

Re: Styles not found! - 11/28/20 02:11 AM

I am not a mac user but there should be a button for rebuilding the styles. Use the slow rebuild and see if it helps.

...Deb
Posted by: VideoTrack

Re: Styles not found! - 11/28/20 03:10 AM

Also, make sure that no filters are in place by pressing the 'Clear' button in the Style Picker.
Posted by: axlchang

Re: Styles not found! - 11/28/20 10:04 AM

cleared several time, and tried rebuild too.

the problem is due to the unavailable real tracks (.st2), i even reinstalled some package, but did not work.
Posted by: Andrew - PG Music

Re: Styles not found! - 11/28/20 09:07 PM

Hello,

Quote:
For the "not available" styles, I'm able to listen to the demo, that means the .m4a file exist. For example, I'm gonna use "-500 WATT" which is perfect for "Mary has a little lamb" of SRV, but when I click "OK" to use, 3 out of 4 tracks are not available but the drums track.


I believe you have the UltraPAK so I wouldn't expect you to have any missing Drums.

Is this the style _500WATT.STY? This uses the Drums RockSyncKick^ which was part of RealTracks Set 273.

A) Do you see RockSyncKick^ in your Drums folder?
B) If so, check the RealDrums Preferences dialog and make sure that your Drums folder location is what you expect (if you are using a custom folder).

Edit: I think I misunderstood your question. Are you missing the RealTracks from this style, or the Drums?
Posted by: axlchang

Re: Styles not found! - 11/28/20 10:35 PM

all 4 tracks of this style, but only drum works, all other 3 tracks are n/a
Posted by: Andrew - PG Music

Re: Styles not found! - 11/28/20 11:22 PM

The three RealTracks used (RT# 1717, 1718, 1719) are from Set 156. I suggest:

A)
Check in the RealTracks Preferences that your RealTracks folder location is what you expect (empty if just using the internal hard drive Band-in-a-Box folder.

B)
Check in the RealTracks Picker, show n/a checkbox and sort by Set # column. See if there's a range of sets that are N/A - maybe you just need to install some missing sets.

Are all RealTracks missing, or just a few, and do they show up as N/A [RT Folder] or N/A [ST2 Missing], or just N/A?
Posted by: axlchang

Re: Styles not found! - 11/29/20 10:30 AM

Hi Andrew,

Thank you for your quick response like always.

A) I did checked the Preference of the RealTracks, everything fine, just leave the "custom RealTracks Folder" as unchecked, since I installed all BIAB in the internal HardDrive.

B) I checked the RealTracks Picker, as I mentioned on the previous thread, only 5272 out of 7642 are available. For the Styles including RealTracks and RealTracks with MIDI, supposed to have 4942, but 2305 of them contains N/A tracks.

So not all RealTracks were missing, just part of them. The reason seems like various, mostly of ST2 missing.

Hopefully I made sense.
Posted by: axlchang

Re: Styles not found! - 11/29/20 12:39 PM

BTW, I tried reinstalling the relative sets, but nothing help for the issue.

In fact, the style of "_500 WATT" is simply an example, I'm experiencing the problem for about 1/4 of the styles, just listed some detail numbers as above.
Posted by: Andrew - PG Music

Re: Styles not found! - 11/29/20 01:40 PM

I have a feeling that some of the files need their permissions fixed. Please install the latest Update patch for Band-in-a-Box 2020 Mac (build 420) (just run the installer even if you already have build 420), and will fix those issues. Afterwards, open the StylePicker and re-build again, and see if the problem is resolved.
Posted by: axlchang

Re: Styles not found! - 11/29/20 02:16 PM

but where is the update patch of build 420? on the my product page, only have the full installation file.
Posted by: axlchang

Re: Styles not found! - 11/29/20 03:26 PM

finally I found the update patch on the "support" page, and reinstalled it. Unfortunately, the issue is still existing...
Posted by: Andrew - PG Music

Re: Styles not found! - 11/29/20 03:41 PM

Ok, then let's focus on one RT # 1717 (Bass, Electric...)

In the RealTracks Picker, does it show it as N/A, N/A (ST2..) or N/A (RT Folder)?

In your Band-in-a-Box/Soloists folder, do you have the file RBass135.ST2?
In your Band-in-a-Box/RealTracks folder, do you have the subfolder 'Bass, Electric, TexasBluesRockStraight Ev 120' ?

In the downloaded DMG containing RT set 156, do you have an install_log.txt file in the RealTracks Packages folder?
Posted by: axlchang

Re: Styles not found! - 11/29/20 04:00 PM

I attached 3 images for your 3 questions.

For the last question, commonly, after installation, it was deleted, or where can I get the log file?
Posted by: Andrew - PG Music

Re: Styles not found! - 11/29/20 05:10 PM

You may have a RealTracks 155-205 disk image, and if so you could look in the RealTracks Packages folder. If there isn't a log there, that is a pretty good indication that you didn't install it, and so you could do that now. If there is, you could open it with a text editor and see what it says.
Posted by: axlchang

Re: Styles not found! - 11/30/20 10:40 AM

Sorry but a little bit confused about that. Where is the RealTracks Packages folder? So I need to download 155-205 for that?
Posted by: Andrew - PG Music

Re: Styles not found! - 11/30/20 11:00 AM

Quote:
Sorry but a little bit confused about that. Where is the RealTracks Packages folder? So I need to download 155-205 for that?


Ok, I made the assumption that you had the UltraPAK and have downloaded the RealTracks from your account and that's how you installed them. If so, you would have that DMG file on your computer, and on it you would have the folder I mentioned. So how DID you install the files? Do you have an UltraPAK USB hard drive? If so, you could run the Setup on that hard drive, and it should sync up all the files that you are missing on your internal HD.
Posted by: axlchang

Re: Styles not found! - 11/30/20 11:11 AM

got it. I'm UltraPAK user of 2020 both windows and Mac. For the issue of installation, I just download all the file at the webpage of "my products". However, after installation, I just deleted the dmg/pkg file.

So do I need to download again?
Posted by: axlchang

Re: Styles not found! - 11/30/20 11:40 AM

good news, I reinstalled 155-205, and on the style picker, I used "rebuild", then no more N/A, I think the problem was resolved. But I wanna ask, I need do the same on all n/a styles? that should be a huge task...
Posted by: axlchang

Re: Styles not found! - 11/30/20 12:03 PM

also, try another style after reinstalling the extra packs, it shows everything fine for the tracks inside, but another issue occurred, refer to the images I uploaded pls.
Posted by: axlchang

Re: Styles not found! - 11/30/20 12:04 PM

another image.
Posted by: axlchang

Re: Styles not found! - 11/30/20 12:40 PM

------ Mon Nov 30 11:31:51 PST 2020 ------
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 155-159.pkg
installer: Package name is RealTracks Sets 155-159 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 160-164.pkg
installer: Package name is RealTracks Sets 160-164 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 165-169.pkg
installer: Package name is RealTracks Sets 165-169 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 170-175.pkg
installer: Package name is RealTracks Sets 170-175 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 176-181.pkg
installer: Package name is RealTracks Sets 176-181 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 182-187.pkg
installer: Package name is RealTracks Sets 182-187 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 188-193.pkg
installer: Package name is RealTracks Sets 188-193 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 194-199.pkg
installer: Package name is RealTracks Sets 194-199 installer: Installing at base path / installer: The install was successful.
---
Installing /Volumes/RealTracks Sets 155-205/RealTracks Packages/RealTracks Sets 200-205.pkg
installer: Package name is RealTracks Sets 200-205 installer: Installing at base path / installer: The install was successful.
Posted by: Andrew - PG Music

Re: Styles not found! - 11/30/20 03:46 PM

Thanks... we can be pretty confident that the files are installed now if they weren't before. Could you try running that Band-in-a-Box 2020 (420) patch again just in case there are now any permissions issues. Then, check again for the existence of the .ST2 file in your Soloists folder...
Posted by: axlchang

Re: Styles not found! - 11/30/20 04:30 PM

tried for that. All the issues from the realtracks sets are resolved now.

But for the styles from the following package are still not available,

Xtra Pak 1-8
Bonus Pak
Bonus
Misc.
MST 28-29
0 MIDI
79 MIDI

1437 styles in total.

The tracks inside the styles are good, but when I tried to use it by clicking "OK" button, the message shows "the .sty file cannot be found..."
Posted by: Andrew - PG Music

Re: Styles not found! - 11/30/20 05:03 PM

Great, it sounds like it's fixed. This is expected that you wouldn't have those styles, since the majority are 'Xtra styles', and the rest are from a bonus PAK.
You should rebuild the StylePicker when prompted after the install. It sounds like that wasn't done, since the styles should be showing up as N/A.
Posted by: axlchang

Re: Styles not found! - 11/30/20 06:53 PM

I did rebuild, however, not help.
Posted by: Andrew - PG Music

Re: Styles not found! - 11/30/20 07:28 PM

I don't think there is a problem to solve anymore... you likely have selected the menu option to show N/A styles. If the style appears as N/A (Not Available) then you wouldn't be able to load it. It's just a style that the program knows about, but you don't happen to have it. The style categories that you listed all make sense as styles that you wouldn't have - so I would recommend just selecting Other --> Show only styles that are available.
Posted by: axlchang

Re: Styles not found! - 11/30/20 07:31 PM

got ya
Posted by: DSM

Re: Styles not found! - 12/01/20 09:43 AM

Andrew, I purchased all the bonus sets in the past and they are showing up as N/A.

Did the rebuild both fast and slow multiple times. Support has my email about this.

...Deb
Posted by: Andrew - PG Music

Re: Styles not found! - 12/01/20 12:47 PM

Quote:
Andrew, I purchased all the bonus sets in the past and they are showing up as N/A.

Did the rebuild both fast and slow multiple times. Support has my email about this.

...Deb


Hi Deb,

You should start a new thread about this, probably in either the Band-in-a-Box Mac or Windows forum depending on which platform you are on.

Just for your information, slow rebuild is only if you want the program to search for "third party" (no -PG Music styles). Also, you'd need to clarify if it is showing up as [N/A], or [RT N/A], and an example style, and we could go from there.