Songs not playing correctly - only hearing drums [Resolved]

Posted by: GarryH

Songs not playing correctly - only hearing drums [Resolved] - 09/12/19 01:08 AM

I'm having a problem playing back songs. When I select a song, no matter which I choose, I only hear the drums.

I can see in the mixer that there is audio meant to be playing on other instruments, but there is no sound, despite nothing being muted. If I solo individual instruments, I don't hear anything - only the drums will play if soloed.

On the mixer, the drums are green, but all other instruments are yellow - does this indicate missing files?

When I check the track settings for the other instruments, all tracks are enabled.

I have version 2018 UltraPlus Pak for Mac.

Can anyone help?
Posted by: sixchannel

Re: Songs not playing correctly - only hearing drums - 09/12/19 01:41 AM

More info please - is it only midi drums you hear, or is that true for a style with RealDrums and Realtracks.
What happens if you run an all midi style?
Ian
Posted by: GarryH

Re: Songs not playing correctly - only hearing drums - 09/12/19 02:47 AM

Thanks for the reply Ian.

I can swap out the drums for different styles, both RealDrums and MIDI, and I hear both.

Regarding an all midi style - I'm not sure how to select this: I go to the Song Selection window, and the categories I have include Name, File Name, Melody and Style. I can't select MIDI/Real from here.

However, if I select any song and load it, I hear only drums. If I then change the style, and choose only MIDI styles, still I hear only drums. However, if I then change to a RealTracks style, now I hear all instruments, and all instruments are green.

Hmm... ok, something to do with the MIDI settings. I think this is related to CoreMIDI setup, because if I instead select Apple DLS, then it works (but sounds very basic). I use MIDI a lot in Logic Pro, and have a large number of sample libraries that I use there, so MIDI seems to be working fine, but clearly something wrong with my MIDI settings in BIAB. I've tried different ports, but nothing works when I have CoreMIDI selected.

Thanks again,
Garry
Posted by: VideoTrack

Re: Songs not playing correctly - only hearing drums - 09/12/19 04:27 AM

Hi, Ian (Sixchannel) is on the money here. Generally, nearly all styles have replaced MIDI drums with RealDrums as the new default.

Look at the mixer, and if the instruments appear in yellow, they are MIDI and if they appear in green, they are Real Tracks (or Real Drums)

I suspect most of the instruments (except for Drums) are in yellow for the problem songs you have encountered, which suggests that there is a problem with your MIDI output device. I don't use Mac so this may be slightly different on your system, but check two things:

1: Change a style to one that is all RealTracks (green) - do all the instruments play correctly?

2: Check under Menu Options > MIDI/Audio driver setup. What is the MIDI Output driver you are using, and if you check "Use VSTi/DXi Synth" and "Route MIDI Thru to MIDI driver" and select a DXi synth, do you now get MIDI sounds?

Please let us know the outcome.
Posted by: GarryH

Re: Songs not playing correctly - only hearing drums - 09/12/19 05:05 AM

Ok, thanks guys - we nailed it! I went into MIDI/Core Audio (choose ports), and set MIDI In to Port 1, and everything else to BIAB Virtual Output.

Now everything works - thanks for the quick replies, much appreciated.
Posted by: VideoTrack

Re: Songs not playing correctly - only hearing drums - 09/12/19 05:45 AM

Garry,
Thanks for letting us know you're OK, and thanks for marking as resolved, and thanks for explaining the resolution you used. This can assist others in the future.