You need to be logged in to post
Options
Index
#447238 - 12/25/17 08:23 PM [RealBand] No sound in Kontakt
Registered: 10/08/15
Posts: 971
Loc: Philippines
Trygve Larsen Offline
Expert

Registered: 10/08/15
Posts: 971
Loc: Philippines
Lately I have ben using RB a bit more for Midi and the other VSTi I have tried, works fine, but not Kontakt. I had that issue before with BiaB, until I learned from the forum that Kontakt must have Chanel 1 in order to work. RB is different here, as it does not have the same as BiaB, in the top, to select a forced channel. I tried right click on the track and chose channel 1 from there, to no avail. What am I doing wrong?
_________________________
Forever Grateful
Trygve "Leo" Larsen
BiaB 2018 Audiophile, Windows 8.1, Intel Core i5 CPU, 270GHz, 32 Gb RAM
My tracks on Soundcloud; https://soundcloud.com/trygve-larsen
The Universe = Uni-verse ie one song.

Top
#447248 - 12/25/17 10:28 PM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 10/31/08
Posts: 14457
Loc: Australia
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 14457
Loc: Australia
Trygve,

We need more information.

How do you load Kontackt? Do you load it on each individual track?

Noel
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447249 - 12/25/17 10:49 PM [RealBand] Re: No sound in Kontakt [Re: Noel96]
Registered: 10/08/15
Posts: 971
Loc: Philippines
Trygve Larsen Offline
Expert

Registered: 10/08/15
Posts: 971
Loc: Philippines
Originally Posted By: Noel96
Trygve,

We need more information.

How do you load Kontackt? Do you load it on each individual track?

Noel
Ok.. I right click the track, then go up to "Specific VSTi for midi track, and select Kontakt from there. When Kontakt loads, I select the VST I like to use and drag it over.. Another problem here both in BiaB and RB is that it takes a terrible long time before the VST loads... Any way to make it load faster?
_________________________
Forever Grateful
Trygve "Leo" Larsen
BiaB 2018 Audiophile, Windows 8.1, Intel Core i5 CPU, 270GHz, 32 Gb RAM
My tracks on Soundcloud; https://soundcloud.com/trygve-larsen
The Universe = Uni-verse ie one song.

Top
#447280 - 12/26/17 06:53 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 10/31/08
Posts: 14457
Loc: Australia
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 14457
Loc: Australia
Trygve,

It sounds like you need to do some homework on how to use midi with multiple channels. There's a great deal of information out there on the internet. While working with midi can be confusing to start with, once you can see how it works, it all makes sense.

Let's see if I can get you started...

Firstly, if you are setting all the different RB tracks to midi channel to 1 (which it sounds like you might be), you'll confuse Kontakt. Each midi track MUST have it's own, unique midi channel.

Then, when you load an instrument in the instance of Kontakt that's specific to the track you are working on, you need to make sure that you use THE SAME MIDI CHANNEL in Kontakt that your track is set to.

Here's an example using Philharmonik Miroslav (because I don't have Kontakt). The principle is exactly the same with any softsynth that is not general midi.

I'm going to put Philharmonik strings on RB Track 5.




1. Right-click on track 5.

2. From the menu that appears: (a) select a unique midi channel for this track (#1 on the image below, I'm using midi channel 6); (b) follow #2, #3 to load Philharmonik Miroslav.



3. Open the softsynth Philharmonik (#4) and make sure that the required String sound is added to midi channel 6 (#5).



Hope that helps get you going,
Noel

P.S. Loading time is a function of the synth. As I understand it, because Kontakt is one of the superior synths, the audio files used for the samples are large. This is why it takes time to load. (The higher the quality of the audio, the longer the loading time.)
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447310 - 12/26/17 11:10 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 12/20/00
Posts: 11107
Loc: Pensacola, Florida
jford Offline
Veteran

Registered: 12/20/00
Posts: 11107
Loc: Pensacola, Florida
Kontakt does not require everything to be on channel 1. when the Kontakt screen pops up, you click on the port (usually Input A) and select the channel you want to use as your input.

In BIAB, you can go to Options, Preferences, Channels to see which channel a particular track uses, and then you should be able to match the channel to the input setting in Kontakt.


Attachments
Kontakt MIDI Channel.jpg


_________________________
John

LaptopBeast HP Win7Pro64, 8GB
AudioBeast ASUS Win10Pro64, 16GB
VideoBeast HP Win10Pro64, 8GB

UMC404HD/Casio Kbds/BB-RB2019/Cakewalk/Reaper/Studio One/Samplitude/MixBus/Notion/Finale/Noteworthy/NI Komplete/Halion/Garritan/IK
http://www.sus4chord.com

Top
#447395 - 12/27/17 12:38 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 10/08/15
Posts: 971
Loc: Philippines
Trygve Larsen Offline
Expert

Registered: 10/08/15
Posts: 971
Loc: Philippines
Thank u guys for trying to help me out. I have messed more around with it today and figure out something, but not all. There is some different Kontakt library that works just fine, others does not work at all and one, and the Chris Hein Harmonica works only on channel 1. It does not have a channel choice at all in it. The one that works well in BiaB but not at al in RB is the Rhapsody Orchestral Color. And I have tried all of the above advice. The strange thing is that I can see it getting midi signal, because the is blinking movement in the little midi channel circle to the left, and the voice numbers fluctuate up and down...

Maybe I just have to contact the Rhapsody company and address the problem? Or is it anybody else that have Rhapsody? And have made it work in RB?

Thank's again guys !
_________________________
Forever Grateful
Trygve "Leo" Larsen
BiaB 2018 Audiophile, Windows 8.1, Intel Core i5 CPU, 270GHz, 32 Gb RAM
My tracks on Soundcloud; https://soundcloud.com/trygve-larsen
The Universe = Uni-verse ie one song.

Top
#447445 - 12/27/17 07:46 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 12/20/00
Posts: 11107
Loc: Pensacola, Florida
jford Offline
Veteran

Registered: 12/20/00
Posts: 11107
Loc: Pensacola, Florida
Quote:
There is some different Kontakt library that works just fine, others does not work at all


Another thing to consider is that Kontakt Libraries are not like general MIDI libraries and so the notes sent to it don't do the same thing as they would going to a GM library. For example, a Kontakt library may only respond to one octave of notes and other octaves may be used for key switches, for example.

So, you have to be very careful to send the library what it expects. If your Chris Hein library only works on channel 1, then just make sure that the track is set to channel 1. Sometimes you have to actually completely rechannel the track to accomplish that (just setting the track to channel 1 doesn't change existing data on the track, which may be, say, channel 3). You can rechannel the track to get everything on channel 1.

Also, if you have multiples that want to go to channel 1, make sure all of those tracks are defined to send to separate instances of the VSTi (Kontakt, for example) on different ports so they don't step on each other.

I'm sure you probably know all this, but it may also help others.
_________________________
John

LaptopBeast HP Win7Pro64, 8GB
AudioBeast ASUS Win10Pro64, 16GB
VideoBeast HP Win10Pro64, 8GB

UMC404HD/Casio Kbds/BB-RB2019/Cakewalk/Reaper/Studio One/Samplitude/MixBus/Notion/Finale/Noteworthy/NI Komplete/Halion/Garritan/IK
http://www.sus4chord.com

Top
#447554 - 12/27/17 09:59 PM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 10/08/15
Posts: 971
Loc: Philippines
Trygve Larsen Offline
Expert

Registered: 10/08/15
Posts: 971
Loc: Philippines
Yes, jford, aware of most of it, but that part;

"Also, if you have multiples that want to go to channel 1, make sure all of those tracks are defined to send to separate instances of the VSTi (Kontakt, for example) on different ports so they don't step on each other."

I have never had to mind before. But since I now work with remixing bigger midi files from Classical Music, I certainly have to learn how to do that... Thank's a lot for ur always helpful advises... wink

I just started to scratch the surface of RB, so I guess I will soon be back here with other questions...
_________________________
Forever Grateful
Trygve "Leo" Larsen
BiaB 2018 Audiophile, Windows 8.1, Intel Core i5 CPU, 270GHz, 32 Gb RAM
My tracks on Soundcloud; https://soundcloud.com/trygve-larsen
The Universe = Uni-verse ie one song.

Top
#447584 - 12/28/17 05:25 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 12/10/15
Posts: 494
Mike Head Offline
Journeyman

Registered: 12/10/15
Posts: 494
HI Leo

You may find this post I made last year helpful .
Although this is my way of working the settings hold true and may well help with you big midi arrangements

http://www.pgmusic.com/forums/ubbthreads.php?ubb=showflat&Number=421946

There is also a printable version on my website below on my technical articles page

Mike
_________________________
BIAB2019,UltraPlus, Asus N55S,W10/64,Akai EIEpro,
Yamaha Clavinova CVP405,CoolsoftVirt,MidiSynth
Novatation Impulse61 Ctr kbd,Cakewalk blab,Kontakt

http://mikesmusic.byethost16.com/

Top
#447611 - 12/28/17 07:11 AM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 12/27/03
Posts: 11783
Loc: Hamlin NY
MarioD Online   content
Veteran

Registered: 12/27/03
Posts: 11783
Loc: Hamlin NY
Originally Posted By: Trygve Larsen
Yes, jford, aware of most of it, but that part;

"Also, if you have multiples that want to go to channel 1, make sure all of those tracks are defined to send to separate instances of the VSTi (Kontakt, for example) on different ports so they don't step on each other."

I have never had to mind before. But since I now work with remixing bigger midi files from Classical Music, I certainly have to learn how to do that... Thank's a lot for ur always helpful advises... wink

I just started to scratch the surface of RB, so I guess I will soon be back here with other questions...


Trygve, Chris Hein's harmonica can be set to any MIDI channel, not just channel 1, as previously indicated.

Are you working with a 64 bit Kontakt via j-bridge? If so, FWIW, I have found the j-bridge does not work correctly for every program. Note that this is using 32 bit VSTis in a 64 bit environment.

If you are working with large MIDI arrangements you will be much happier, IMHO, using a 64 bit system and DAW. YMMV.
_________________________
Steal a man's wallet and he will poor for a week. Teach him music and how to buy instruments and he will be poor for his lifetime.

64 bit Win 10 Pro - the latest BiaB and RB - Roland Octa-Capture audio interface - a ton of software and some hardware.

Top
#447763 - 12/28/17 10:20 PM [RealBand] Re: No sound in Kontakt [Re: Trygve Larsen]
Registered: 10/08/15
Posts: 971
Loc: Philippines
Trygve Larsen Offline
Expert

Registered: 10/08/15
Posts: 971
Loc: Philippines
Thank's Mike, will have a look at it...
Mario, yes, I have tried Reason, but don't have all the time to learn a new interface. Struggling enough with learning RB...;)
_________________________
Forever Grateful
Trygve "Leo" Larsen
BiaB 2018 Audiophile, Windows 8.1, Intel Core i5 CPU, 270GHz, 32 Gb RAM
My tracks on Soundcloud; https://soundcloud.com/trygve-larsen
The Universe = Uni-verse ie one song.

Top


PG Music News
Band-in-a-Box® 2019 for Windows Build 614 Available

Attention Band-in-a-Box® 2019 for Windows users... Build 614 is available!

Learn more and download now...

Summary of changes for build 614:
Fixed: Songs would not save plugins on tracks that had a Hi-Q patch selected previously.
Fixed: Hi-Q Patches would not load if the Sforzando VSTi was not in the VSTi plugin list.
Fixed: The Sforzando VSTi was not automatically being added to the VSTi plugin list during bootup (64 bit only).
Fixed: Loading the Hi-Q patch "Hi-Q 040 01 Synth, Analog, FatBass Sforzando" would cause an access violation error.
Fixed: Track Settings > Set Track offset [0] was not working properly.
Fixed: Importing MusicXML files was failing to include melody notes and lyrics.

DAW Plugin 1.10.4 fixes:
Improved: Generation is much faster, at least 4X.
Added: Notification dialog when generation is complete, and a setting to toggle this on/off.
Added: 32-Bit AAX plugin for Pro Tools 10.
Fixed: Soloist not generating on first attempt.
Fixed: MIDI tracks could be rendered at wrong tempo in the Master.
Fixed: Multiriff playback and bar highlighting
Added: Much faster MIDI renders: "No MIDI Renders" option in Custom Generate menu. If this is selected, any MIDI tracks will be left as MIDI and not rendered to wave which takes time.

Video - Band-in-a-Box® for Windows® Download and Installation Tutorial

If you've purchased Band-in-a-Box® and want to download it to get started right away - make sure you check out our latest video for assistance! Click here to watch...

RealBand® 2019 New Features Video!

Learn more about the new RealBand® 2019 features with our RealBand® 2019 New Features Overview Video: Click here...

RealBand® is included in all Band-in-a-Box® for Windows purchases!

Band-in-a-Box® 2019 for Windows Build 612 Available

Attention Band-in-a-Box® 2019 for Windows users... Build 612 is available!

It includes the DAW Plugin patch too!!!

Learn more and download now...

Summary of changes:
Fixed: Songs would not load or save VST data if larger than 1 megabyte, displaying flash message error "VST/FX data is too large to save".
Fixed: It was not possible to use the N key while entering note based lyrics in the Notation window.
Fixed: Recorded MIDI would be erased if also recording audio.
Fixed: The MIDI Driver dialog would not show the selected VSTi or DXi synth after choosing one in the Plugins window.
Updated: PDF and help file documentation.

Band-in-a-Box DAW Plugin 1.9.28 fixes:
There are lots of significant fixes and additions in this patch, especially related to some single track operations not working.

Fixed: Right-clicking generate bass track generated all individual tracks
Fixed: StylePicker, RealTracks Picker, and other style and instrument selection windows would sometimes open behind the main window, requiring you to alt+tab to see them.
Fixed: Loading demo from StylePicker or loading a song when a special track was already present sometimes added an extra RealTracks (special track) to page 2
Fixed: Output directory error.
Fixed: BBW sometimes not receiving message when run as administrator. This would cause some actions to hang or not work at all.
Fixed: Skip grey bars when moving selector through chordsheet.
Fixed: Dragging tracks into Reason would sometimes give a 'Not found' error message.
Fixed: AAX Plugin was not being recognized by Pro Tools.
Fixed: Problem scrolling chord table when crossing PartMarker during highlight.
Fixed: Repaint problem in Reason (possibly other DAWs).
Fixed: Some opened BB songs with realcharts on a frozen track would cause an access violation.
Added: Detailed log file written in BB Data folder bbw4exe_pluginLog.txt.
Fixed: Generation of single tracks would hang the program if the bb folder contained the file MaxPluginsToScan.txt containing Max=0. This file should not normally be present except in rare cases where a DX plugin scan failed.
Added: VST2 FX 32-bit version.
Improved: Installer has options for installing all plugin types. All files are now digitally signed.

Video - the Band-in-a-Box® 2019 DAW Plugin for Windows® in Pro Tools®

Check out our latest video that demonstrates the Band-in-a-Box® 2019 DAW Plugin for Windows® in Pro Tools® - Watch now...

View all of our the Band-in-a-Box® 2019 DAW Plugin videos here, or check out the YouTube Playlist.

Video - the Band-in-a-Box® 2019 DAW Plugin for Windows® in PreSonus® Studio One®

Check out our latest video that demonstrates the Band-in-a-Box® 2019 DAW Plugin for Windows® in PreSonus® Studio One® - Watch now...

View all of our the Band-in-a-Box® 2019 DAW Plugin videos here, or check out the YouTube Playlist.

Video - the Band-in-a-Box® 2019 DAW Plugin for Windows® in Reason®

Check out our latest video that demonstrates the Band-in-a-Box® 2019 DAW Plugin for Windows® in Reason® - Watch now...

View all of our the Band-in-a-Box® 2019 DAW Plugin videos here, or check out the YouTube Playlist.

Forum Stats
28766 Members
60 Forums
56374 Topics
469951 Posts

Max Online: 2434 @ 11/14/17 12:37 AM
Newest Members
FRANK WYBOUW, bjazzy, yanorz, Prodigital, Marc Baum

28765 Registered Users
Top Posters (30 Days)
Pipeline 332
RobH 309
Noel96 293
fiddler2007 191
VideoTrack 160
Matt Finley 155
MarioD 142
Jim Fogle 139
Rustyspoon# 132
silvertones 127
Today's Birthdays
CinKid, DPRyan, operaverdi