14. When I record audio in RealBand, why does it not sync up with my other audio or MIDI tracks?

Identify if the problem is that (1) a MIDI track is consistently out of sync by the same amount throughout your song, or (2) your MIDI and/or audio tracks drift out of sync over time.

(1) MIDI track is out of sync by the same amount throughout your song

You might be using a software synthesizer MIDI output driver such as the Roland VSC or Microsoft GS Wavetable (check this in Options | Preferences | MIDI | MIDI Devices). Software Synthesizers usually have noticeable latency because the sound is processed by your computer's CPU before being sent to your sound card. This means that there is a delay between when RealBand sends the MIDI data and when you hear it played. You should consider using a DXi synth, such as the VSC-DXi, by checking the box 're-route MIDI playback to default DXi synth' - this would likely solve the problem.

Also, there shouldn't be a problem even if you aren't using a DXi synth, if you are consistently using the same MIDI Output Driver. But if you are having trouble syncing audio and MIDI there are a couple of settings in RealBand that you can use to correct the problem.

  • The Audio Delay setting in Options | MIDI Devices. This will delay the start of audio playback and audio recording, which is useful if you want to attempt to keep audio playback/recording in sync with MIDI, especially if you are using a software based synth for MIDI playback. Normally, you will set this to match the Synth (visual) Delay setting. If you are finding that the audio comes in before the MIDI (MIDI is slower), increase this setting. The audio will be delayed by the amount in milliseconds that you specify. You may have to experiment a little to find exactly the correct delay. Note that while the Synth Latency setting should normally be set to the same value as the Audio delay, the Synth Latency setting is quite different; it is only for keeping the visual display, such as displayed times and highlighting of notes, in sync with MIDI playback. It doesn't have any effect on what you actually hear.

  • The Offset In MS setting in Options | Preferences | Audio can be used to make an adjustment to the timing for the purpose of keeping the MIDI and audio in sync. You can make an adjustment to this setting if the sound card's audio timing is early or late in comparison to the MIDI. For example, if the sound card's audio is being heard later than the MIDI, you can try increasing this setting, which will delay the MIDI timing to match the Audio timing. The default for this setting is 0.

(2) MIDI and/or Audio tracks drift out of sync over time

If you are only working with audio, or your tracks don't remain consistently out of sync by the same amount as described above, check to see if you are using more than one sound card. In other words, are you are playing back different tracks through different sound cards? It is possible that the clocks on your sound cards are not perfectly in sync.

There are two places you can configure your audio drivers:

  • In RealBand: Options | Preferences | Audio | [Drivers].

  • In the Windows Control Panel: Multimedia (Win 98/ME), Sounds and Multimedia (Win 2000), Sounds and Audio Devices | Audio (Win XP), or Sound | Playback/Recording Devices (Win Vista/7).

In RealBand, if you have "Microsoft Sound Mapper" selected as your audio driver, RealBand will use whatever is configured in the Windows Control Panel. If you have a driver *other* than the Microsoft Sound Mapper selected, RealBand will use that specific driver. Make sure you don't have the Sound Mapper selected in addition to another driver. To correct this problem, you will most likely need to use a single sound card for audio playback.

Another thing that we have encountered that might cause tracks to drift out of sync, is if the sound card is recording and playing back at different sample rates. This seemed to be a somewhat common issue with some SoundBlaster cards. The first thing you can try is to set RealBand to 48 KHz sample rate, which is done in Options | Preferences | Audio (File type pull-down). If that doesn't help, take a closer look at your sound card's software and make sure that it is set to the same sample rate as RealBand.



Edited by Alyssa - PG Music (09/11/18 11:07 AM)
_________________________
Alyssa - PG Music