You need to be logged in to post on the forum
Topic Options
Index
#447547 - 12/27/17 08:25 PM [Beginners Forum] Song loads a style, but only the midi solo plays
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
The style is available, because if I close the song and load the style it will play.

I made the song file by entering notes in notation view. I've done this with half a dozen other songs and had no problem getting the styles to play. The only difference I can think if is that this one has 3/4 time.

Could I have accidentally changed some setting that is preventing the styles from playing?

Top
#447552 - 12/27/17 09:49 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
Lesley,

I'm not fully following your predicament.

Are you saying that...

1. You load a song style, generate it and then it plays fine.

2. Now when you use notation editor to add a melody and then play the song, only the melody plays?

Did you regenerate the song after writing the melody (this may or may not be necessary depending on what's happened)?

Regards,
Noel

P.S. Also, I don't know if you saw my reply regarding ties in this thread.
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447556 - 12/27/17 10:23 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
Hi Noel,
Yes, only the melody plays when I load a style for the song for which I just entered the melody. Generating it doesn't seem to make any difference.

The style will load, but only the melody plays. I'm thinking I must have changed some setting, or something.

Yes, thank you for your reply about ties. It was very helpful.







Edited by Lesley55 (12/27/17 10:24 PM)

Top
#447564 - 12/27/17 11:24 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
Ahh...

Thanks, Lesley.

Have you checked that the style is actually set as 'Enabled'?

To do this...

1. Right-click on the style name (#1).

2. Select "Style is enabled" (#2).

Note a 'Disabled' style will have an X at the front of its name.


Attachments
disabled style.JPG


_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447573 - 12/27/17 11:55 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
Unfortunately the style IS enabled, but it still won't play.

I made a recording showing how the style will play with no song loaded, but not when I load the song:

https://youtu.be/IZlAeFL2Q_Y


Styles work with other songs I have entered, or with no song, just not this particular one, Ashokan Farewell.

I'm wondering if it something to do with the fact that my external hard drive that I got when I ordered the UltraPack kept cutting out when I was entering the song, and I had to keep restarting BiaB. I just got BiaB and the external drive last week, and there is a loose connection somewhere. But I had the same problems when I put together my other videos, and did not encounter this problem of the style not playing.

Top
#447576 - 12/28/17 12:57 AM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
Originally Posted By: Lesley55
I'm wondering if it something to do with the fact that my external hard drive that I got when I ordered the UltraPack kept cutting out when I was entering the song, and I had to keep restarting BiaB.


Something like this could create a corrupt file.

As a test, try creating a brand new version of the song from scratch (i.e. using "File | New") and then enter (say) 4 bars of notes. Does this work?
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447643 - 12/28/17 09:24 AM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
jford Offline
Veteran

Registered: 12/20/00
Posts: 10447
Loc: Pensacola, Florida
First thing I would do is to use the double USB cable and plug it into two USB slots to ensure the drive is getting enough power (not all USB connections are created equal). If you are still getting intermittent response from the USB drive, then you may need to undo the screws on the drive enclosure and see if there is a loose cable connection (they do sometimes come loose in transit - I've had to do this a couple of times in the past).
_________________________
John

HP Win10Pro-64, 8GB
ASUS Win10Pro-64, 16GB
HP Win7Pro-64, 8GB

H/W-Behringer U-Phoria UMC404HD, Casio Kbds
S/W-BB/RB2018/Sonar/Reaper/Studio One/Samplitude/MixBus/Notion/Finale/Noteworthy/NI Komplete/Halion/Garritan/IK
Web-http://www.sus4chord.com

Top
#447675 - 12/28/17 12:26 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
Noel,
I think the file is corrupt. I saved the file as a midi, then imported the melody and chords into a new file, and it worked. But while I was working on the new file the external drive cut out again and the new file became corrupted. It is very frustrating


jford,
I only have one USB outlet on my computer. I've already done the unscrewing and "reseating", as instructed by someone I spoke with on the phone. I can't do it again because one of the screws is stripped.


I have tried sending email, chat and phoning. The email is not answered, the chat tells me to call technical support. I got through once to technical support this morning. The guy on the phone told me to make sure style was enabled (as Noel suggested further up the thread). Before he could suggest anything else we were cut off. I haven't been able to get through since.

I have read all the trouble shooting stuff. The only thing I haven't done is try a new USB cable. I don't have one, so I guess I will have to go out and buy one--probably cost $20 CND.

I'm worried that I'm being charged for all my phone calls, since I think my plan only has free calling within Canada. Every time I call I get a message saying everyone is busy and to call again. The last few times I have called I get a message saying their mail box is full. It would be better if I just got a busy signal since I wouldn't get charged for the call then.

This is getting so it isn't fun any more.


Edited by Lesley55 (12/28/17 12:27 PM)

Top
#447677 - 12/28/17 12:32 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
Lesley,

Could the reason the USB drive cuts out be due to your antivirus software constantly checking the drive when you read/write?

Regards,
Noel
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447679 - 12/28/17 12:38 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Noel96]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
Maybe. How could I check to see if this is happening?


Edited by Lesley55 (12/28/17 12:38 PM)

Top
#447683 - 12/28/17 12:52 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
What is your antivirus software?
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#447768 - 12/28/17 11:43 PM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
I think the problem might have been the cord connecting the external drive to my computer. I replaced it and so far it has worked.

Top
#448152 - 12/31/17 01:28 AM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Lesley55 Offline
Apprentice

Registered: 12/14/17
Posts: 110
No, it turns out it wasn't the cord. The external drive just seems to be unstable. I have given up and installed the complete program on my work laptop, which has lots of room. I made sure everything stayed perfectly still while it installed from the external drive, and it worked.

But now I have to bring my work laptop back and forth from work every day so I can work on BiaB nights and weekends.

I'll try calling again next week. Do external drives simply not work if you are holding a computer in your lap? The external drive was on a table beside me, but it was attached to my laptop by a cord, and the cord moves when the laptop does.

Top
#448162 - 12/31/17 02:52 AM [Beginners Forum] Re: Song loads a style, but only the midi solo plays [Re: Lesley55]
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 13210
Loc: Australia
Lesley,

Sometimes USB drives are faulty. There have been a couple of instances of this on the forums and PG Music have looked after the people involved.

I suggest you contact Sales staff and send them the URL of this thread.

Regards,
Noel
_________________________
LINKS TO MY BIAB/RB SONGS


Top


Moderator:  Andrew - PG Music, PeterGannon 
PG Music News
Video - Making A Song in Band-in-a-Box® 2018

Ever wonder how to create a song in Band-in-a-Box®? We start off with the basics in our latest video for Band-in-a-Box® 2018!

Windows users: click here | Mac users: click here

RealTracks Patch Update for Windows Users

Band-in-a-Box® 2018 for Windows users can download the latest RealTracks update patch (519) here.

This patch includes some RealTracks audio updates we have made since the release of Band-in-a-Box 2018. 2018 users should be sure to download the latest Band-in-a-Box 2018 update patch (519), as that patch includes the bulk of the fixes for RealTracks released with 2018. This is a larger download than typical because it updates the Vocal Oohs and Aahs RealTracks audio files. There is more information and Audiophile patches available here.

Summary of RealTracks Audio updates:
Improved: There were small issues with the tuning of several Bass styles. This has been fixed for both the original mix and the direct input mix. This affects the following RealTracks:
- Bass, Acoustic, AmericanaSlow16thsByron Ev16 060
- Bass, Acoustic, AmericanaSlow128Byron Sw 040
- Bass, Acoustic, RockabillySwingByron Sw 190
- Bass, Acoustic, BluesyPopByron Ev 100
Improved: Audio glitches have been removed from the ends of phrases in the Vocal Oohs and Aahs RealTracks.

Band-in-a-Box® 2018 for Windows Patch Update Available!

Band-in-a-Box® 2018 for Windows users can download the latest (free) update patch (519) here.

Summary of changes:
Added: Additional dialog available for detailed information in the StyleMaker (fields for memo, examples, and other parameters). These are set in the StyleMaker (more dialog, a button called "Style Memos etc").
Added: Help Video button Added to the Audio Harmony dialog.
Improved: ABC opening improvements with some accidentals, and leadin bars that occur in middle of song.
Improved: Audio harmonies now used Improved algorithms, and can be easily set using N voices above, M voices below (and have additional functions like duplicate melody, and dup. melody octave below).
Improved: Lyrics will be now read from .mid files that used to be karaoke files (.kar) and got renamed somewhere along the line.
Improved: Support for RealTracks that should be transposed only lower (ie heavy metal guitars) and for future Improved metal guitar comping.
Improved: The Audio Harmony Dialog has been rearranged to be more intuitive when using Band-in-a-Box Intelligent Mode.
Fixed: Audio harmonies might be missing some notes.
Fixed: Audio harmonies would be generated with the wrong notes if selecting a range of audio in the middle of the track.
Fixed: Band-in-a-Box might crash on bootup with error "Read Beyond end of file".
Fixed: Band-in-a-Box should show message if the latest VJT application is not installed when the user tries to render videos.
Fixed: File > Open Special > Open Audio was importing audio instead of opening it in a new song.
Fixed: In the Bar Settings window, "Chordsheet and Notation - Start a New Line" should say "Notation - Start a New Line".
Fixed: It was not possible to record audio using WAS audio drivers if "Output always on" was disabled.
Fixed: Misc. RealTracks updates.
Fixed: Quicklist drums picker sometimes showing too many drums in the list.
Fixed: Redundant flash messages were showing.
Fixed: Removing a custom drums from a track would still display Drums as the name of the loop in the track.
Fixed: Rendering audio while there is a region of bars highlighted in the chord sheet might cause a crash.
Fixed: Saving a MIDI file would fail unless saving as type 1.
Fixed: Some 12-key RealTracks were incorrectly set to allow transposition.
Fixed: The Audio Harmony dialog needed some hints.
Fixed: The Audio Harmony dialog was missing the new Band-in-a-Box Intelligent Mode.
Fixed: The VJT application should print out its version number in log files.

Tutorials - How to Install Your Band-in-a-Box® for Mac Hard Drive

When you have your Band-in-a-Box® 2018 for Mac UltraPAK shipped to you on a portable hard drive, there are a few different options for installation. We go over these 3 options with our latest video series:

Option 1: Run Band-in-a-Box® directly from the USB drive only: click here to view.

Option 2: Install Band-in-a-Box® on your computer hard drive, but leave the RealTracks & RealDrums on the USB hard drive: click here to view.

Option 3: Install Band-in-a-Box® and the RealTracks & RealDrums on your computer hard drive: click here to view.

Check out all our Band-in-a-Box for Mac videos here.

Video - Downloading and Installing RealTracks Sets for Band-in-a-Box® for Mac

Have you purchased your Band-in-a-Box® package, and want to make sure you're downloading and installing the RealTracks Sets correctly?

Well, we've created just the tutorial video you're looking for! Band-in-a-Box® 2018 for Mac® - Downloading and Installing RealTracks Sets.

Video link:
www.pgmusic.com/?vid=QndXu8H_IwM

Thoughts on Band-in-a-Box® 2017 - Mac Power Users Discussion

David Sparks and Katie Floyd discuss a variety of topics in their recent episide of Mac Power Users: https://www.relay.fm/mpu/432 - listen all the way through (and laugh along with them - it was a very entertaining episode!), or jump to 1:37:40 where David shares his thoughts on Band-in-a-Box® 2017 for Mac!

Thank you David and Katie!

Polish New Features Video for Band-in-a-Box® 2018 for Windows

Our Polish Distributor, Sound Station, has finished their Band-in-a-Box 2018 New Features summary video (in Polish!) - click here to watch.

We hope all our Polish Band-in-a-Box users find this video helpful - thank you Sound Station!

Forum Stats
27629 Members
50 Forums
52261 Topics
432645 Posts

Max Online: 2434 @ 11/14/17 12:37 AM
Newest Members
Flower, BjornTopo, lauzah, soucychapiro, rH7yB6bGKL

27629 Registered Users
Top Posters (30 Days)
Icelander 182
Noel96 167
Janice & Bud 143
David Snyder 141
Deryk - PG Music 118
rsdean 118
Pipeline 98
Kent - PG Music 97
Ember - PG Music 96
eddie1261 - gone 96
Today's Birthdays
Ifiddler