You need to be logged in to post
Options
Index
#512693 - 12/25/18 09:27 PM [Band-in-a-Box for Windows] No sound from any vst 64 bit
Registered: 03/19/16
Posts: 248
rap429 Offline
Apprentice

Registered: 03/19/16
Posts: 248
after updating to build 609 i no longer can hear anything from a vst in 64 bit version. does not matter if default synth or try to input directly on track. have tried several vst. all work outside biab. tried to reset to factory settings in case I did something I was unaware of but no luck. any suggestions?

(i can get the vstsynthfont64 to work but nothing else, halion, sample tank, kontakt. Midi is getting to the vat but no sound is coming back)


Edited by rap429 (12/25/18 09:49 PM)

Top
#512698 - 12/25/18 10:46 PM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 10/31/08
Posts: 17763
Loc: Australia
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 17763
Loc: Australia
rap,

What audio driver is the BIAB program using? The setting is found under "Audio | Audio Drivers/Settings".

If BIAB is using WAS or ASIO try changing to MME and see if that makes a difference.

Regards,
Noel
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#512749 - 12/26/18 05:06 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: Noel96]
Registered: 03/19/16
Posts: 248
rap429 Offline
Apprentice

Registered: 03/19/16
Posts: 248
Originally Posted By: Noel96
rap,

What audio driver is the BIAB program using? The setting is found under "Audio | Audio Drivers/Settings".

If BIAB is using WAS or ASIO try changing to MME and see if that makes a difference.

Regards,
Noel


I have tried all 3. Seems to be defaulting to WAS on start up

Top
#512755 - 12/26/18 05:47 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 10/31/08
Posts: 17763
Loc: Australia
Noel96 Offline
Veteran

Registered: 10/31/08
Posts: 17763
Loc: Australia
I suspect that the WAS driver could be stopping playback. I'm not sure of this but it's worth testing because some people have had issues with WAS.

If BIAB is defaulting to WAS when you start the program even though you changed it to MME or ASIO, it sounds like you might not be running the program in "Run as administrator" mode. This is different from logging in into Windows as Administrator.

To set "Run as administrator", right-click on the startup shortcut, select properties and activate 'Run as administrator' that's found under the Compatibility tab.

Does this make a difference?

Regards,
Noel
_________________________
LINKS TO MY BIAB/RB SONGS


Top
#512756 - 12/26/18 05:48 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: Noel96]
Registered: 03/19/16
Posts: 248
rap429 Offline
Apprentice

Registered: 03/19/16
Posts: 248
Originally Posted By: Noel96
I suspect that the WAS driver could be stopping playback. I'm not sure of this but it's worth testing because some people have had issues with WAS.

If BIAB is defaulting to WAS when you start the program even though you changed it to MME or ASIO, it sounds like you might not be running the program in "Run as administrator" mode. This is different from logging in into Windows as Administrator.

To set "Run as administrator", right-click on the startup shortcut, select properties and activate 'Run as administrator' that's found under the Compatibility tab.

Does this make a difference?

Regards,
Noel


this does not make any difference. i do hear real tracks just fine. nothing midi.except from vstsynthfont64. all vst work fine in any other program


Edited by rap429 (12/26/18 05:52 AM)

Top
#512757 - 12/26/18 06:04 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 02/05/15
Posts: 7849
Pipeline Offline
Veteran

Registered: 02/05/15
Posts: 7849
I lost audio and sync in VSTi with 609

Top
#512833 - 12/26/18 11:06 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: Pipeline]
Registered: 03/19/16
Posts: 248
rap429 Offline
Apprentice

Registered: 03/19/16
Posts: 248
Originally Posted By: Pipeline
I lost audio and sync in VSTi with 609


Are your saying no sound from midi in the 64 bit version of biab or no sound from the biab vst?

Top
#512834 - 12/26/18 11:10 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: Pipeline]
Registered: 12/27/06
Posts: 399
Loc: Netherlands
rodipoet Offline
Journeyman

Registered: 12/27/06
Posts: 399
Loc: Netherlands
Same problem here: TTs-1 and vstsynthfont64 are working but Halion stopped in build 609
_________________________
Rob de Klerk, Dutch singer-songwriter
https://www.robdeklerk.nl

Biab 2022, Cakewalk, N.I. Komplete 12, Win 10,64, Ozone 9 elements suite, UR22mark2

Top
#512968 - 12/26/18 07:49 PM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 03/19/16
Posts: 248
rap429 Offline
Apprentice

Registered: 03/19/16
Posts: 248
This is a universal problem with build 609. I tried to get confirmation from PG but was not able to get tech support in time. I only know it is universal because I was using 64 bit vsti on 608 and it worked fine but was gone in 609. Same issue as you. Could see the the data triggering the vst but no sound. Tonight I reverted back 608 and sound is back.

I have to say that as a user of BIAB for about 6 years I have full confidence in the company resolving these issues. They always have in my experience. It is an incredible product that has no equal.

What bothers me, as someone who has used the forum as a reference and not really been a participant(bad on my part), is the attitude given by some long term members. While I appreciate the help and your undying support for the product some may want to consider that using a condescending attitude when someone is trying to point out or solve a legitimate problem is not healthy for the users of the product. Yes, it may be user error but why immediately jump to that conclusion?

As the new 64 bit version grows, especially the vst, I believe there are going to be droves of new users that will be able to provide great content and inspiration on the use of BIAB in many ways I have not even thought of. The last thing I would want is these people to be ran off due to a lack of objectivity or an instant rebuttal of "your doing it wrong!"

To all that have responded to my questions and taken time to try and assist I thank you.

Top
#512972 - 12/26/18 08:07 PM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 08/08/06
Posts: 6597
Loc: Pawling New York
Rob Helms Offline
Veteran

Registered: 08/08/06
Posts: 6597
Loc: Pawling New York
I haven’t played with VSTis in BiaB so I can’t comment, however I don’t think all the problems are user error. I think that some is but the rest is bugs, and program issues. Let’s face it there are thousands of computers with all different configurations, and all different drivers, and all different systems and system needs. So making stuff like this is complicated. Still I believe they will sort it out, until then it is hard to wait and try to get things right.
_________________________
Lenovo Win 10 16 gig ram, Mac mini with 16 gig of ram, BiaB 2022, Realband, Studio one Pro latest version, Logic Pro X, Melodyne 5 editor, Presonus Audiobox 1818VSL, Presonus control app, Komplete 49 key controller.

Top
#512978 - 12/26/18 09:55 PM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 02/05/15
Posts: 7849
Pipeline Offline
Veteran

Registered: 02/05/15
Posts: 7849
Originally Posted By: rap429
Originally Posted By: Pipeline
I lost audio and sync in VSTi with 609


Are your saying no sound from midi in the 64 bit version of biab or no sound from the biab vst?


Virtual Instruments that need sync like EZDrummer 2 have no audio or sync.
I think when they fixed the crackling audio problem it stopped the audio in the virtual instruments.

Top
#512979 - 12/26/18 10:04 PM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: Rob Helms]
Registered: 12/25/15
Posts: 82
A_R Offline
Enthusiast

Registered: 12/25/15
Posts: 82
Originally Posted By: RobH
I haven’t played with VSTis in BiaB so I can’t comment, however I don’t think all the problems are user error
You're right, It's not user error, I can open Presonus Studio One, load a midi file, drag several VSTi plugins onto different tracks, assign midi channels, load patches, and be playing a song in under a minute, and do it all day long if I want with no errors, crashes, sluggishness, or abnormal behavior, with BIAB 2019 I can waste an entire afternoon hoping to find some magic combination and sequence of events to get it to work and just end up frustrated after each try, so I just end up using the Sforzando VSTi while in BIAB and export the midi to my DAW where I can using all my VSTis just I was doing with the previous 32 bit versions

Top
#513056 - 12/27/18 07:26 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: A_R]
Registered: 12/27/03
Posts: 17235
Loc: Hamlin NY
MarioD Offline
Veteran

Registered: 12/27/03
Posts: 17235
Loc: Hamlin NY
Originally Posted By: A_R
Originally Posted By: RobH
I haven’t played with VSTis in BiaB so I can’t comment, however I don’t think all the problems are user error
You're right, It's not user error, I can open Presonus Studio One, load a midi file, drag several VSTi plugins onto different tracks, assign midi channels, load patches, and be playing a song in under a minute, and do it all day long if I want with no errors, crashes, sluggishness, or abnormal behavior, with BIAB 2019 I can waste an entire afternoon hoping to find some magic combination and sequence of events to get it to work and just end up frustrated after each try, so I just end up using the Sforzando VSTi while in BIAB and export the midi to my DAW where I can using all my VSTis just I was doing with the previous 32 bit versions


Ditto!

Like you I can also use Studio One without a single problem. IMHO the BiaB VSTi is a half baked product that never should have been exposed to the public. I try to use the VSTi after every update but thus far no success. However for my workflow if I can not assign a sound source in a Studio One track and have the BiaB VSTi access it like every other VSTi can then the BiaB VSTi is useless to me.

The VSTi is great if you are a RT user but not so great for the MIDI side.

YMMV
_________________________
How did the man who made the first clock know what time it was?

64 bit Win 10 Pro, the latest BiaB and RB, Roland Octa-Capture audio interface, a ton of software and some hardware

Top
#513090 - 12/27/18 09:58 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 05/29/00
Posts: 14857
PeterGannon Offline
PG Music Staff

Registered: 05/29/00
Posts: 14857
Rap429,
Yes, that issue affects a few VSTi that use multiple channels, such as SampleTank 64. It will be fixed in next patch build, available by Monday.
_________________________
Have Fun!
Peter Gannon
PG Music Inc.

Top
#513097 - 12/27/18 10:10 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 05/30/06
Posts: 23
darryla Offline
Enthusiast

Registered: 05/30/06
Posts: 23
Is it possible to go back to an earlier version of BB if 609 has already been installed?

Top
#513104 - 12/27/18 10:32 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 05/29/00
Posts: 14857
PeterGannon Offline
PG Music Staff

Registered: 05/29/00
Posts: 14857
Darryla,
Yes, just run the 608 installer from the support page.
_________________________
Have Fun!
Peter Gannon
PG Music Inc.

Top
#513105 - 12/27/18 10:32 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 12/20/00
Posts: 12397
Loc: Pensacola, Florida
jford Offline
Veteran

Registered: 12/20/00
Posts: 12397
Loc: Pensacola, Florida
You can just re-install build 608 over the 609 update, then apply the 610 update when it comes out.
_________________________
John

Laptop-HP Omen I7-10750H Win10Pro 32GB 2x1TB SSD/2TB SATA
Desktop-ASUS-I7-3770 Win10Pro 32GB 3x2TB SATA

BB2022/UMC404HD/Casios/Cakewalk/Reaper/Studio One/MixBus/Notion/Finale/Dorico/Noteworthy/NI/Halion/IK

http://www.sus4chord.com

Top
#513107 - 12/27/18 10:39 AM [Band-in-a-Box for Windows] Re: No sound from any vst 64 bit [Re: rap429]
Registered: 05/30/06
Posts: 23
darryla Offline
Enthusiast

Registered: 05/30/06
Posts: 23
Thx John

Top


PG Music News
How to: Using Playable RealTracks in the Notation Window of Band-in-a-Box® 2022 for Windows

With the release of Band-in-a-Box 2022, we added Playable RealTracks! These allows you to add MIDI notes to the same RealTrack that is playing, either at the same time, or alternating back and forth. This means you can get the RealTracks to play the notes you want at key parts of the performance, either augmenting or replacing what the RealTracks is playing, for the section you want to change.

See how to use and edit these in the Notation Window with our video, Using Playable RealTracks in the Notation Window of Band-in-a-Box®

Fun with Band-in-a-Box® - A Reunion Event: "Life Is Hard"

Getting together and playing music and writing songs is a wonderful way to spend some free time!

Recently, a few of our Forum members did just that... and they made a video to prove it!

Check out what Charlie Fogle, Eddie, Herb, Pat Marr, David Snyder got up to - and how they did it: Fun with Band-in-a-Box® - A Reunion Event: "Life Is Hard"

...hopefully it inspires you to keep the fun in making music!

How to: Replace a RealTrack with a MIDI Track in Band-in-a-Box®

Starting with a RealStyle in Band-in-a-Box®, and want to make one of your tracks a MIDI track? See how this is done using the MIDI Track Picker dialog with our video How to Replace a RealTrack with a MIDI Track in Band-in-a-Box®.

Want to see a quick video tutorial that's not on our Tips & Tricks list? You can post your request to our I want a video that shows me how to .... forum.

Band-in-a-Box® Tuba RealTracks

Today (May 6) is International Tuba Day!

Celebrate your love for the Tuba today - add one of our Tuba RealTracks (available in Sets 143, 162, and 248) played by either Brad Muirhead or Philip Santner.

Already have a Band-in-a-Box® song with a Tuba? Share it here!

How to: Search for RealTracks in Band-in-a-Box®

Looking for a specific RealTrack for your song? See how easy it is to search by keyword or file name when you watch our latest video, How to Search for RealTracks in Band-in-a-Box®.

Want to see a quick video tutorial that's not on our Tips & Tricks list? You can post your request to our I want a video that shows me how to .... forum.

Update Your Band-in-a-Box® 2022 for Windows Today!

Using Band-in-a-Box 2022 for Windows? Great news! We've released a free update that enhances many of the MIDI features and Drum Stems tracks, updates the program manual and documentation, and resolves a few user reported issues.

This free update includes additional enhancements to the DAW Plugin, and updates it to version 4.5.33.

Make sure you download this free update today!

Learn more...

How to: Capturing and Adding a Screenshot to the PG Music Forums

The PG Music Forums is packed with an incredibly active community, always happy to discuss and share Band-in-a-Box tips, help with any questions other users have, and of course share their songs!

Want to know how to add a screenshot to your forum post? Follow the steps in our helpful video tutorial.

Forum Stats
36060 Members
64 Forums
74436 Topics
653231 Posts

Max Online: 2537 @ 01/19/20 07:09 AM
Newest Members
JazzyK, LisaMcCoy, Homerootspm, dreamyguitar, joeyx

36060 Registered Users
Top Posters (30 Days)
AudioTrack 107
MusicStudent 107
MarioD 101
David Snyder 98
Janice & Bud 95
rayc 92
Matt Finley 91
justanoldmuso 85
BabuMusic 85
Scott C 84
Today's Birthdays
kybordr, MoultiPass, PianoAccordionMan