Search Manual

Band-in-a-Box® 2021 for Mac® User's Guide

Chapter 11: Working with Audio

About Band-in-a-Box Audio Files

You can open an audio file by clicking the [Open] toolbar button and selecting Open Audio (wav, aif, mp3, m4a, etc.) from the pulldown menu.

Audio files can also be opened from the File menu with the command Open Special | Open Audio (WAV, AIFF, M4A, MP4).  Open an audio file and play it back at 1/2, 1/4, or 1/8 speed.  This is great for transcribing or analyzing audio.

If MySong.MGU is loaded, and a same named audio file (e.g. MySong.WAV) is present, Band-in-a-Box will open the audio file to the Audio track. This allows third parties to make audio files with chords in them, by making a MySong.MGU and MySong.MP3 pair of files, which will load into Band-in-a-Box yet will have the audio compressed to take up little disk space.  For example, make a teaching set of trombone files for Band-in-a-Box, with audio trombone track, and Band-in-a-Box file with chords, all fitting in a small file size.

About Band-in-a-Box Audio Files

If you have an audio file that wasn't recorded at a fixed tempo, you can change so that the tempos in the audio are all at the same. We call this an "equalization" of the tempos.

Open the Audio Edit window, press the [Marker Mode] button, and select Audio Chord Wizard.

Set bar lines for the whole audio, and press the [Equalize Tempos] button.

Tip: Press the video button on the Audio Edit window toolbar to see how you can set bar lines.

Audio and Utility Tracks

The Audio and Utility tracks can contain your live recording or the imported audio file.

Import Audio File

You can import an audio file (WAV, AIFF, MP3, M4A, etc.) to your song.  To do this, go to menu File | Import | Import Audio and select an audio file.  You can also access this feature from the Audio menu. You will then see the Import Audio File dialog.

Select the destination track, the point to insert the audio file, and the option to merge or overwrite existing audio in the destination track.

If the audio file contains Acid Loop or Apple ® Loop information, the dialog shows an option to set the audio base tempo of the current song to the tempo of the audio file.

Using the Half-Speed Audio feature to help you transcribe a piece of music

Once you open the audio file, open the Audio Edit window and you can see the audio data on the track.

Choose “Half-speed tempo” (control+minus (-) hot key).  control+equals (=) returns to normal tempo.

Highlight the range that you want to hear, and then press [Loop Selected Area].

You can then move around the window to play different sections as you transcribe the recording.

Audio Offset

The Audio Offset feature allows you to synchronize any point of the audio file with bar 1 of the Band-in-a-Box song – usually to sync the audio file with the rest of the song.
Let’s say you have a home recording of a live performance of one of your songs, saved as a WAV file (or MP3/AIFF).  File | Open Special | Open Audio will load the song into Band-in-a-Box.

Now open the Audio Edit window, right-click where you would like to be considered bar 1 and select Mark this point as Bar 1 of the song from the menu.


Then, as the song is playing, use the tap tempo feature (the minus key, pressed 4 times in tempo) to set the tempo of the piece.
Your audio file will then start playing at bar 1 of the Band-in-a-Box song in sync with the audio starting at the place you have marked as bar 1, and the bars will be in sync (approximately in sync, they will drift as the tempo of your live performance varies.)  You can put tempo changes on certain bars to keep it perfectly in sync if you want to.

Audio Settings

The Audio Settings dialog allows you to choose the Audio track type (mono or stereo) for the current song or the new songs, and channels (left/right/both) to record the audio.  The dialog can be accessed from the [Audio] button in the Preferences dialog.

Audio Track Type for THIS song: This allows you to choose either mono or stereo for the Audio track in the current song.  If you change this, then you will be asked if you want to convert the existing Audio track after exiting the dialog.

Preferred default track type for new songs: This allows you to choose either mono or stereo for the Audio track of the new songs.

When opening songs, show message if WAV file not found: If the song you are loading has the associated WAV audio file, the audio file will be loaded to the Audio track.  If you enable this option, then when the associated file is not found, an error message will display.  Uncheck this option if you do not want an error message popup when the WAV file is not found.

[Audio Devices]: This will launch the Audio Devices dialog where you can select input and output audio devices.

If Use default device is checked, Band-in-a-Box will use the device currently selected by your operating system (System Preferences > Sound).  Disable this if you want to manually select a device.

The Avoid connecting to low quality input devices option prevents Band-in-a-Box from connecting to low quality input devices, which are usually Bluetooth devices such as AirPods. These devices might reduce audio output quality if input is active.

Record Audio

You can record vocal or instrument to your song.

Press the [Record Audio] button to open the Record Audio dialog.

The [Audio Options] button will open the Audio Settings dialog, where you can choose the Audio track type (mono or stereo) for the current song or the new songs, and channels (left/right/both) to record the audio.

The [Set Recording Levels] will launch System Preferences > Sound where you can select a recording device and recording levels for that device.

Set the start point for the recording.

You can record from the start of the song, somewhere in the middle, or punch in by choosing a bar and chorus # to start recording.

Select the destination track.

Audio can be recorded to the Audio or a Utility track.

Select the destination track for recording MIDI.

If you also want to record MIDI at the same time, choose the destination track with the “Record MIDI to” option.

Select the punch-in recording option.

Punch-in audio recording allows you to punch-in record or overdub a section of audio. You can select a section to punch-in by highlighting it in the Audio Edit window. You can also hear the existing audio part when you are overdubbing. This is automatic.

Select the overdub underlying audio option.

If you have previously recorded audio on the track, and want to overdub (to add a harmony for example), then you should select the “Overdub underlying Audio.”  It is not essential to select it at this point, since you will get another chance at the end of the recording. Note that the Audio track will not play during record, so you’d have to sing the harmony without hearing the original audio part.

Set the track type (stereo/mono) for recording.

The dialog displays the mono/stereo status of the recording, but if you want to change it, press [Audio Options] button.

Test the recording level with VU Meters.

The meters show the average strength of the signal, with a dB scale, and a clip indicator. Clipping indicates that the signal has overloaded and will sound distorted (clipped).
The green area represents normal levels, while red indicates an overload.
Ideally, the sounds should remain in the green and avoid the red altogether. Unlike analog recording, where it’s good to get a “hot” high signal, digital recordings need to absolutely avoid high levels since any overload of the signal will result in clipping and a ruined.

Press [Record].

Audio recording begins. If you have set the “Leave VU Meter while recording” option, then the VU Meter will open and display during recording so you can monitor the VU meters.

Press the [Stop] toolbar button or press the [Esc] key.

You will then see the Audio Recorded - Keep Take? dialog.

Copy 1st chorus to whole song: If you have recorded only the first chorus, you can choose the option to copy that to the whole song.  This will fill up the whole song with the audio by repeating it as many times as necessary.

Overdub underlying Audio: If this is enabled, any existing data in the track will be merged with the new recording.

Retain audio past last recorded: If this is unchecked, any audio that follows the end of the current take (i.e. recorded from a previous recording) will be erased.

Press the [OK - Keep Take] button if you are happy with the recording.  Then the audio will be added to the Audio track.  You can listen to the result by pressing the [Play] button on the toolbar.  If you are not happy with the results, you can go to the menu Edit | Undo Record Audio and you will be back to where you were prior to the recording.  You can also reopen the Record Audio dialog and press the [Take Again] button to cancel the recording.

Converting Audio Channels

You can easily convert the Audio track from stereo to mono, or vice versa, with the Audio | Edit Audio | Convert Channels (mono/stereo) menu command.  When you convert the channel, you can choose the percentage of each channel.

 

Generating Synthetic Vocal

Your Melody or Soloist track with lyrics can be rendered to a vocal audio track, with built-in support for the popular online vocal synth “Sinsy.”

To access this feature, you should first enter melodies and note-based lyrics to the Melody or Soloist track.  If no lyrics are present, you can still generate a vocal synth using the syllable of your choice (e.g. la la la).

Press the [Vocal Synth] button on the Notation window toolbar or right-click on the Notation window and select either of the Vocal Synth menu items.

With the manual mode, Band-in-a-Box creates a Sound.XML file, which you need to upload to the Sinsy server.  When the Sinsy has generated an audio file with a vocal synth, import it to Band-in-a-Box.

Normally, you would use the auto mode, which does this process automatically for you.  When you choose an auto mode, the Generate Synthetic Vocal dialog will open.

Language: The choice is English or Japanese.  Select English unless your lyrics are entered in Japanese.

Vocalist: Choose one of the female or male vocalists.  If the language is set to English, you can only select an English singer.

Gender Parameters: You can adjust the gender of the voice in a range from -0.8 to +0.8.  Higher values are more masculine.  The default is 0.55.

Vibrato Intensity: This controls the amount of vibrato in the voice.  The range is from 0 to 2.  The default is 1.

Pitch Shifting: This setting will shift pitch in semitones.  The range is from -24 to +24.  A setting of -12 would be down one octave.  The default is 0.

For Melody notes with no lyrics use: If the track does not include lyrics, you can enter a syllable (.e.g. la) to use for notes with no lyrics. (Note: If you select a Japanese vocalist, you need to enter a Japanese syllable.)

When you press [OK], your song will be sent automatically to the Sinsy server and will be rendered to a vocal synth.  This may take a few minutes. When the vocal synth has been generated, press the [Play] toolbar button to hear the vocal synth singing your song!

Editing the Audio File (Audio Edit Window)

This window shows a digital waveform for the Audio track.  In this window, you can select, play, and edit the audio data.

To open this window, press the [Audio Edit] button, or go to menu Window | Audio Edit Window.
Tip: Shift+clicking on the button will open the movable and resizable window.

The numbered scale at the top of the window indicates bars and beats, with a full height vertical division for each bar and a short vertical line for each beat or quarter note.  Bars with part markers also include the part marker letter with the bar number (e.g. 1a, 9b).  The decibel (dB) scale is shown at the right of the window.

A region of the audio data can be selected by clicking and dragging the mouse.  To expand or reduce the selection, hold down the shift key while clicking on the desired new boundary.  The selection can be played using the [Loop Selected Area] button.

There are some handy features for stretching regions of audio.  To use these features, select a region of audio, then click & drag while holding the command key.  Clicking within the region and dragging to somewhere else within the region will stretch both halves of the region (one will become longer, and the other will become shorter).  Clicking outside the region and dragging to somewhere in the region will shorten the region.  Clicking within the region and dragging to somewhere outside the region will lengthen the region.  These features can be useful for quantizing beats, or correcting mistakes in a recording.

To select a region, you can shift+click on the end point to easily select a large area.
- Click on the starting bar.
- shift+click on the ending bar.

Following hotkeys are available.
- home will move the cursor to the beginning of a track.
- end will move the cursor to the end of a track.
- shift+home will move the left cursor of the selected region to the beginning of a track. If no region is selected, this will select a region from the cursor to the beginning of a track.
- shift+end will move the right cursor to the end of a track. If no region is selected, this will select a region from the cursor to the end of a track.

This button zooms out horizontally to display a larger area of the audio.  Zoom focus will be on audio cursor. You can also zoom with the mouse wheel, which focuses on the mouse cursor.

This button zooms in horizontally to display a smaller area of the audio.  Zoom focus will be on audio cursor. You can also zoom with the mouse wheel, which focuses on the mouse cursor.

This will zoom out as far as possible, showing the entire audio track.

This will zoom in to the sample level, which displays individual sample points (digital audio), and the curve of the waveform (analog audio).  This is band limited interpolation which represents the waveform as it will be heard in reality once converted from digital to analog.

These buttons change the height of the waveform display.  [+] increases the height of the waveform display, [-] decreases the height of the display.

Enable this to snap to the closest beat when selecting a region of audio.

This will start playback and loop the selected region.

This will select the whole audio track.

This button lets you access various features for editing the selected audio region and also allows you to change your settings for the Audio Edit Window.

Note: The editing functions are available for the Audio and Utility tracks only.

Silence - This will silence the audio.

Amplify - This will increase or decrease the volume of the audio by a chosen number of decibels.  A positive value will make the audio louder, or a negative value will make the audio quieter.

Normalize - This will increase or decrease the volume of the audio in order to make the loudest point match the chosen decibel level.  For example, if you choose -6 decibels and the loudest point in your audio is -8 decibels, then the audio will be increased by +2 decibels.

Fade In - This will gradually change the volume of the audio.  The audio will begin silent, and then gradually increase to full volume at the end.  You can change the type of amplification curve in the Audio Edit Settings dialog.

Fade Out - This will gradually change the volume of the audio.  The audio will begin at full volume, and then gradually decrease to silence at the end.  You can change the type of amplification curve in the Audio Edit Settings dialog.

Paste (Mix) - This will mix the audio from the clipboard with the existing audio instead of overwriting it.  You will be given the option to set the percentage of the existing audio to keep and the pasted audio to mix in.

Paste (Insert) - This will insert the audio from the clipboard to the current location, instead of overwriting the existing audio.  The audio to the right of the insertion point will be shifted to make room for the new audio.

Delete - This will delete the selected region of audio.

Insert Silence - This will insert silence at the cursor.  The duration of the silence inserted will be equal to the duration of the selected region.

Convert Channels - If the audio is stereo, this will convert it to mono.  If it’s mono, this will convert it to stereo.  You will be given the option to set the percentage of the left and right channels to include.

Transpose - This will transpose the audio by a specified number of cents.

Harmonize - This will add harmonies to the audio.

Transcribe - This will transcribe the audio to the Melody or Soloist track as MIDI data.

Fix Tuning - This will automatically correct the tuning according to the key of your song.  For example, in the key of C, if a C# is detected then it will be transposed down to C or up to D depending on which one is closer.

Fix “Sour” Notes - This will automatically correct notes in polyphonic audio. When chord is played with multiple notes at once, this feature can fix certain notes within that chord so that the note won’t clash with the chord progression or other tracks. In the dialog, you can select one of the rules for the auto-fix.

 

Rules: This defines the rules for the auto-fix. You can see the description for each rule in the above area.

Process MIDI: If this option is enabled, any MIDI note on the track will be processes as well. Notes within the selected region will be changed according to the chosen rule.

Sensitivity Level: Increasing the sensitivity level will cause weaker notes to be detected. Decreasing it will cause weaker notes to be ignored and unaffected by the auto-fix.

Transient Level: Increasing the transient level will make transients (e.g., beats like plucking sounds or drum hits) louder. Decreasing it will make transients quieter.

Smoothing ms: This is the length of time that notes will take to change in milliseconds. Increase this for instruments that sound better with slower bending between notes like vocals or pedal steel. Decrease for rigid sounding instruments like piano.

Pitch Correction: This will correct the tuning of notes. For example, a guitar might have one string out of tune, and notes played on that string will be pitch corrected.

Extract Stems - This will extract stems from the selected region. Individual instruments such as bass, drums, and vocals will be extracted onto their own separate Utility tracks. This feature requires a stem splitter application to be installed.

Generate - This allows you to generate RealTracks.

Settings - This allows you to customize the appearance of the window.

This button will open the Audio Edit Settings dialog, which allows you to customize the appearance of the window.


Draw interpolation: If this is enabled, the curved lines will be drawn between sample points, representing real sound.
Interpolation quality: This is the accuracy of the interpolation drawing.
Default fade type: Choose the type of curve used for the automatic/manual cross-fading. “S-Curve” is good for most situations and is the best for very short fade durations since it will not introduce a noise.
Auto cross-fade regions: When a region of audio is being modified or replaced, the beginning and ending of the region will be cross-faded with the existing audio to make a smooth transition. This applies to Cut, Paste, Silence, Amplify, and Normalize.
Default duration in samples for cross-fades: This is the number of samples that will be used for audio cross-fading. This duration will be shortened automatically when processing very short regions of audio.
Synchronize insert/delete edits with MIDI on track: If this is enabled, then when inserting or deleting regions of audio, MIDI on the same track will be shifted accordingly to keep the MIDI and audio in sync.
Mouse wheel zooms to edit cursor instead of mouse pointer: If this is enabled, the mouse wheel will zoom to the edit cursor instead of zooming to the mouse cursor.
Center screen to edit cursor when zooming: If this is enabled, the edit cursor will scroll to the center of the window when zooming with the mouse wheel. This is only applicable if “Mouse wheel zooms to edit cursor instead of mouse pointer” is enabled.

This button allows you to change the Marker Mode.  When you select the Audio Chord Wizard or UserTracks mode, the markers will be visible and editable.

Each marker mode displays editable markers for various purposes.  The Audio Chord Wizard mode shows bar line markers for making a tempo map, and the User Track mode shows bar/beat markers for defining rules in your UserTrack.

Audio Chord Wizard

The following buttons will appear if you select the Audio Chord Wizard marker mode.

In this mode, the first task is to locate bar lines in the audio so that the Audio Chord Wizard can detect chords accurately and the audio will play in sync with the Band-in-a-Box song.

  You can add bar lines with the [Add Bar Line] button or with the L key on your keyboard.  A bar line will be placed at the audio edit cursor or at the playback cursor if the song is currently playing.

When you start entering bar lines, the program automatically sets the tempo of the song to the tempo of the first bar of the audio.

Once the tempo of the first bar is set, the program automatically moves the location of the first bar of audio over so that the visual space of the count-in bars is visible.

After you’ve added the bar lines, if you adjust the first or second bar and the tempo of the first bar changes accordingly, the program automatically changes the tempo of the song to match.

  The [Add/Delete Bar Lines] button menu has options to add bar lines based on your song structure or tempo.  You can delete all the existing bar lines or only the ones within the highlighted region.

  If Auto Marking is enabled, then Band-in-a-Box will automatically add and arrange bar lines based on the bar lines you have added manually.  The “auto” bar lines will show in light blue, and the “user” bar lines will show in purple.  You can change these colors in the Audio Edit Settings dialog if you want.

  If Auto Analysis is enabled, then Band-in-a-Box will re-analyze the chords in the audio whenever you add or move a bar line, or when you edit the audio data.  Keep this setting disabled if you prefer to set all bar lines first (i.e. establishing tempo), and then analyze the chords when you are done.

Bar lines can be moved with the mouse.  Just click and drag the thumb control at the bottom.  If you move an “auto” bar line, it will become a “user” bar line. 

You can also right-click on the thumb control to get a context menu with options to switch a marker type (“user” or “auto”), delete the bar line, or set the time signature for the bar.  The menu also shows you the tempo of the bar, based on the time signature of the bar and the position of the next bar line.

When you add or move bar lines, Band-in-a-Box will automatically make a tempo map, so your song is in sync with the Audio track.

Any changes you make in the Audio Chord Wizard mode are undo-able.

  Use the [Analyze] button to analyze the chords in the audio.  The chords detected in the audio will be written into the Chord Sheet.  You don’t need to do this if you have “Auto Analysis” enabled, but you might want to if you have erased or made changes to the chords in the Chord Sheet.

When you open the Chord Sheet, you will see the Audio Chord Wizard has entered the chords and the tempo map.

If Transcribe MIDI Track is checked, the wizard will send the transcribed MIDI notes to the Soloist track for further analysis by the user (via Piano Roll or Notation window).  Note that this is a “snapshot” view every 8th note of the pitches present, not an attempt at polyphonic transcription.

This will remove tempo changes by stretching regions of audio so that the tempos are all equal.

The wheel button opens the dialog for customizing the chord analysis.

Song Key: Choose the key in which to look for chords. For example, if the song key is set to G major, the wizard will search for chords in the key of G major. These G major chords are further specified by the Chord Preset.
Chord Preset: Choose which set of chords to look for, from the chosen key.
Pre-tune audio: Auto-tune the track to a reference of A440 before performing the chord analysis. This is useful for songs that were recorded slightly out of tune.
Minimum chord duration 1 bar: This forces the wizard to choose only 1 chord per bar (i.e., no half-bar chords).

Audio Harmonies

The audio harmonies include following features.
- Harmonizing the audio with up to 4 voices.
- Correcting out-of-tune notes.
- Transcribing the audio to notation.

Harmonize the Audio Track

First, import an audio file or open a Band-in-a-Box song file with audio.  Then, go to the menu Audio or Harmony, and select Audio Harmonies, Pitch Tracking, Fix Tuning (Audio Edit).

 or    

This will open the Audio Edit window and the Audio Harmony dialog.

Tip: If the Audio Edit window is already open, press the [Edit] button on its toolbar and select Harmonize to open the Audio Harmony dialog.

Choose one of the 3 harmonizing modes.

1) The “Chords” mode will harmonize the audio based on the chords in your song.  Choose a type of harmony from the “Harmony type” option.  Choose either the intelligent mode, which allows you to select the number of voices and other options, or one of the harmony presets.  Then, set the volume and the stereo balance of each voice in the harmony. When you select the intelligent mode, you can also use the “Melody Double” option to make one of the harmony voices double the original melody.  For the 2-part harmony, you can make the harmony voice 3rds or 6ths above/below the original melody depending on the “Voice above” setting or a combination of 3rds and 6ths with the “Duet Voicing” setting.

2) The “MIDI” mode will add voices to the audio, based on melodies in the source track.  You can choose the number of voices (up to 4 voices), and the volume and the stereo balance of each voice.

3) The “Fix Tuning” mode will analyze the track and corrects out-of-tune notes in the selected region according to the key of your song.  Normally, you do not want to keep out-of-tune notes after the fix tuning is done, but you can mix the original voice with the fixed one by moving the volume slider for “Original Melody” to the right.

Render Song to Audio Track

This will convert all tracks in the current song into audio data and move them to the Audio track.  To use this feature, right-click on the Master radio button, and select Render Song to Audio Track (and mute tracks) from the menu.

 

If you want to restore the tracks, right-click on the Master radio button and select Un-Render Song from Audio Track (Enable tracks, erase audio track).


Live Help
Contact Info

PG Music Inc.
29 Cadillac Ave Victoria BC Canada V8Z 1T3

Sales: 800-268-6272, 250-475-2874,+ 800-4746-8742*
* Outside USA & Canada where International Freephone service is available. Access Codes

Tech Support: Live Chat, support@pgmusic.com

Chat online Online now

Need Help?

Customer Sales & Support

Phones (Pacific Time)
1-800-268-6272 1-250-475-2874
Live Chat
OPEN Online Ordering
24/7
OPEN Forums, email, web support
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.