Search Manual

Band-in-a-Box® 2019 for Windows® User's Guide

Chapter 10: Working with MIDI

Band-in-a-Box has two built-in MIDI sequencer tracks.  They are named the Melody and Soloist tracks, but they can be used to record any MIDI part you like – such as drum overdubs or layered accompaniments.  MIDI can be recorded in Band-in-a-Box

  • Live with a MIDI keyboard, MIDI guitar, or MIDI wind controller.
  • In step time by entering notes in the Notation window with the mouse.
  • Using the Wizard feature to “play” notes with your QWERTY keyboard.
  • Importing a pre-recorded Standard MIDI File into the Melody or Soloist.

Recording Live in Real Time

You can punch in/out, do unlimited overdubs, record directly to the tag or the ending, and start recording from any bar. 

To record live using your MIDI keyboard, guitar, or wind controller, click on the [Record MIDI] button, press the [Ctrl]+[R] keys, or choose the menu option Melody | Edit Melody Track | Record Melody.  The Record MIDI to Melody Track dialog will appear.

Select “Soloist track” if you want to record onto the Soloist track.

Tip: If you select the “Overdub underlying melody” option in the Record Melody dialog, you will hear the underlying melody while recording.

Pressing this button will launch the MIDI Recording Filter.  The Record Filter supports all MIDI controllers including the sustain pedal. You can record any type of MIDI information to the Melody or Soloist tracks and use the Record Filter to select what types to include.  Choosing Options | Preferences | [Rec.Filter] for recording will also launch the Record Filter dialog.

Press [Record] or the [Ctrl]+[R] keys again to begin recording.

Stop recording by pressing the [Esc] key or the spacebar, or by clicking the [Stop] button.  The OK – Keep Take dialog will open.

[OK - Keep Take] (yes/no) saves the take you just recorded.  Remember that it’s easy to fix small glitches in the Editable Notation window or in the Event List editor.

[Take Again] lets you quickly reject a take and start the recording again.  Press the [A] key to do this with a keystroke.

[Cancel] ends the recording session; nothing is saved.  To start again, press the [Record MIDI] button or the [Ctrl]+[R] keys.

Copy 1st chorus to whole song - If you have recorded one chorus of the song, checking this at the end of the recording will copy the same recording to all of the choruses.

Overdub Underlying melody - You have the option to merge the recording with the existing melody.  If there is no underlying melody, this option will be grayed out.

Retain Melody past last recorded - You have the option to erase any melody after the last recorded melody note or keep it.  Use this feature when you want to punch out at the end of a take.

Recording to an external sequencer

Many people use Band-in-a-Box in live situations.  If you are unable to bring your computer with you, a good alternative is a hardware sequencer or a keyboard with a built-in sequencer that reads Standard MIDI Files.  To transfer songs to the Sound Brush, follow these simple steps:

  • Make a MIDI file of the song by pressing the button.
  • Either save the file directly to a floppy disk or copy it to the floppy from your hard drive.
  • The Sound Brush is then able to read the IBM formatted disk with MIDI files on it.

Entering Notes Manually

You can enter melody notes directly to the track in the Notation window in either the Editable Notation Mode or the Staff Roll Mode.

  Enter the Editable Notation mode from the Standard Notation screen with a single mouse click on the Editable Notation button.  In the Editable Notation mode, you can enter, move, and edit notes and rests using standard mouse techniques – point and click, drag and drop, and right-click to open the Note Edit dialog.

Confirmation dialogs prevent accidental entry of a duplicate note (same pitch near same time) and accidental entry of a very high or very low note (large # of ledger lines).

Once you have some melody entered, you can copy and paste chunks of it as you would in a text document.  To copy and paste notation, highlight an area of notation by dragging the mouse over the region.  Then select Edit | Copy.

Click on the place where you want to paste to (by clicking at the time line on top of the notation window) and then choose Edit | Paste.  You can specify a precise paste location in the Paste Melody dialog.

Recording with the Play Along Wizard Feature

This is a very helpful feature if you don’t have a MIDI keyboard but you want to record with a “live” feel.  Use the Wizard to record notes from the computer’s QWERTY keyboard for a track that’s more natural than step time.  Here’s how it works.

1. Click the [MIDI] toolbar button and check MIDI Keyboard Wizard Enabled.
 

2. Press [Ctrl]+[R] keys to record.

3. As the song plays, play the melody on any keys on the bottom two rows of the QWERTY keyboard, in the rhythm of the melody.  The “wizard” notes won’t be the correct melody of course, but don’t worry about that as you record.  When you’re finished, look in the Notation window.  You will see the wrong notes in the right places with the correct durations.

4. Drag the notes (with the left mouse button) to the correct place on the staff.  You will hear the notes play as you drag them, and the names will show in the note name box.  For sharps, flats, and naturals, hold down the Shift key, Ctrl key, or Alt key respectively.  You will end up with a melody that sounds like it was recorded live, without the rigid feel of tracks entered in step time.

Tip: If you have the Wizard “On” the spacebar won’t stop playback.  You need to press the Esc key to stop playback when the Wizard is on.  This is to prevent stopping the song if you mistakenly hit the spacebar while playing the Wizard.

Melody Wizard

For songs with melodies, there are QWERTY keys (Enter, \ , T, 6) that trigger notes from the melody as the song is being played.  Other keys trigger 1-4 approach notes from below or above.  The notes can be recorded, to humanize a stiff melody with better timing, and approach notes also useful for sight reading, rhythm practice, or to perform.  This feature works with harmonies

  • Melody notes: T, 6, Enter, \
  • Same Melody note: 5
  • Approach notes: QWER  YUIO
  • Octave set: 1, 2, 3

MIDI notes also work (if Preferences [Transpose] is set to “Allow Melody Wizard on THRU part”).

  • Octave set: E(40), F(41), G(43)
  • Melody notes: F(53), G(55)
  • Approach notes: B(47), C, D, E   A, B, C, D(62)

To use the Melody Wizard, make sure the Keyboard Wizard is enabled. This will also enable the MIDI Wizard on the QWERTY keys.
 

If you also want to use the Melody Wizard on MIDI notes, go to Preferences [Transpose] and enable “Allow Melody Wizard on THRU part” in the Settings for transposing songs when loaded or “Do it Now” dialog.

*.MGU

Then, choose a song that has a Melody track.

Mute the Melody track by right-clicking on the Melody track (Alt+8).

Play the song.

ENTER or \

As you play the song, you can use the Enter key or the \ key (or T or 6 above the T) to play Melody notes.

W,E,R,T

These will be approach notes up to the melody.  You can start on any note.

Q,E,R,T

Starting on a Q instead of W will use wider voicings for approach notes.

I,U,Y,T

These will be approach notes down to the melody.  Start on any note.

O,U,Y,T

Starting on an O instead of I will use wider voicings for approach notes.

MIDI Keyboard Wizard

The Wizard can also be used with a connected MIDI keyboard.  The keyboard wizard always plays correct notes and is a fun way to play along with Band-in-a-Box.  The MIDI keyboard also sends volume information (unlike the QWERTY keyboard), so is a better choice if you have a MIDI keyboard connected.

This feature is accessed with the [Transpose] button in the Preferences dialog. To turn on the Wizard to allow MIDI control, choose “Use Wizard for THRU part.”

Make sure that the Keyboard Wizard feature is enabled.
 

Now, when you play notes on the MIDI keyboard (during playback), they will get remapped to chord tones.  C/E/G/Bb notes played on a THRU keyboard will be mapped to chord tones, and D/F/A/B will be passing tones.  This scale - C D E F G A Bb B - is considered the “Bebop” scale, useful for playing over dominant 7th chords.

The Wizard is useful for entering notation quickly.  If you can’t play piano well, play the wizard in the correct rhythm.  The pitches will be wrong, but you can fix them in the Editable Notation window later, and the durations, volume, and timing are already correct.

Melody/Soloist Sequencer

There are 2 tracks in Band-in-a-Box to add your own recordings.  These are the Melody and Soloist tracks.  Normally you would want a single part on each of them.  But, since MIDI information can have separate channels, it is possible to store 16 separate parts on each of the Melody and Soloist parts.  For the following discussion, we will assume that you’re using the Melody track, but the same functions are available for the Soloist.  When the Melody track has been set to “Multi(16)-Channel” we refer to this as “Sequencer Mode.”

Also, for this discussion we will assume that you have a multi-channel track loaded in.  Let’s load a MIDI file, using File | Open MIDI file, and choosing a MIDI file like C:\bb\Documentation\Tutorials\violet.MID.

If you want to use the 16 separate parts for the Melody track, you need to set the Melody Track type to “Multi-Channel.”

This is done from the Melody menu or with the [Sequencer] button.

Now, when you are in this multi-channel mode, output from the Melody part will be on whatever MIDI channel the information is stored on and will not be using the Melody MIDI Channel.

  You can examine the track to see the channels by looking at the event list, which you can access by pressing the [#] button on the Notation window.

You will notice that the information in the event list is color coded by channels for multi-channel tracks.  For example, channel 7 is pink, and channel 10 is gold.

If you open the Lead Sheet window, you will see the entire MIDI file displayed on separate tracks of notation.  Since this represents 6 separate tracks (in the case of violet.MID), this is likely “too much information” for you to read, unless you are a symphony conductor.

 To customize the notation display for sequencer mode, press the lead sheet options button, and see the settings for Multi-Channel Tracks.

Choose the “CUSTOM channels play/display” option and press the [Set] button to launch the Sequencer Window.  Then you can customize which channels will play and display.


In the example picture, we have set Channel 2 (Bass) and Channel 4 (Trumpet) to show on the notation, and have set all of the channels to play (to hear them).

For a specific channel, (e.g. channel 3: piano), we see the following information.
- Channel 3: Acoustic Piano (this is the patch name found on the track).
- 842: There are 842 events in the track, usually every note is an event.
We have customized the piano track so that it can be heard (play=true), but not seen in notation (Show=false).

There is a small button at the right of the track line that allows you to delete/ rechannel or merge the channel with another channel.

You can also change the patch (instrument) for that track by using the instrument patch combo box.

So now that we’ve customized the display, we are seeing the bass and trumpet on the notation,and hearing the entire track.

Removing All Tracks Except Melody from A MIDI File
One use for the Sequencer mode is to load in a MIDI file, and then delete all of the channels except the melody, so that you can allow the Band-in-a-Box rhythm section to provide the accompaniment.
To do this, open the Sequencer window, and use the Edit pull down menu to delete all tracks except the melody. 

Once you have done this, you don’t need the Melody | Track Type to be multi-channel anymore, so you should set it to be Track Type [Single Channel], so that it will be like any other Band-in-a-Box song and use the Melody channel for playback.

Recording Your Own Parts to The Melody Sequencer
Normally, you would record your parts to the Melody, and not be concerned about what MIDI channel they are using, because Band-in-a-Box uses the Melody channel (usually channel 4) for this.
But if you have set the Track type to be multi-channel, the output on the Melody part will be whatever channel is stored in the tracks.
  When you record a Melody part and the track type is set to multi-channel, the “Keep Take” dialog will have a selection for the channel that should be used for the recording.
  Also, make sure that you have “Overdub underlying melody” checkbox set, or you won’t hear the other melody parts during the recording.
Example: Recording 4 Separate Counter Melodies on The Melody Track
So, if you want to record, for example, 4 separate parts to go along with a Band-in-a-Box song, you should do the following.
1. Set the Melody track to Multi(16)-Channel (Sequencer)

2. Record a Melody part.  At the end of the recording, pick a channel for the part that is not already used by Band-in-a-Box.  BB uses channels 2-10, so channels 11 to 16 are available for your counter melody parts.
3. Repeat step 2 by recording additional melody parts.
4. Assign patches to the Melody parts using the Sequencer Window.
  

Importing MIDI Files

Importing MIDI Files to the Melody or Soloist Tracks

Standard MIDI files can be read in to the Melody or Soloist tracks from MIDI files or from the Windows® clipboard.  You can read in all of a MIDI file, or selected channels and a specific range of bars.  Use one of the following two commands.

  • Melody | Edit Melody Track | Import Melody from MIDI File – to select a MIDI file from disk using the Windows® Open File dialog.
  • Melody | Edit Melody Track | Import Melody from Clipboard - when the MIDI data is already copied from another program to the Windows® clipboard.  The clipboard option will be grayed out if there is no MIDI data in the clipboard.

Once chosen, the Import MIDI File - Options dialog opens.

Import Which Channel(s)?
You need to know which channel(s) of your MIDI file the melody is on.  You then select these channels for Band-in-a-Box to read-in.  If you select all of the channels, Band-in-a-Box will read in all of the channels and merge them to the Melody track.  You can import and play the complete file on the Melody track if the Track Type is set to Multi (16) -Channel in the Melody menu.

# bars to offset from start of MIDI file
If you want to start reading from the beginning of the MIDI file, select 0 as the offset.  If you want to start at bar 32, for example, select an offset of 32 (bars)

How Many Bars to import?
Leave this setting at the default of 1000 to read-in the entire file (unless it’s longer than 1000 bars!), or set it to the number of bars that want.

# blank bars to insert at beginning
This will insert blank bars into the Melody track.  Remember that Band-in-a-Box normally has a 2 bar lead-in count.  If your MIDI file has no lead-in, then you need to set this to = 2 to compensate for the 2 bars of lead-in.

Include notes early by (120 PPQ)
If you’re reading in a MIDI file starting at bar 5, it would be annoying to have a note that was played 1 tick earlier than bar 5 left out of the MIDI file that is read in.  To include it, you can set this, and the note will be read in.

Include continuous controllers and pitch bend / Patch changes / Lyrics
If you don’t need these items, you can save space by not importing them.

Merge with Existing Data on the track
ou can choose to merge the imported data with the existing data in the destination track.

Import to the Melody with the MIDI Chord Wizard

You can open an entire MIDI file into Band-in-a-Box using the MIDI Chord Wizard.  The chords will be auto-interpreted by the Chord Wizard and the MIDI file will play and display on the Melody track.  A “silent” style will be loaded so you will only hear the MIDI file.  When the file is saved, the extension will be MGX, allowing you to easily identify the songs that contain entire MIDI files.

The MIDI Chord Wizard is opened from the File | Import Chords from MIDI File menu item.  In the Interpret Chords from MIDI file dialog, select the “Open ENTIRE MIDI File to Melody” radio button, and then click on [INTERPRET CHORDS NOW].

The chords will be interpreted and written to the Band-in-a-Box Chord Sheet and an “X” will appear in front of the style name, indicating that the style is silent.

Press [Play] to hear the MIDI file play on the Melody track.

Additional Options for Melody/Soloist Track

Choose Melody | Edit Melody Track | Quantize, Time Adjust | Time Shift Melody.  This will move (slide) the melody a certain number of ticks.  There are 120 ticks per quarter note.  For example, to give the song a more laid-back feel, shift the melody about 10 ticks ahead.

In the same submenu, choose Insert Beats or Delete Beats to insert or delete beats in the Melody.  For example, to insert 2 bars in the melody at bar 5, choose Melody | Edit Melody Track | Quantize, Time Adjust | Insert Beats, select bar 5, and select 8 beats (2 bars) to insert.

Intelligent Humanize of Melody and Soloist Track

Quantize routines can leave the music sounding stiff and unmusical.  Some routines attempt to humanize a part by adding “randomization,” which rarely has the desired effect since humans don’t randomly change timing or volume.  Band-in-a-Box uses intelligent humanization routines to humanize a melody from one feel to another, from one tempo to another, and vary the amount of swing to 8th notes.  The results are very musical, with natural sounding melodies.

Let’s look at some of the parameters found under Humanize.

In this example, Melody | Edit Melody Track | Quantize, Time Adjust | Humanize Melody was selected.  The window for Humanize Soloist is the same.

As you can see, we have broken down the Humanize effect into 5 main categories: tempo, lateness, 8th note spacing, legato, and feel. The best way to learn how these parameters combine is to try them (you can always press the UNDO button if you don’t like the results.)For example, try changing the tempo of a song to see the changes that this will make to the 8th note spacing and lateness.  Press the [Quantize NOW] button to apply your changes to your song.

Tip: Often, when musicians play at faster tempos they play the swing 8th notes closer together and a little later.

We feel that these categories are straightforward and you should have no trouble achieving the desired results.  Remember to apply such parameters as Legato and Lateness sparingly, then press the Quantize NOW button to apply your changes to your song.

Editing the Melody Track

Event List Editor


You can edit events including all MIDI events and lyric events using the Event List Editor.  It can be launched in several ways.

  • In the Melody menu, choose Edit Melody Track | Step Edit Melody.
  • In the Soloist menu, choose Edit Soloist Track | Step Edit Soloist Part.
  • In the Window menu, choose Notation | Event List Editor.
  • In the Notation window, by pressing the event list button [#]. The dialog will display events on the selected track in the Notation window.

The list uses a color coding based on Event Type, Channel, Duration, or Velocity.

If the color coding is based on “Event Type,” the list shows the event as follows.
- Notes starting near the beat boundary are dark pink.
- Notes starting on the off-beat are light pink.
- Patch changes are cyan.
- Controller changes are yellow.
- Pitch Bends are grey.

The Event List Editor allows you to modify, insert, and delete notes.

  • Double-click on an event to edit it (or press the [Edit] button.)
  • [Insert] puts an event before the current event.
  • [Append] puts an event at the end of the track.
  • [Delete] removes an event.
  • [Show] exits the dialog and highlights the note in the Notation window.
  • [Play] plays the current event moves the next event.
  • [Update] redraws the notation screen.
  • [Edit Lyrics][Edit Soloist][Edit Melody] selects which track to edit.

Event List Filter

There is a filter for the Event List Editor, allowing you to quickly spot all patch changes.

For example, to examine the patch changes on the Melody track, choose “Use Event Filter,” and then press the [Filter…] button.

In the Event List Filter, select the type of information you want to display.  In this case, it is program changes (patches) only.

The track will then display with the program changes only.

The Event Type to Edit dialog opens when either the [Insert] or [Append] buttons are pressed in the Event List Editor.
This dialog allows you to select which type of event to insert or append - note, controller, pitch bend, etc. – and then opens the selected edit dialog.

Notation Window Editing

You can often get better results by using the Notation window to edit notes instead of the Event List window.  To do this, open the Notation window in either Editable Notation or Staff Roll Notation mode.  In both of these modes, notes can be dragged and dropped with the mouse.
For precise note editing, right-click on the note you want to edit and choose “Edit Note” in the contextual menu.  This opens the Note dialog where all of the parameters of the note can be addressed.

Piano Roll Window

The Piano Roll window enables precise graphic editing of note timing and duration.  You can also graphically edit note velocity, controllers, program changes, channel aftertouch, or pitch bend.

The Piano Roll may be opened as a movable window, which floats above the Band-in-a-Box main window or opened embedded in the same position as the Chord Sheet/Notation panels in the Band-in-a-Box main window.

Note: A demo song PianoRollDemoSong.MGU in the C:\bb\Documentaion\Tutorials\Tutorial – BB 2005 Demo folder contains some MIDI data which can be seen in the Piano Roll window.

Track Selection

 
Select the track - Bass, Piano, Drums, Guitar, Strings, Melody, or Solo.

Note: These buttons show the initial of the automatic track labels ([H] for Harmonica, [F] for Flute, etc.) when you check "Auto-Generate Track Labels" option in the Preferences dialog.  If you prefer the "default" labels (B/P/D/G/S/M/S), uncheck this option.
Note: The tracks other than the Melody and Solo tracks will be overridden every time you press the [Generate and Play] button, so if you want to retain your edits, press the [Play] button instead or freeze the track.

Snap-to-Grid

Selections, Inserted Notes, or Edited Notes will snap to the grid spacing.  If you do not want snap-to-grid, select [NONE] in the drop-down menu.

Note Duration

Set the default duration of new inserted notes.  It is easy to mouse-edit a note’s duration after a note is inserted, so it is usually sufficient to select a typical note duration that makes sense for your purposes and then mouse-edit the duration of “exception” notes after they are inserted.

View/Insert Channel

If a track contains multiple channels, “All” will display MIDI events on all channels.  Otherwise, select the channel that you need to see.  If “All” is selected, new MIDI events are inserted on the Band-in-a-Box track’s assigned channel.
Except for perhaps multi-channel Guitar tracks, Band-in-a-Box plays all track events on the assigned track channel.  Therefore, in almost all cases, the channel of track events does not matter.
For instance, if the Melody track is set to transmit on channel 4, all events on the Melody track will be sent on channel 4 regardless of the “actual channel” of each track event.

Ghost Notes

  When viewing a single channel, notes on other channels can be ghost-displayed in light gray.  This is useful when viewing multi-channel tracks.

View/Edit Graphic Data

Determine what graphic data to view or edit in the bottom Graphic Event panel.  Choose Velocity, Controller, Program Change, Channel Aftertouch, and Pitch Bend.  If “Chan” is not set to “All,” only the selected channel events will be displayed.

Keyboard Pitch Panel

1. Click on a single note of the keyboard to select all notes ofthe clicked pitch.
2. Click-drag on the keyboard to select all notes in a pitch range.
3. Shift-click-drag to add another set of notes to the selection.
4. Ctrl-click-drag to invert a pitch selection.
For instance, you could drag C5 thru C6 to select an octave of notes.  Then Shift-click C3 to add all C3 notes to the selection.  Then Ctrl-click C5 to remove all C5 notes from the selection.

Cursor Location Info Panel


The Info Panel shows the cursor’s Bar:Beat:Tick and MIDI note or controller value (depending on the cursor location).  In cursor locations where a value would be nonsensical, the status text values are blank.
For instance, in the Note panel, Bar:Beat:Tick and Pitch are displayed.  In the Ruler panels, only Bar:Beat:Tick is displayed.  In the left Piano panel, only Pitch is displayed.  In the Graphic Event panel, Bar:Beat:Tick and Event Value are displayed.

Chords Ruler and Note Time Ruler

There are two top rulers.  The top Chords Ruler displays chords and the Playback Location Indicator.  The Note Time Ruler displays bars and bar subdivisions.  When zoomed-in, more subdivisions are displayed.  When zoomed-out, fewer subdivisions are displayed.

Click or drag in the Chords Ruler to set the Insertion Point (useful if you wish to use the menu Edit | Paste (Ctrl+V) to paste into the Piano Roll).  If a song is playing, a Chords Ruler click will stop playback.
Double-click in the Chords Ruler to start playback at the indicated bar.  You can also set the Insertion Point and then tap Ctrl+F to start playback at the desired location.

Splitter Bar

A vertical Splitter Bar sits between the Note and Graphic Event panels.  If you want to maximize the Note Panel to see more notes, drag the Splitter down.  If you want to maximize the Graphic Event Panel for more accurate event editing, drag the Splitter up.

Zoom Buttons

These buttons will zoom the Note Panel vertically.

 Select notes and click this button.  The vertical pitch range and horizontal time range will adjust to fill the Note Panel with the selected notes.
 This will return to the previous view range after zooming in on a region.
 This will zoom the window so that all track notes are visible at a glance.
 These buttons will zoom the window horizontally.

Note Panel


Horizontal bars represent notes.  Notes can be selected, edited (start time, pitch, duration), inserted, and deleted.
Overlapping notes are displayed in bold aqua color, making them easy to identify.  Overlapped notes can be eliminated from the right-click menu in this window.

Note Selection
Selected notes are red.

1. Click on individual notes to select.
2. Shift-click on individual notes to add to the selection.
3. Ctrl-click on a note to invert (toggle) its selection.
Click on white space and then drag a rectangle around notes to select a group of notes.

Note: Only notes that start within the rectangle are selected.  If the left edge of a note is not inside the rectangle, it will not be selected.

1. Shift-drag a rectangle to add another group of notes to the selection.
2. Ctrl-drag a rectangle to toggle the selection of the notes in the rectangle.
Notes can be selected with the Note Time Ruler.

1. Click-drag on the Note Time Ruler to select a time-range of notes.
2. Shift-click-drag to add a time-range of notes to the selection.
3. Ctrl-click-drag to invert the note selection of a time range.
For instance, you could drag to select all notes in bars 2 thru 7.  Then you could Ctrl-drag to toggle off note selections in bar 4.  By using the Shift and Ctrl keys, very flexible time selections can be made.
Edit Note Time Stamp (start time)

Hover the cursor over the left of a note.  An east-west cursor appears.  Then click-drag the note to a new time (horizontal dragging).

If multiple notes are selected and you want to move all selected notes, use Shift-click-drag.  Otherwise, a click on a note will deselect the previous selection, and it will only select/edit the clicked note.

Edit Note Pitch
Move the cursor over the middle of a note.  A north-south cursor appears.  Then click-drag the note pitch (vertical dragging).

If multiple notes are selected and you want to transpose all selected notes, use Shift-click-drag.  Otherwise, a click on a note will deselect the previous selection, and it will only select/transpose the clicked note.

Edit Note Duration
Move the cursor over the right of a note.  A right-arrow cursor appears.  Then click-drag the note duration (horizontal dragging).

If multiple notes are selected, and you want to change duration of all selected notes, use Shift-click-drag.  Otherwise, a click on a note will deselect the previous selection, and it will only select/edit the clicked note.

Insert a Note

Hold the Shift+Ctrl keys.  The cursor becomes a pencil.  Click where you want the note and it is inserted with a duration from the “Dur” drop-down menu, and on the channel selected by the “Chan” drop-down menu.

If “Snap” is enabled, the note is inserted at the nearest grid boundary.  For instance, if the snap-to-grid setting is a quarter note, inserted notes will snap to the nearest quarter note boundary.

There are many on-screen visual cues to assist cursor positioning.  The Cursor Position Time Markers in the Time Rulers can assist time positioning.  The Cursor Pitch Marker in the Keyboard can assist pitch positioning.  The Cursor Location Info Panel gives precise time and pitch info.  Also, the Note Panel has time grid markings, and pitch accidentals are marked in light gray on the background.

Delete a Note
Select a note (or a group of notes), then tap the Delete key.  Alternately, select notes, right-click, and choose Delete Selected Events in the pop-up menu.
You can also use an eraser tool.  Hold the Shift+Ctrl keys and hover the cursor over a note.  When the cursor becomes an eraser, click on a note to delete it.  If multiple notes are selected, all selected notes will be deleted.

Graphic Event Panel


This panel graphically displays non-note MIDI events, which are specified in the Chan, View/Edit, and Controller Type controls.
Zero-value events are drawn as small hollow squares, to make them easy to identify.
When graphically inserting controller and pitch bend events, the event density is adjustable from one event per 1 tick up to one event per 30 ticks.
With events such as pitch bend or controllers like modulation and sustain, it is important to take care to end a “gesture” with a zero-value event.  Otherwise, subsequent notes will be affected, with an unwanted “hanging” permanent pitch bend, permanent vibrato, or sustain pedal locked down.
Velocity
  Set the “View/Edit” control to “Velocity,” and the velocity events will display in the Graphic Event panel.

Control

If “View/Edit” is set to “Control,” the Controller Type control becomes visible.  The Graphic Event Panel will display the chosen controller type.  If “Chan” is not set to “All,” only the selected channel events will be displayed.

Select “11 Expression MSB” in the Controller Type control.

The Expression controller is recognized by most modern synthesizers including most General MIDI synths.  However, some older synths do not recognize this controller.  Expression is an alternative to “7 Main Volume MSB.”  Use the Expression controller for individual tracks and reserve the main Volume controller for overall track loudness.  That way, you can use the Band-in-a-Box main window Volume controls without affecting individual notes in the track.
In the example shown, the intro flute ostinato pattern fades in, and then fades back out, via the expression controllers.  These events were entered with the Line Tool.  Notice that before the trumpet comes in, there is a single expression event of value 127, to kick the loudness up to normal.
Single controllers are inserted by moving the mouse cursor to the desired position and then clicking the mouse button.
Select “1 Mod Wheel MSB” in the Controller Type control.

The Modulation controller is not firmly defined, but it is usually a Vibrato or Tremolo effect (especially in General MIDI synths).
Play the demo song and watch how Modulation has been added to some notes to add Vibrato.  It is usually best to use a modest amount.  With graphic edits, too much is almost always too much!
Program Change

Set the “View/Edit” control to “Program,” and the program changes will display in the Graphic Event Panel.  The demo song intro has a flute program change.  Then the first chorus is trumpet, the second chorus is flute, and the third chorus is soprano sax.

Channel Aftertouch

Set the “View/Edit” control to “ChnAfter” and you can see the Channel Aftertouch events in the Graphic Event Panel.

Pitch Bend

Set the “View/Edit” control to “Pitch Bend.”  Play the demo song and watch how a few pitch bends have been inserted to “scoop” some note attacks, “sting” the middle of a note, or “fall off” some note releases.

Event Selection
Selected Events are red.

Graphic events can be selected with the Graphic Event Ruler.

The Graphic Event Ruler will only select non-note events.  In addition, it will only select the type of MIDI events specified in the Chan, View/Edit, and Controller Type controls.  When you make a Ruler Time selection, ONLY THE VISIBLE events in this time range are selected.  Other MIDI events in this time range are not selected.

Graphic Events Editing Modes
There are two modes for editing graphic events.
Add Mode: This will add/subtract the same amount to all selected events.
Scale Mode: This will scale the selected events.  Select one or more Graphic Events and move the mouse over one of the events.  Shift-drag vertically, and the events are scaled in a proportional fashion.  Large-value events are scaled more than small-value events.  This keeps the same shape of a gesture but makes the gesture bigger or smaller.
Note Velocity Line Tool
  With the Add Mode, note velocities will exactly match the slope of your drawn line.

  With the Scale Mode, the Line Tool will shape the dynamics, but note velocities are scaled to follow the approximate shape of your drawn line.  With this mode, you can insert a velocity fade, or change the velocity of a region, while preserving the Velocity dynamics of the music.

Edit Event Value
Move the cursor over the top half of an event.  A north-south cursor appears.  Click-drag vertically to scale event values.

To scale a selected group of events, Shift-click-drag vertically on one of the events in the selection.

Edit Event Time
Move the cursor over the bottom half of an event.  An east-west cursor appears.  Click-drag horizontally to slide the event in time.

To slide a selected group of events, Shift-click-drag horizontally on one of the events in the selection.

Insert Events
Line Tool
With no modifier keys, the “white space” cursor is a Line Tool.  Move the cursor to white space and then click-drag to draw a line.  When the mouse button is released, a series of events are inserted which follow the line slope.

To avoid choking the MIDI stream, the maximum event density is one event per 10 ticks.  Repeated events of the same value are not inserted.  Therefore, long gradual Line Tool fades have a lower density than short extreme Line Tool fades.

The Spacing controls how often the events are drawn.  For example, if this is set to 30, events will be spaced apart by 30 sticks.


Spacing=1


Spacing=30

Pencil Tool
Move the cursor over white space and hold the Shift+Ctrl keys.  A Pencil Tool appears.  Shift+Ctrl-drag to freehand-draw a curve.  If you don’t get the curve quite right on the first pass, just keep holding the mouse button and move the mouse back-and-forth to draw your desired freehand curve.  When the mouse button is released, a series of events are inserted to follow the freehand curve.

To avoid choking the MIDI stream, the maximum event density is one event per 10 ticks.  Repeated events of the same value are not inserted.  Therefore, many freehand curves have a fairly low density.
Delete Events
Make a selection of events with the Ruler or by clicking on events.  Then tap the Delete key.  You can also right-click and choose Delete Selected Events in the pop-up menu.
You can also use an eraser tool.  Hold the Shift+Ctrl keys and hover the cursor over an event.  When the cursor becomes an eraser, click on an event to delete it.  If multiple events are selected, all selected events will be deleted.

Right-Click Contextual Menu

The pop-up menu can be accessed by right-clicking on the notes, graphic events, or any of the rulers.

Undo: Duplicates the Band-in-a-Box Edit | Undo (or Ctrl+Z) action.
Delete Selected Events: Deletes any selected events (highlighted in red).  This can also be accomplished by tapping the Delete key.
Select All Notes and Graphic Events:  If the “Chan” combo box is set to “All,” this item will select ALL EVENTS on ALL CHANNELS (all events in the track).  Otherwise, ALL EVENTS are selected which match the CURRENT MIDI CHANNEL.
Select All Note Events (Of Current Channel): If the Chan combo box is set to “All,” this item will select ALL NOTES on ALL CHANNELS, but it will not select any non-note events.  Otherwise, ALL NOTES are selected which match the CURRENT MIDI CHANNEL.
Select All Note Events (Of Current Channel): If the “Chan” combo box is set to “All,” this item will select ALL GRAPHIC EVENTS of the CURRENT VIEW/EDIT TYPE on ALL CHANNELS.  Otherwise, ALL GRAPHIC EVENTS of the CURRENT VIEW/EDIT TYPE are selected which match the CURRENT MIDI CHANNEL.  For instance, you could select all channel 4 modulation events, then Delete, to easily remove all of those events from the track.
Cut: Copy selected events to the clipboard and then remove them from the track.  Can also be accomplished with the menu Edit | Cut (or Ctrl+X) action.  If you wish, it is possible to cut from the Piano Roll, and then paste into the Notation window, or vice-versa.
Copy: Copy selected events to the clipboard can also be accomplished with the menu Edit | Copy (or Ctrl+C) action.  If you wish, it is possible to copy from the Piano Roll, and then paste into the Notation window, or vice-versa.
Paste - Replace: If no events are on the clipboard, this item is dimmed. The paste occurs at the time location of your right-click.  Move the mouse cursor to the desired insert location.  Right-click on the Note Panel, Graphic Event Panel, or any of the Rulers.  Then choose this item from the pop-up menu.  Any previous event types in the paste range which match event types in the clipboard are removed before the clipboard data is added to the track. If the “Chan” combo box is set to All, pasted events keep their original (copied) MIDI channel.  Otherwise, the pasted events will be re-channeled to match the “Chan” combo box.
Paste - Merge: If no events are on the clipboard, this item is dimmed. The paste occurs at the time location of your right-click.  Move the mouse cursor to the desired insert location.  Right-click on the Note Panel, Graphic Event Panel, or any of the Rulers.  Then choose this item from the pop-up menu.  Events from the clipboard are merged with existing data in the track. If the “Chan” combo box is set to All, pasted events keep their original (copied) MIDI channel.  Otherwise, the pasted events will be re-channeled to match the “Chan” combo box. The feature can also be accomplished with the menu Edit | Paste (or Ctrl+V) action (to match the Notation window, which also uses a merge style of pasting).  Before using the main menu Edit | Paste (or Ctrl+V), first make sure the insertion marker is set to your desired paste time location. This is easy to do.  Just click or drag in the Chord Ruler to place the insertion marker where you want it.  Then tap Ctrl+V.
Re-Channel All Events to the Track Channel (Ch = xx): Re-channel all notes and graphic events (the entire track) to the MIDI Output channel assigned for this track.  Sometimes this can come in handy to bring some “sanity” into Piano Roll editing. For instance, though the default Melody output channel might be channel 4, meaning that Band-in-a-Box transmits any events in the Melody track on channel 4.  The actual events in the Melody track might be channel 1, or a mixture of several channels. For ordinary playback or note tweaking, it doesn’t matter if the event channels are “mixed up,” as long as you have the view channel set to All.  But if you wish to use Paste - Replace, the Paste - Replace function is smart enough not to “stomp on” a track’s events that differ from the channels of the clipboard MIDI data.  So if you force all events to the track channel, the Paste - Replace function will always replace appropriately.
Re-Channel Selected Events to the Track Channel (Ch = xx): Re-channel only the selected events to the track channel.
Re-Channel Selected Events to the View Channel: When editing a multi-channel guitar part or editing an imported multi-channel MIDI file, this command may be useful.  Beware that it might initially appear confusing.or instance, one might set the view channel to ALL, and make a selection (intending to set these events to Ch 12).  Then set the view channel to 12, and of course the selected events disappear (if the events had some other MIDI Channel).  But then when you invoke “Re-Channel Selected Events to the View Channel,” the MIDI events will reappear on the Piano Roll.
Eliminate Overlapped Notes:Overlapped notes are displayed in bold aqua color, making them easy to identify.  Selecting this menu command will remove the overlap.

Live Help
Contact Info

PG Music Inc.
29 Cadillac Ave Victoria BC Canada V8Z 1T3

Sales: 800-268-6272, 250-475-2874,
+ 800-4746-8742*

Tech Support: 866-983-2474, 250-475-2708, + 800-4746-8742*

* Outside USA & Canada where International Freephone service is available. Access Codes

Chat online Online now

Need Help?

Customer Sales & Support

Phones (Pacific Time)
1-800-268-6272 1-250-475-2874
Live Chat
OPEN Online Ordering
24/7
OPEN Forums, email, web support
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.