Search Manual

Band-in-a-Box® 2020 for Mac® User's Guide

Chapter 12: Tools, Wizards, Tutors, and Fun

Video Window

Note: This feature is not implemented yet in the current 64-bit build of Band-in-a-Box 2020 but is available in the current 32-bit build and should be available in a future patch build of the 64-bit build.

You can load videos that you have already downloaded from YouTube or elsewhere into Band-in-a-Box Video Window.  This window is a great tool for learning and composing.  For example, if you have a video music lesson that you want to learn but the riffs are too fast, you can slow down the video in Band-in-a-Box.  The stretching quality is excellent, allowing you to decrease or increase the tempo by an incredible amount.

Press the Views - [Video] button and select Video Player from the menu to launch the Video Window and then click on the [Open] button on its toolbar.  You will then see a menu of options.

All the Import options allow you to add a video to your existing project, while the Open options will start a new project.  You can choose to extract both the video and the audio of the file, just the video (no audio), or just the audio (no video).  Many video formats are supported, including MP4, M4V, MOV, MPG, MPEG, and AVI.

 

Use the transport control at the bottom of the window to play, stop, or move to a position in the video.

  As the song plays, you can slow down the video, and the audio will slow down and stay in sync.  The quality of the audio at slower or faster tempos is great.  The video slowdown range is 6-800%.  This is a great tool for transposition.  You can select a range in the Chord Sheet window and use Transport - [Loop] button to loop a section of the video at a lower tempo, for example.

  This button steps back 2 seconds.

  There is a [Full] button to make the video full screen, and the Esc key will go out of the full screen mode.

DAW Plug-In Mode

There is a “plug-in” mode for your favorite sequencer (GarageBand, ProTools, Logic, Nuendo, Reaper and more).  With the plug-in mode, Band-in-a-Box is open as a small window, and acts as a plug-in for your favorite DAW sequencer, so you can drag and drop MIDI and audio (AIFF, M4A) tracks from Band-in-a-Box to your favorite sequencer.

The DAW Plug-in mode is a mode within the regular Band-in-a-Box program.  This mode allows you to transfer tracks or parts of tracks, to other DAW sequencers or Finder.

  You can enter and exit the plug-in mode easily by pressing the small [DAW] button on the main toolbar.

When you do this, the window size of Band-in-a-Box becomes small. (You can resize it to the size/position that you want, and it will remember that).

Drag and Drop

This is the Drop Station where you drop a track after dragging it to get an audio or MIDI version of the track.  There are 4 quadrants, and they are labeled according to the types of files that will be made by the drop: Audio Files (WAV, M4A, AIFF) or MIDI file (MID).

When you drop the track onto the Drop Station, you will see an orange color, indicating that the track is accepted, and the file is being prepared.

When the file is ready, the Drop Station turns green.  You can now drag it to your favorite DAW or Finder.

When you drop the track to the [+], you are presented with a dialog, where you can choose a file format and other render options.

You can choose a format (WAV, AIF, M4A, or MID) of the file.

When you have dragged the Master radio button, you can select the “Separate files for each track” option.

If “Normalize audio files” is selected, the file will be normalized.  Normalizing boosts the volume to a maximum level without distortion.  Most professional music tracks are normalized.

If you want to add ACID information (tempo, key, and time signature) to the WAV file, check the “Acidize WAV files” option.

The dialog also has settings for bit depth (16, 24, 32 bit) and sample rate (44.1, 48.0, 96.0 kHz).

There is a right-click menu allowing you to copy the resulting file to a favorite folder, open the favorite folder, start/stop the DAW Plug-in mode, upload to Dropbox and more.

Dragging Master Track

  If you want the entire performance, drag the Master button to the Drop Station.  Then when it turns green, drag to a DAW or Finder.

  It will be dragged as audio, unless you have set it to be dragged as MIDI in Plugin Settings dialog.

  By default, a single file is dropped, with the entire arrangement, but if you want all tracks transferred as separate files, you can enable this option in Plugin Settings dialog.  (Note that your DAW will need to support dropping of multiple files and will typically put them on consecutive tracks.)

Dragging a Single Track

  If you want a single track transferred, drag that track button to the drop station.  (For example, drag the Bass button to transfer the bass track.)  Then when the Drop Station turns green, drag that to a DAW or Finder. 

If the track is a RealTrack (green), then it will be transferred as Audio.  If it is a MIDI track (yellow), then it will be transferred as MIDI.

  If you want MIDI tracks transferred as audio, you can set this in Plug-In Options dialog.

Tip: If you hold the SHIFT key during the drag, then the file will be dropped as MIDI (if it is a MIDI track), regardless of the setting in Plug-in options.
Tip: If you hold the CONTROL key during the drag, then the file will be dropped as AUDIO (if it is a MIDI track, it will be rendered to audio using Apple® Synth), regardless of the setting in Plug-in options.

Dragging Selected Regions

If you would like to transfer only a portion of the performance, you can do this by selecting the region in Band-in-a-Box and then dragging the track button to the Drop Station (don’t drag the selected region).  You will then get just the selected region dragged to a DAW or Finder.

Dropbox Support

You can easily drag/drop files from Band-in-a-Box directly to your Dropbox folder, or save audio to Dropbox, without leaving the main Band-in-a-Box screen.   To do this, drag a track (or the Master button for all tracks) to the Drop station, and when it turns green, you can right-click on the [Drop] button, and choose “Copy files to Dropbox Folder.”

Plug-In Options

To get to the DAW Plug-in options, press the [Plugin] button and choose the menu item “Options for DAW Plug-in” or go to the Preferences dialog and click the [DAW Plugin] button.

You will then see the plug-in options.

Allow Drag and Drop (default=true) - If disabled, the Drag and Drop feature will not work.  There shouldn’t be a reason to disable this.

Drag individual MIDI tracks as audio (default=false) - When enabled, the chosen MIDI tracks get converted to audio, using Apple® Synth.

Drag Combo (Master) track as audio (default=true) - When enabled, the entire arrangement gets converted to audio, using Apple® Synth.  If not selected, the MIDI tracks in the arrangement get transferred as MIDI, in a single file.

Drag Combo as separate tracks (default=false) - If set to true, when dragging the Combo button, the drop will result in multiple files, one for each track.

Drag Audio as - You can choose the format of the audio files that will be created.

Show DragDrop Folder - This will show Finder where the dropped files reside.  When you drag a file to your DAW, the file is created on disk and stored in the DragDrop folder inside the Band-in-a-Box folder.

Erase DragDrop Folder - This will erase (trash) all the dragged audio/MIDI files in the DragDrop folder.  Note that some DAW sequencers require these files to reside permanently (or until you use a “consolidate” command in the DAW), so don’t erase these files unless you are sure that they are not needed.

Note the tips for forcing MIDI or forcing audio when dragging.  Holding shift forces MIDI, holding control forces audio.

“Woodshed” Tempo Feature

When practicing (or “woodshedding”) a tune, it is useful for the tempo to speed up every time the section loops or the song restarts from the beginning.  To use this feature, press the [Practice] button on the toolbar, select the menu item Woodshed (increasing) tempo practice and set the “Woodshed tempo” value in the Tempo Woodshedding dialog.

For example, if you set the value to 5, the tempo will speed up by 5 each time the song (or a highlighted section) loops to the beginning.  The idea is that you start off with a slow tempo, playing the part perfectly, and keep this up as the song tempo increases.

When you press Stop, the tempo reverts to the original tempo.

There are four modes to the woodshed tempo field. 

  • “Up only,” which is getting faster each loop “forever,” well until tempo = 500, which is BB’s maximum tempo.
  • An “up then down” mode that goes up by [a settable increment] up to a [settable maximum] and then starts going down by the increment back to the original where it restarts.  For example, a song with a tempo of 140, if you set the tempo to increase by 5, to a maximum increase of 100, the song will go from 140,145,150 etc. to 240, then go to 235,230… back to 140 and cycle again.
  • An “Up then Reset” mode, that goes up in increments up to the settable maximum, then resets to the original and starts again.  For example, a song with a tempo of 140, if you set the tempo to increase by 5, to a maximum increase of 100, the song will go from 140,145,150 etc. to 240, then go to 140 and start again.
  • An “Up and stay at Max” mode that goes up until the maximum and stays there.

Modes 2 and 3 are analogous to a “treadmill workout,” with programmed changes in speed.

Playalong Wizard

The Playalong Wizard is an intelligent play along feature that uses your QWERTY keyboard to play along with Band-in-a-Box.  This also allows you to record to the Melody or Soloist track without an external MIDI keyboard, and can even be used to trigger the Soloist Wizard.  Also, play along using the Wizard can use the harmony feature, so you can play along live from your QWERTY keyboard in 4-part Saxophone harmony for example.

Turning the Wizard On/Off

Click on the [MIDI] toolbar button and check MIDI QWERTY Keyboard Wizard.  You can also select the Wizard Playalong option from the Song menu, or press Option+W.

 

Playing the Wizard

The Wizard keys are only active during playback.  The active keys are the lower 2 rows of the keyboard.

Changing Instruments / Settings for the Wizard

The Wizard is a play along instrument, so is treated just like the THRU instrument.  Changing Instruments, Volume, Reverb, etc. for the Wizard is therefore the same as for the THRU instrument.  (i.e., Click on the THRU button, then select instrument etc.)  You can record the Wizard and it will use THRU harmonies if selected.

Play Regular Notes

There is an option to play regular “non-smart” notes, for those of you up to the task of poking out actual melodies on your QWERTY keys.

In the Song menu, toggle Wizard Uses ‘Smart’ Notes off (unchecked) to have the Wizard provide you access to a chromatic scale, and toggle on to have Band-in-a-Box provide you with notes based on the chord/key of the song.

Soloist Wizard

Additionally, you will find another great Wizard feature in the Soloist menu; the Solo Wizard.  Toggling this option “on” enables the Soloist Wizard.  As you play notes on the MIDI or QWERTY keyboard, the program will play “correct” notes in the style of the current Soloist!  This means that you can play a perfect solo every time, simply by pressing any key on your MIDI keyboard or QWERTY keys.

Beyond impressing your friends with your newfound improvisational prowess, this feature has practical implications as well.  For example, you can concentrate on practicing your solo phrasing and playing “in time” without concerning yourself with which notes to play (Band-in-a-Box will supply the correct notes: see the next section for details.)

Recording Using the Wizard

To record the Wizard, press the [Record MIDI] button to record, and play the Wizard.  This will be recorded.  You can use the feature of recording the Wizard to enter music without a MIDI keyboard that doesn’t sound as stiff as most music entered in step time.  This is how it works:

  • Press the [Record MIDI] button.
  • As the song plays, play the melody that you want on any Wizard key, using the same key for each note, in the rhythm of the melody.  The Wizard notes won’t be the exact melody, but don’t worry about that as you record.
  • When you are finished, go to the Notation window.  You now have the notes with the correct durations and times, but the wrong pitches.
  • One by one drag the notes up to the correct melody note, holding down the shift, control, and key for sharps, flats, and naturals respectively.  You will then have entered a melody that sounds like it was recorded from a keyboard, without the stiff sound of a melody entered in step time!
Note: If you have the wizard on, the SPACEBAR will not stop playback.  You need to press ESCAPE to stop playback if the Wizard is on.  This is because people mistakenly hit the spacebar while playing the wizard, which would stop the song inadvertently.

Scales Wizard

When students are practicing Jazz tunes, it is helpful to see the scales that are used for each chord.  The Scale Wizard allows you to easily generate these scales, which appear as notation on the Soloist track.  Options include Instrument Range, Patch Selection, Jazzy Mode (will use Lydian dominant scales for some 7th chords), and Diatonic Mode (keeps scales relative to the song key). 

The Soloist | Scales menu items allow you to generate scales for a certain song, or auto-generate them for all loaded songs.  View the scales in the notation or the on-screen guitar and piano.

Scale Direction - When playing a new scale, either start on the root of the scale (going up) or start with the closest scale tone (moving up or down).  The two modes are:
1. Ascending.  The scales will always start on the root that is in the octave above the Lowest Note that is set and will play in ascending order.
2. Walking.  The scales will start on the nearest scale tone to the previous tone that was played.  The notes will ascend to the Highest Note setting, and then descend (by scale tones) down to the Lowest Note.

Write to Track - Choose Melody or Soloist track to write the scales to.

Lowest Note is the lowest note to play for any scale.  C5 (note 60) is middle C.

Highest Note is the highest note to play, used when the scale direction is up and down (Walking).

Scale Tones Diatonic to Key Signature - If diatonic, minor scales will be according to the key (VI minor is Aeolian etc.).  Otherwise, all minors will be Dorian.

Use Jazz Scales - If set, will use Lydian b7 chords.  Chords like Bb7 in the key of C will have Lydian b7 scales (i.e. A#4 in the scale).

Patch - Send this MIDI patch (instrument) when playing the scale.

[Defaults] sets to default values.

[OK- Generate Scales] writes the scales to the notation of the selected track, Soloist or Melody.

Audio Chord Wizard

The Audio Chord Wizard can be accessed from the Audio Edit window.

First, import an audio file with the Audio menu item.

 

Next, select Audio Chord Wizard from the Audio menu.  This will open the Audio Edit window with the Audio Chord Window marker mode selected.

 

Alternatively, you can press the [Audio Edit] button, and when the Audio Edit window opens, press the [Marker Mode] button on its toolbar and select Audio Chord Wizard from the menu.

The first task is to locate bar lines in the audio so that the Audio Chord Wizard can detect chords accurately and the audio will play in sync with the Band-in-a-Box song.

  You can add bar lines with the [Add Bar Line] button or with the L key on your keyboard.  A bar line will be placed at the audio edit cursor or at the playback cursor if the song is currently playing.

  The [Add/Delete Bar Lines] button menu has options to add bar lines based on your song structure or tempo.  You can delete all the existing bar lines or only the ones within the highlighted region.

  If “Auto Marking” is enabled, then Band-in-a-Box will automatically add and arrange bar lines based on the bar lines you have added manually.  The “auto” bar lines will show in light blue, and the “user” bar lines will show in purple.  You can change these colors in the Audio Edit Settings dialog if you want.

  If “Auto Analysis” is enabled, then Band-in-a-Box will re-analyze the chords in the audio whenever you add or move a bar line, or when you edit the audio data.  Keep this setting disabled if you prefer to set all bar lines first (i.e. establishing tempo), and then analyze the chords when you are done.

Bar lines can be moved with the mouse.  Just click and drag the thumb control at the bottom.  If you move an “auto” bar line, it will become a “user” bar line. 

You can also right-click on the thumb control to get a context menu with options to switch a marker type (“user” or “auto”), delete the bar line, or set the time signature for the bar.  The menu also shows you the tempo of the bar, based on the time signature of the bar and the position of the next bar line.

When you add or move bar lines, Band-in-a-Box will automatically make a tempo map, so your song is in sync with the Audio track.

Any changes you make in the Audio Chord Wizard mode are undo-able. 

  Use the [Analyze] button to analyze the chords in the audio.  The chords detected in the audio will be written into the Chord Sheet.  You don’t need to do this if you have “Auto Analysis” enabled, but you might want to if you have erased or made changes to the chords in the Chord Sheet.

When you open the Chord Sheet, you will see the Audio Chord Wizard has entered the chords and the tempo map.

If “MIDI to Soloist Tracks” is checked, the wizard will send the transcribed MIDI notes to the Soloist track for further analysis by the user (via Piano Roll or Notation window).  Note that this is a “snapshot” view every 8th note of the pitches present, not an attempt at polyphonic transcription.

This will remove tempo changes by stretching regions of audio so that the tempos are all equal.

MIDI File Chord Interpretation Wizard

Many people who play music by ear think of songs in terms of “Chords and Melody.”  However, many MIDI files lack chord symbols, so they become difficult to learn without the user having to figure out the chords in a time-consuming process. 

Now you can open any MIDI file in Band-in-a-Box, and Band-in-a-Box will automatically figure out the chords of the song for you.  It automatically analyzes the MIDI file, figures out where the Bass, Piano, Melody, and other tracks are, and then figures out the chord changes for the song.  The chords are written onto the Chord Sheet like any other song.  This allows you to quickly learn how to play a song from a MIDI file - just read it into Band-in-a-Box and you’ll see the chord symbols, and then learn the melody!  You can also read tracks into the Melody and Soloist tracks.

To interpret MIDI chords, first blank the Chord Sheet, by choosing File | New.  Then select the menu item File | Import | Import Chords from MIDI File or press the keystrokes control+option+I.  This launches the Chord Wizard dialog. 

  Press the [Open (Change)…] button to select the MIDI file that you’d like to import.  If you select the “All” checkbox, then all files will be displayed.  If you deselect the “All” checkbox, then only filenames ending with .MID will be displayed.

Note: Any Band-in-a-Box song can quickly be converted into a MIDI file by pressing the [.MID] button, or with the keystrokes Option+S, or from the menu File | Save Special | Save Song as MIDI File.  The song will be saved in the Band-in-a-Box folder with the same file name, but the file type will be “.MID.”  For example, the Band-in-a-Box song Violet.MGU becomes the MIDI file Violet.MID.

  Once you have selected the file, you can press the [INTERPRET CHORDS NOW] button.  When you do that, the chords will be interpreted from the MIDI file, and written onto the Chord Sheet. 

Prior to pressing the button, you might want to make some custom settings.

  When you load in the MIDI file, Band-in-a-Box automatically interprets many things from the MIDI file for you.  Normally you’d want this to happen, but if for some reason you’d prefer to make the settings yourself, you can set “Auto Interpret settings from MIDI file” to false.

The settings that are determined automatically for you are:

  • The key signature of the song (MIDI file).  Some MIDI files contain a special event that states the key signature of the file, but most don’t.  For the ones that don’t, Band-in-a-Box analyzes the tracks and makes a “best guess” at the correct key signature for the song.  It usually gets it right, but if it’s wrong, it’s likely out by a 4th or 5th interval.
  • Tempo, time signature.
  • The channels used for the Bass part, Piano (comping) parts.
  • The channels used for the Melody parts.
  • The number of bars in the song to import, including the number of lead-in bars in the song.

Once you have loaded in the MIDI file, (by pressing the [Open (Change)…] button), and assuming that you have the “Auto Interpret” set to true, you’ll see that the dialog displays the settings that the Chord Wizard has found in the MIDI file for the key signature and channels used for the song.

Let’s work with an example song called Violet Song.MID.

This should be included in your Songs folder.  For this example, we are going to interpret the chords of this MIDI file and read them into Band-in-a-Box.

Start with a blank Chord Sheet by choosing File | New.

Choose the MIDI file Chord Wizard dialog by choosing File | Import Chords from MIDI File.

  Press the [Open (Change)…] button to select the MIDI file, and then choose the file that you would like to import.  In this case, it is called “Violet Song.MID.”

Once you load in the file, you will notice that the Chord Wizard has analyzed the MIDI file and made these determinations for you.

It has automatically determined that the “Violet Song.MID” file

  •   has 2 bars of lead-in,
  •   has 103 bars of chords,
  •   is in the key of F with a 4/4 time signature, and a tempo of 120.
  •   The Bass part is found on channel 2.
  •   The chording (comping) parts are found on Channels 3, 6 and 7.
  •  The Melody is found on Channel 4.
  • There are no other parts like the Melody that should be put on the Soloist track.

Presets for Chord Options

Now, after loading in the MIDI files, you’d normally have a look at these settings to see if they seem reasonable for your MIDI file.  If they are not, you can change the settings.  For example, if you know that they key signature of the song is not F but is C, then you would set that.  Similarly, if you knew that the Melody channel was on channel 3, you could set that to override the Chord Wizard settings.

Presets

Once you have done that, choose one of the Presets to quickly enter the settings to the type of song that you are trying to interpret.  Preset choices are Jazz Standard, Jazz (Modern), Pop (with seventh chords), Pop (with no seventh chords), Rock, Pop Ballad, Solo Piano, and Solo Piano (Jazz).

Chord Options

When you choose one of these presets, it automatically makes a number of settings in the Chord Options section of the dialog, but you can override them in this dialog.  These include,

 (Range from 1 beat to 4 bars, default = 2 beats)
This is the minimum number of beats for a chord.  For example, if you set it to 2 beats, then the Chord Wizard will never attempt to come up with different chords that are only a beat apart. 

Tip: If you have a song that has a short section that does include chords every 1-beat, you can redo that section of the song with a 1-beat resolution.


If set, the Chord Wizard will include “slash chords” like F7/A or Cm/G.


You can set this to “Root only,” “Root third and 5th,” or “Walking bass.”  If you choose “Root Only,” the Chord Wizard will assume that any bass note is the root of the chord.  Choosing “Root-3-5” will cause the Chord Wizard to assume that the bass pattern is mainly on the root-3-5 of the chord.  If you choose “Walking bass,” it will assume that the bass notes can be changing and can include many notes beside the root.  Setting the “Walking bass” line will likely result in fewer chords overall than setting the “Root only” option.

The setting for “Allow Sus” chords determines if chords like Csus or Bbsus7 will be included.  The “Allow 7th chords” specifies if 7th chords like C7 or Bbm7 would be allowed. 

Simple Rock songs might not have 7th chords or SUS chords.  Allowing chords with no thirds should be set in a hard rock song, or similar song with “power chords” that might not contain the 3rd of the chords.


Usually a bass player plays the root of the chord at or near the time when the chord changes.  But in solo piano playing or some bass styles, the bass doesn’t state the root until later on, and this setting should be set to “delayed” in a solo piano style of this type.


You can also set the primary style of the song to Jazz or Pop using the Lead sheet Method combo box.

Using the Chord Options Presets to make settings for Violet Song.MID.

For the song “Violet Song.MID,” we know that this is a Jazz Swing type of song, so we press the preset called “Jazz Standard.”

By doing this, we see that the chord options have then been set to Chord Resolution of 2 beats, no slash chords, walking bass, sus chords, 7th chords, and Jazz lead sheet.

These settings look OK for our Jazz song; if we wanted to customize it (for example to allow slash chords) we could do it at this point.

So, to recap, using the Chord Wizard is a 3-step process.

  •   We loaded in the song “Violet Song.MID.”
  •   Pressing the preset button called “Jazz Standard,” we then looked at the Chord Options settings for the various channels and they looked OK, so we didn’t make any changes.
  •   We then press the [INTERPRET CHORDS NOW] button – this gets the Chord Wizard to interpret the chords and write them to the Chord Sheet.

Once we’ve pressed the [INTERPRET CHORDS NOW] button, we can see the results by looking at the Chord Sheet.  Here are the chords that were interpreted,


Chord Wizard results – interpreting from “Violet Song.MID.”

So that we can see how well the Chord Wizard did, we can compare it to the “correct chords” of the song, input by a musician listening to the song.  You can see these by loading in the song “Violet Song.MGU.”

The “correct chords” for the song “Violet Song.MID.”

As you can see, by comparing the two sets of chords, the Chord Wizard got almost all the chords correct in this example.  The Chord Wizard purposely avoids chords like “C13,” it will put a simpler “C7” instead, since this is more like a typical lead sheet.

If you have read in the entire MIDI file, you have 103 bars of chords on the Chord Sheet.  This actually contains 3 choruses of the song.  You might want to reduce that to a single chorus, by setting the chorus end of the song to bar 36, and then erasing the excess bars (after bar 36) by choosing Edit | Erase.

Examining the song that has been interpreted by the Chord Wizard.

You will notice that the title (Violet Song), key (F,) and tempo (120) have been set to the values found in the file.  Part markers are not set; the Chord Wizard doesn’t try to guess where part markers might be occurring.  You need to put the part markers in yourself.  You also need to choose the style to use (a Jazz Swing style in this case). 

If you examine the Melody track by opening the Editable Notation window and option clicking on some notes you will notice that the Melody track contains notes from Channel 4, which is what we specified in the Chord Wizard dialog.

Importing part of a MIDI file or redoing a section of the Chord Sheet.

Normally we’d want to import an entire MIDI file worth of chords.  But if you only want to import some bars, you can deselect the “Import Complete Song” checkbox, and then specify where to start in the MIDI file (i.e. “the # of lead-in bars in MIDI file”) and what bar to start at in Band-in-a-Box (“Insert to BB starting at bar #”) and the # of bars to import (“How many bars to import”).

For example, using the song “Violet Song.MID,” we could redo a section of the song using different settings (for example, a chord resolution of 1 beat instead of 2 beats).  If we were unhappy with the results at bar 7 and 8, we could redo this by making the settings as follows:

Other Settings for the Chord Wizard


Band-in-a-Box and PowerTracks Pro songs contain special events that write the exact chord names into the MIDI file.  So, if the Chord Wizard sees these events, it will use them instead of interpreting the chords, since they are likely to be completely accurate.  If you’d prefer the Chord Wizard to ignore these chord events, you set the “OK to use PG Music Chord names from MIDI file” to false.

Note: If you set this to TRUE, then the Chord Wizard won’t be working – it won’t be interpreting chords since it relies instead on the chord names being present in the MIDI file.


The setting for “Write chord summary notes to Soloist Track” is only used for diagnostic or special purposes.  If set, the Soloist track will contain a special track that has a chord written every 2 beats (or whatever the setting for chord resolution is) that contains every note found for the chord.  This shows you the type of logic that the Chord Wizard was basing its decisions on.  If you encounter a song that gives incorrect results for the chords, you can try this setting, and then examine the Soloist track to see the actual notes of the chords.


You can optionally include controllers, pitch bend, patch changes, and lyrics from the MIDI file.

The Reharmonist

Generate Chords for a Melody

Generate chords for a melody, or an improved chord progression for a melody, with the “Reharmonist” feature.  This feature generates a chord progression in the chosen genre, based only on the melody.

The idea of the Reharmonist is to generate a completely new chord progression for a melody, in a genre that you choose (Jazz, Country, etc.).  This ignores any existing chords in the song.

There are 2 separate windows for the Reharmonist feature.

  • Reharmonize entire song with a new chord progression.
  • See a list of possible reharmonizations for a given area of a song.

Chords for a Whole Song

This example uses the melody of Bach’s Brandenburg Concerto #1 in F, 1st movement, but you could use the melody of any song you choose.

Go to the menu Edit | Chords | Auto-Generate Chord Reharmonization.

You will then see the Select Re-Harmonist dialog.

Deselect “Show-All” and then select the “Bossa Nova (Latin)” genre.

Note that the program has analyzed the melody and decided that the key should be F (this is independent of any key that was already set in the song).

Now press [OK – Reharmonize].

You will then have an entire chord progression written for the song, in a Bossa Nova style.

The Chord Progression generated is different every time, so the one that you get will be different from this one.

Play the file that you have generated.  Notice the “Bossa” style of chord progression, with 2-5 progressions, and other typical Bossa chords.

Revisit the Reharmonize dialog, and try generating a new chord progression, in a new Genre.

For example, “EZ listening (Pop)” will generate a Pop style chord progression, very different from the Jazz chords in the Bossa version.

This dialog can also be opened from the menu command Windows | Auto Generate Chord Reharmonization.

Reharmonize Part of a Song

Now let’s use the Reharmonist in an “interactive mode” where it gives us choices of various chord progressions at each bar.  Let’s see if we can interactively improve on the chord progression, according to our own tastes.

The first 2 bars generated originally are:

Make sure that the currently highlighted cell is bar 1.

Go back to the Select Re-Harmonist dialog. 

This time choose “Part of Song” and under “Set Range” enter Bar 1, Chorus 1, and the # bars as 2. 

Here are two of the possible variations the Re-Harmonist has suggested for the first two bars.

See a List of Possible Reharmonizations

Go to the menu Edit | Chords | Chord Reharmonist Dialog (choose your own)

In the Reharmonize melody – new chords for 2 bars of the melody dialog you can choose from a list of reharmonizations for any 2-bar segment of the song. The reharmonization starts at the Bar # indicated.  Use the [-2] and [+2] buttons to navigate to the segment to be recompiled.

Use the feature interactively by displaying a menu of possible chord progressions for a portion of the melody and audition them to choose the best one using the “Bar Reharmonist.”  This allows you to hear some new chord progressions for existing melodies, or brand-new progressions for tunes without chords.

  Choose a chord progression, and press [Do-Reharmonize NOW] and the program will insert that progression.

  The progressions are sorted in alphabetical order, or from “best to worst” depending on this setting.

Chord Breaks

Insert Breaks (silence) in arrangement, also called Chord Breaks, is found in the Preferences 2 dialog.  This is a great feature for practicing tempo control. 

Select the # of bars, and Band-in-a-Box will play for, say 4 bars (selectable), and then will rest all instruments for the next 4 bars.  During the silence, you keep playing (comping, drums, melody, etc.), trying to stay in tempo.  Drummers can mute the drum part.  When the band comes back in after the 4 bars, you will get instant feedback on how well you have maintained the tempo, if the band comes in time with you or not.

Once set, this feature works automatically with all songs until you turn it off.

Guitar Tutor

Use the “Guitar Tutor” to analyze any song.  This feature will show the chords that are playing on the virtual guitar fretboard, in your choice of a Jazz, Pop, or Folk perspective.  The Guitar Tutor is a fun way to learn about new guitar chords while playing along with your favorite Band-in-a-Box tune.

The Guitar Tutor is most useful on styles that aren’t guitar styles.  This would apply to styles that don’t have an exclamation point (!) in the file name.  This is because the guitar styles already have a guitar part that you can learn from, on the Guitar part.

Using the Guitar Tutor, you can see (and optionally hear) guitar chords played on the guitar fretboard.  This teaches you how to play the chords on guitar.

To turn the Guitar Tutor on, launch the Guitar window and press the [Tutor] button.

Using the Guitar Tutor

Enable the Chord Tutor display by setting that checkbox.  This will silently display the chords on the guitar fretboard.  If you would also like to hear the notes, select the “Play chords through MIDI” checkbox.

The Tutor part uses the MIDI Thru part to playback on.  You can control volume, pan, reverb, and tone by using the Thru settings in the Mixer.  You can also select the patch here.

The tutor will display Jazz, Pop, and Folk voicings in easy, medium, and advanced forms.  The advanced forms use inversions, and changing patterns of chords, while the easy ones just stick to the common “campfire” chords.

  One of the tutors uses 3-note Jazz voicings to simulate the famous Big Band chord guitar comping styles.  If you use this, you will only see 3 notes in the chords of course.  Since it sometimes helps to see the entire 4 chord voicing, in this case there is the option to show the muted note as well.

Note: This applies to the Guitar Tutor.  There is also the option to show this for the Guitar Styles.  This option is present in the Guitar Settings Dialog.

The Guitar Tutor stays enabled until you change the Guitar track to another track (for example, to change it to the Bass track).  You can easily re-enable it by clicking on the [Tutor] button again.

Turn the tutor off by disabling the “Enable Chord Tutor Display” setting.

Chord Substitution Wizard

Reharmonizing a song with the Chord Substitution Wizard is a fun and educational way to perform or practice a familiar song in a brand-new way.  This feature is very easy to use; simply highlight an area of chords and select “Chord Substitution.” The possible chord substitutions are instantly displayed for you.

For example, if you had chords such as “Dm7 G7 Cmaj7,” a list of substitutions including the tritone substitution “Dm7 Db7b5 Cmaj7” would be offered to you for use in your song.  There are also helpful comments associated with each substitution, showing you why a given substitution might work in each case (e.g., is the melody compatible with the substitution, etc.).  Alternatively, you can enable the “Auto-Substitution feature and the substitutions will be selected according to the general preset preferences.

There are two ways to get chord substitutions, you can let Band-in-a-Box show you a list of possible substitutions to pick from yourself (Edit | Chords | Chord Substitution Dialog), or you can let Band-in-a-Box pick them automatically (Edit | Chords | Auto-Generate Chord Substitutions).

Chord Substitutions Dialog

The appearance of this dialog depends on what chords are present at the highlighted bar.  This bar number is shown in the dialog and may be changed.  In the example above, the chord is an F7 chord, so the substitutions shown are for an F7 chord.  The substitutions shown may work for up to 4 bars, depending on the substitution.  In the examples above, the substitutions work for 2 bars.

You can control what types of substitutions to see by using the Jazz/Pop checkbox.  Some substitutions include more chords than the original, some simplify the progression, and these can be viewed using the checkboxes.  You can elect to exclude substitutions that have a chord on each beat.

The “Types of Substitutions to include” combo box will filter the substitutions to include only the best substitutions or all of them.

The “reload” [Recompile] button is only used if you have edited the chordsub.txt file to add your own substitutions. 

Once you see a substitution that you like, you can enter it onto the worksheet by pressing the [Do Substitutions now] button or double-clicking on the substitution line.  You can then move the current bar to the next part of the song that you need a substitution for and repeat the process.

You can undo the substitution by pressing the [Restore] or [All] button.

Auto-Chord Substitution Dialog

You can quickly auto-generate substitutions for an entire song or portion of a song using the auto-substitution dialog.  For example, we can generate substitutions for the !Freddie.MGU song.  Here is the original chord progression.

By using the auto-substitution dialog, we can generate substitutions for the whole song, and we get this result:

You can see that Band-in-a-Box chose the substitutions for about 70% of the chords in the song (that’s what we told it to do in the dialog).  Some of the substitutions chosen are more advanced than that (replacing an F7 with a B13 for example)

Here are the settings in the auto-substitution dialog that produced this result:

If you’d like Band-in-a-Box to only generate for a certain range of bars, you should first highlight that range of bars in the Chord Sheet, then launch the dialog.  The Range will then be set to Part of the song and the bar # and # of bars settings will also be set.  You can override these settings with manual settings, if necessary.

Chord Builder

The Chord Builder is launched with the [Chord Builder] toolbar button, with the menu item Edit | Chord Builder, or with the keystrokes control+shift+H.

This feature allows you to hear and build chords up by clicking on the root, extension (and alternate root if applicable).  Chords are previewed as they are built.

To enter a chord at the current bar, click on the root of the chord (in the “Root” group), the extension (Maj7 etc.), and an alternate “slash-note” root if desired.

For example, to make the chord F9/A, you would click on the “F” root, the “9” extension, and the Slash Root of “/A.”  As you click on them, you will hear the bass note played on the Bass part, and the extension played on the Piano track.

If you are happy with the sound of the chord, you can press the [Enter Chord] button to enter the chord at the bar and beat specified.  If you would like the chord to be inserted automatically when you click on the note/extension names, select the “Enter chord when clicked” option.  This will advance the Bar/Beat position.  You can change the Bar/Beat settings to move to a different bar.  The [<] & [>] buttons move 1 beat on right click, and 2 beats on left click.

If you are happy with the sound of the chord, you can press the [Enter Chord] button.  That enters to enter the chord at the bar and beat specified.  If you would like the chord to be inserted automatically when you click on the note/extension names, select the “Enter chord when clicked” option. 

Clicking on the [<] & [>] buttons moves 2 beats and control+clicking on these buttons moves 1 beat.

The Chord Builder can be left open as you work entering chords into Band-in-a-Box.  Remember that you can also play chords in from the MIDI keyboard by pressing control+return after you’ve played a chord.

Pressing the [Show More] button will open the Chord Theory section, which displays and suggests chords that are most popular in the current key.

The top row is diatonic chords.  Other rows add additional chords that are part of the key, such as dominant 7th approach, slash chords, parallel minor, diminished, and more.  This allows you to quickly enter chords by clicking on the most common chords in the key.  For example, if you stick to the top row (diatonic), the chord progression you enter will be a typical song progression.  Choosing from other rows will add variation and color to the progression.  This is a fun, interactive way to enter and explore chord progressions, and learn music chord theory at the same time.

For example, if you are in the key of F, the top row shows the most common chords in the key of F, which are the diatonic chords.  You can just click on chords on this row to enter your chord progression using the most popular chords.  Lower rows have additional chords in the key of F, like G7, A7, etc.

You can enable the “Jazz” checkbox to show jazz chords (e.g. sevenths like Maj7) instead of pop chords (e.g. triads like C). 

F              Gm          Am          Bb               C             Dm          Em7b5        (in pop mode)

FMaj7     Gm7        Am7        BbMaj7      C7           Dm7        Em7b5        (in jazz mode)

Diatonic: These are the diatonic chords, made up only of notes in the key.  They are the most common chords used in the key, with the 1, 4, and 5 chords being the most common.

Dominant 7: These chords are considered to be in the key when they resolve up a 4th to a scale tone.  For example, A7 resolves to D, which is a scale tone in the key of C.

Slash Chords: The diatonic chords are also commonly used with different chord tones as the bass note.  They are called slash chords, like C/E.

Parallel Minor: For a major key like C, the chords from the Cm key are also used commonly.

Diminished/Half Dim.: The most common diminished chord used is the 1 diminished family [Cdim7, Ebdim7, F#dim7] in the key of C.  Half-diminished chords (e.g. #4m7b5 [F#m7b5] and 7m7b5 [Bm7b5]) are used as 2-5-1 leading to minor diatonic chords.

All (Common): This row lists all commonly used chords with the root in the key.

Clicking on the small button on each row will list more suggestions.

Drum Kit Window

Note: This feature is not implemented yet in the current 64-bit build of Band-in-a-Box 2020 but is available in the current 32-bit build and should be available in a future patch build of the 64-bit build.

This sizable window is a cool animated 3D display of a complete drum kit, with all 61 Drum sounds displayed on their instruments.  Watch the various drum instruments being played, or play-along/record on any of the drum instruments by using QWERTY keys or a mouse.  Very educational and lots of fun!

To launch the Drum Kit window, click the [Drums] button, or choose the Windows | Drum Window option.  Then the Drums Kit window will display an animated display of a complete GM drum kit.

You can do several things with the Drums Window:

  • Watch the Drum part being played on the Drums Window in real time.
  • Play along with the drums in real time by mouse clicking on the Drum Instrument or using QWERTY keys (the key names to use are listed on the Drums Window).
  • Record a drum part into Band-in-a-Box.  To do this, simply press RECORD in Band-in-a-Box and play along.
Note: If you want to record a drum part to the Melody track, you will have to set the Melody channel to 10 using the Options | MIDI Settings menu item.

Drum Display

All the General MIDI percussion instruments are shown.

Acoustic Bass Drum
Acoustic Snare
Low Floor Tom
Pedal Hi-Hat
Low-Mid Tom
High Tom
Ride Bell
Cowbell
Ride Cymbal
Mute Hi Conga
High Timbale
Low Agogo
Short Whistle
Long Guiro
Low Wood Block
Mute Triangle

Bass Drum 1
Hand Clap
Closed Hi-Hat
Low Tom
Hi Mid Tom
Ride Cymbal 1
Tambourine
Crash Cymbal 2
Hi Bongo
Open Hi Conga
Low Timbale
Cabasa
Long Whistle
Claves
Mute Cuica
Open Triangle

Side Stick
Electric Snare
High Floor Tom
Open Hi-Hat
Crash Cymbal 1
Chinese Cymbal
Splash Cymbal
Vibraslap
Low Bongo
Low Conga
High Agogo
Maracas
Short Guiro
Hi Wood Block
Open Cuica

Some percussion instruments are triggered by multiple MIDI notes.  When controlled by more than one MIDI note, a percussion instrument will show different behavior in response to the different notes.  For instance, the Hi-Hat responds differently to Close Hat, Pedal Hat, and Open Hat MIDI notes.

The on-screen instruments may be played by mouse-click or computer keys.  When playing by mouse-click or computer keys, the shift key adjusts velocity between two user-specified levels.

Drums that you play show up in blue (the computer played drums are red).  There is an option to display all the QWERTY names on the drums at the same time, so that you can see what keys to hit without having to mouse over the instrument.  The drums can be moved off-screen without snapping back to the middle.

To display the QWERTY keys on the notes, select the option in the Drums Window Settings dialog to “Display QWERTY Chars on Drums.”

Multi-note instruments send different notes depending on where you click on the instrument.  For instance, the Kick Drum can send three different notes, Ac. Bass Drum (MIDI note 35), Bass Drum 1 (MIDI note 36), and Square Kick (MIDI Note 32).

The hint line at the top of the window describes the current control under the mouse cursor.  Use the hint line to learn the mouse-responsive areas of each drum instrument.

Multi-Note Drums Instruments

Kick Drum - Ac. Bass Drum, Bass Drum 1, Square Kick
Snare - Acoustic Snare, Side Stick
Hi Hat - Closed, Pedal, Open
Floor Tom - Low, High
Electronic Pad - Multi-zoned for Hi-Q, Slap, Electric Snare
High Conga - Mute, Open
Surdo - Mute, Open
Cuica - Mute, Open
Metronome - Bell, Click
Whistle - Long, Short
Triangle - Mute, Open
Guiro - Long, Short
Scratch - Push, Pull

Computer “QWERTY” Drum Keys

Numeric Keypad Drum Keys

Strike computer keys to play drums.

Drums are grouped on the computer keyboard by category.  The kick, snare, and hi-hat sounds are on the lowest keyboard row.  The lower-middle row contains toms and cymbals.  The upper-middle row contains Latin drums, and the top row contains Latin hand percussion.

The numeric keypad keys contain the remainder of the Latin hand percussion plus the electronic tones.

Drum Kit Main Window

The Drums main window can be resized to tile with other windows of interest.

On 256 color displays, the image does not look its best.  The window looks its best if the computer is in Thousands-of-colors (16 bit) or Millions-of-Colors (24 bit) video mode.

Drum Transport Controls

Place the mouse cursor on each control to see its function.

  • Record: Place Band-in-a-Box in Record mode so drum instruments can be recorded.
  • Play: Start Band-in-a-Box song playback.
  • Rewind: Stop and return to song start.
  • Stop: Stop Band-in-a-Box playback.
  • Size Buttons 1/1, 1/2, 1/4: Preset the window to full size, half size, or quarter-size.  If the window has been changed to a size different from these, by dragging a window border, none of the size buttons will be down.
  • Settings Dialog: Adjust program behavior.

Drum Window Settings

In the Drum window, press the [Settings] button (to the left of the Record button), to adjust the Drum Window Settings.

Note: If your computer video is in 256-color mode, the colors in the Drums window may sometimes appear strange.  To display the drum window at its best, use Thousands-of-colors (16 bit) or millions-of-colors (24 bit) video modes.

Velocity - When playing drums with a mouse or computer keys, the shift key toggles between two levels of note velocity.  The default velocity is 90, with a default shift key velocity of 127.

The two velocity levels can be set any way desired.  For instance, if you want the shift key to send quiet notes, program the shift velocity lower than the non-shift velocity.

Randomize - Enables the Randomize checkbox to send random velocity levels when playing by mouse or computer keyboard.

Range - Control the amount of velocity randomization.  Usually a small range works best, around 10% to 30%.

If velocity is set to 127, and the random range is set to 20%, notes would randomly vary between a maximum velocity of 127 and a minimum velocity of 102.

Instrument Hints - Customize appearance of the Hint line with Note Name, MIDI Note Number, and Computer Key.

Display Qwerty Characters on Drums displays the QWERTY key names that play each drum in the kit.

Show
- “Show All Instruments” shows all instruments in the drum window. 
- “Show Used Instruments” displays the basic trap kit but does not display any extra instruments unless they are used in a song.  The drum window is cleared each time Play or Stop is pressed.



Chat online Online now

Need Help?

Customer Sales & Support

Phones (Pacific Time)
1-800-268-6272 1-250-475-2874
Live Chat
OPEN Online Ordering
24/7
OPEN Forums, email, web support
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.