Search Manual

RealBand® 2018 for Windows® User’s Guide

Chapter 8: RealTracks and Audio

Overview

The audio production options available in RealBand include RealTracks, RealDrums, and audio tracks plus powerful audio effects and editing features.

RealTracks are audio tracks generated automatically following the chord changes you enter in the Chords window.  They use the exciting Real Instruments, live recordings of top session musicians.  This is the same feature found in Band-in-a-Box.

RealDrums, also found in Band-in-a-Box, are similar to RealTracks, except that they are generated from live recordings of top studio drummers.

You don’t need to have Band-in-a-Box to generate RealTracks and RealDrums, but if you have a copy you can use all of your RealTracks and RealDrums from Band-in-a-Box in RealBand.

Audio tracks are for your own live recordings - such as a person singing or playing guitar – or for imported audio files in the many formats supported by RealBand.

RealStyles - Styles with RealTracks

RealStyles use only RealTracks and RealDrums.  Every track generated by these styles is a RealTrack, playing audio from live recording sessions.

Generating RealTracks

This feature lets you generate realistic instrument tracks using RealTracks instruments.  It is selected from the right-click menu in the Tracks window. 

You can generate complete tracks or just selected sections of tracks, and you can use more than one RealTracks instrument in a single track.

Select an open track for your RealTracks, then right-click and choose either Select and Generate RealTracks or Generate RealTracks (Favorites).

Select and Generate RealTracks

This command opens the RB Assign RealTracks to Track dialog.  It shows a list of all available RealTracks, including the RealTracks you have installed in Band-in-a-Box if you have specified your bb\RealTracks folder as the path for RealTracks in the Song Generation preferences.

When you click on a RealTrack in the list a Memo appears with information about the selected instrument.

The RealTracks have been recorded by top studio musicians.  The Artist Bio displays the names and bios for the RealTracks artist.  Double click here to view the full memo.

You can enter your own comments about any style in the User Memo field.  The comments are saved in RTUserMemos.txt.

You can audition an audio demo of the currently selected RealTracks.

The [Solo] button plays the solo version of an audio demo, while the [Band] buttons plays the band version.

  If this option is checked, then when you double click on a RealTracks in the list, an audio demo will play with the RealTracks AND a band backup, followed by the solo version.  If this option is disabled, the solo version plays first.

  This option allows an audio demo to play from pgmusic.com using the internet if the audition file isn’t found on disk.

Options for Selected RealTrack

With the Timebase option you can play any RealTracks at normal, half-time, or double time.

 

Half time is used for fast tempo songs when a much slower tempo RealTrack has been chosen.  Double time is used for slow tempo songs (e.g. ballads) when a much faster tempo RealTrack is chosen.  This allows you, for example, in a ballad at a tempo of 70, to add a RealTracks Sax solo with a tempo of 140, and play it as a double time, which will match the ballad tempo of 70.  All of your existing RealTracks can be used at three different tempos (normal, half-time, double time).

  The [Medley] button lets you assign a series of RealTracks to play on the track.

There are lots of options to control how often the RealTracks in the medley will change.

  Click on the ▼ arrow to choose from the list.  Note that <Silence> is an option.  You can use it when you want to play a section yourself.

There are hundreds of RealTracks to choose from, so type a string like “guitar country” to filter the list.

 Choose this setting to have the current RealTracks play in a bluesy style where major triads are treated like 7th chords.

 Plays a simpler arrangement if the RealTracks instrument has an “s” in the “Simpler” column.

 Uses a clean guitar signal if there is a “y” in the Direct Input column.  You add your own effects.

 The [None] button sets the current instrument to have no override of RealTracks for the song.  The style may still have a RealTrack in it for the instrument.

 The [Clear All] button sets all RealTracks for the song to “None.”  It will also optionally disable RealTracks present in the style for the song.

To help make your selection you can sort the list by clicking on any of the column headings.  As well as Name, Instrument, Type (Rhythm or Soloist), Feel (Even or Swing), Tempo, Genre, and Number there are more columns with additional information about each RealTrack instrument.

The tempo shown is the “base” (or typical) tempo for the RealTracks instrument as it is played, but RealTracks have a tempo stretching capability that enables their application over a wide range of tempos.  If saving a song with RealTracks and the audio base tempo is different than the song tempo, a warning message will show, asking you to confirm that you want to save it like this.

  • The “N/A” column shows “N/A” for RealTracks that you have not installed yet or haven’t purchased, if “Show RealTracks that are N/A” is checked.
  • “Set” is the number of the RealTracks set that includes the instrument.
  • The “Stereo” column shows whether the instrument playback is stereo or mono.
  • Instruments with an “N” or “Gt” in the “Chart” column will display the RealTrack in notation.
  • The “Artist” column has the name of the musician playing on the RealTrack instrument.  See the “Artist Bio” box for information about the player.
  • The letter “Y” in the “TS” column means that Tempo Swapping is supported for the instrument.  If you have similar RealTracks available at different tempos, Band-in-a-Box automatically chooses the best one to use.
  • “Holds” indicates whether that RealTrack supports shots, holds, and pushes.  If there is a number there (other than a blank field), then they are all supported.
  • “Simpler Available” will have a letter “s” in the column if the RealTracks instrument has simpler options available.  These are parts with less busy, less embellished playing for generating simpler arrangements.
  • “Direct Input Available” has a letter “y” if the instrument offers the option of clean recordings without effects.  This allows you to start with a clean track and add your own effects.

  This will show RealTracks that you do not have installed yet, or may not have purchased.  The missing RealTracks will be marked in the N/A column.

  Variations of RealTracks use the same performances but with different settings.

  This will show RealTracks that wouldn’t work well at the current tempo. The acceptable range is -15% and +40% of the source tempo of the RealTracks.

The filter is another feature that makes it easier to select a RealTracks instrument. 

For example, type “Blues” in the edit control box and press the [Update] button to see a list of Blues instruments available, including instruments from other genres that are suitable.  The [Show All] button clears any filter and shows all available RealTracks.

 Click on [OK] to generate the RealTrack and close the dialog.

  Click on [Cancel] to exit the dialog without generating a RealTrack.

  This rebuilds the list of RealTracks and reports errors.

  This will display installation errors of RealTracks when you open the dialog.  Press the [Rebuild and Fix] button for more information, or after you have installed new RealTracks.

Track names for generated non-BB tracks are displayed in green.  For example, if you had generated a track by right-clicking on it and selecting “Generate RealTrack” then the track name of that track will be displayed in green.

Generate RealTracks (Favorites)

This command opens a short list of the most recently used RealTracks for a quick and convenient selection.  Click on your choice in the list to begin generating the RealTrack.

Regenerate Track

This will regenerate an existing track.  If a track is a non-BB track, but it was generated individually from one of the generation options in Tracks window popup menu, or from one of the generation options on the [Generate] button popup menu, then the track name will be displayed in green.  The track name being displayed in green or blue means that the track can be regenerated using this command.  This feature is useful to regenerate, if you had changed the song’s tempo, or just to generate fresh material.

Generate All will regenerate all Blue and Green tracks automatically.

Freeze Track

You can “freeze” a track, which prevents it from being regenerated by functions like re-generate all tracks, or the [BB] button.  To do this, right-click on the track and select, “Freeze track from Generation.”

MultiRiffs

With “Same but Different” MultiRiff selection you can audition 7 different RealTracks performances, to choose the one that works the best with your song, with a single click!  This works for the entire track, or the highlighted region of a track.  Choose one riff or multiple riffs to add to the song.

For example, if you want a pedal steel riff for 4 bars, highlight that region, and listen to the 7 selections, and choose the riff that works best.  Or if you want 2 “different” acoustic guitar strumming parts, choose 2 from the 7 different generated parts, they will be written as to different tracks, and contain different strumming.  We call this “Same but different” since the strumming patterns are on the same chords, but are different performances.

If you are generating riffs for a highlighted region of a track, not for the complete track, you can select the “Allow riffs to start earlier or end later” checkbox.  This allows the program to insert the whole riff, even in the case of the riff starting earlier or ending later than the highlighted area.

For example, you may have selected bar 2 through bar 4.  If that checkbox is enabled, and the riff generated by the program happens to start early or end late (be more than exactly 3 bars long), then, when the OK button is pressed, the program is allowed to insert the entire riff into the track, even if it means that what gets inserted actually starts earlier than bar 2 or actually ends later than the end of bar 4.  The riff description in the MultiRiff dialog reports how many ticks earlier and later the riff is.  This is also visible in the track overview.

The Riff data itself is generated in such a way so that the program always generates the nearest “X” bars worth of riff data.  For example, if the user highlighted beat two through beat three of bar 6, then the riff is really going to be a bar long.  However, if "Allow riffs to start earlier or end later" checkbox is unchecked, then the user will get what the user selected rather than a full bar.  If that checkbox is unchecked then the user will get at least a full bar of data inserted.

If the start of the highlighted area, or end of the highlighted area, is not on a bar boundary, then the Riff description is expected say that the riff starts early (or ends late).  That is not a bug, since it does start early or end late relative to the area that the user highlighted.  For example, if the user highlighted beat 2 through beat 3 of a bar, then the program may say that the riff starts 120 ticks early and ends 120 ticks late since the program really generates at least a full bar in that case.

Note:  If a riff that was generated happens to END earlier than the end of a bar, or END earlier than the end of the highlighted region, this will not be reported in the riff description field.  That field will only tell you if the riff starts early or ends late.

Generating MultiRiffs

To generate MultiRiffs you right-click with the mouse on the track where you want a new RealTracks instrument track generated.  In the menu that opens, select MultiRiff… (Choose).

The RealTracks Picker will open and you can choose the instrument you want for the track.  When you OK your choice there will be a bit of a delay and the MultiRiff dialog will open.

You will see the seven different riffs that have been generated listed along with a riff description giving the number and range of notes in each one.  Click on the adjacent [►] play arrow to hear each riff playing along with your song arrangement.

Hit the [Stop Riff Playback] button if you’ve heard enough and want to move on to the next riff.

There is also an option to play multiple riffs.  You can have several riffs – all seven if you want – generated and played on separate tracks.  Try this with some of the Dixieland RealTracks soloists!  This is also the easy way to layer backing tracks.

There is also an option to solo each riff to hear it unaccompanied.

When your riffs play, they are loaded into the track you have selected (or multiple tracks for multiple riffs playback) and you will see the waveform(s) in the Tracks window overview.  Of course this means that you have all of RealBand’s editing features available to you.  You could even drag and drop your favorite sections of each separate MultiRiff onto a single track to compile them into one edited track.

You’ll see that your track name has been updated with the name of the RealTracks instrument you chose for your riffs.

To change to a different instrument, right-click on the track and select MultiRiff… (Choose) in the menu.

This will open the Assign RealTracks to Tracks dialog (RealTracks Picker), where you can select different instruments to play the riffs.

RealBand can automatically generate RealCharts after you have chosen multiple riffs, if the Also Generate RealCharts was enabled in the track’s right-click menu.

Generating RealDrums

This feature lets you generate realistic drum tracks using RealDrums styles.  It is selected from the right-click menu in the Tracks window.  You can generate a full track or any part of a track, and you can use different RealDrums styles for different sections of a track.

Select an open track for your RealDrums, then right-click and choose either Select and Generate RealDrums or Generate RealDrums (Favorites).

Instant Preview of RealDrums

You can double click on a RealDrums, or on the Variation name of the RealDrums, to audition each variation of the RealDrums.  For example, if you’ve found CountryWaltz^, you can now hear demos of the variations (CountryWaltz^1-HiHat,Ride, CountryWaltz^2-Brushes etc.).

Each demo has a “band” version with all instruments, and a “solo” version with drums only.

You can choose which of band or solo plays first if you double click on the list, by the “Band (on DblClick)” checkbox.  Otherwise, press the [Band] or the [Solo] button. 

The demos play 4 bars of “a” substyle, and then 4 bars of “b” substyle, using the current RealDrums (left hand panel) and the variation (right hand panel).

Select and Generate RealDrums

This command opens the RB RealDrums Picker dialog.  You will see a list of all of your available RealDrums styles.  If you have Band-in-a-Box installed on your computer you can use all of your Band-in-a-Box RealDrums styles if you have set the path for RealDrums to your bb\Drums folder in the Song Generation preferences.

The RealDrums Picker has many features to help you choose your RealDrum style. 

Enter a filter string like Salsa, Jazz, or congas and the displayed list of styles will be limited to styles/genres including that name. 

The [Update] button applies the current filter in the edit field.  [Show All] clears the filter and shows all styles in the list.

  This will show styles that wouldn’t work well at the current song tempo.  The acceptable range is shown in the Lo | Hi columns for the list of styles. 

  This will show a song where the drums are in Even feel and the style is Swing, or vice versa.

  You can assign a style as one of your favorites by clicking in the first column on the left, which is headed with an asterisk *.  This will place an asterisk to the left of the style name.  Then you can sort by favorites or use this option to only see favorites.

  These are styles not found in the \drums folder, likely because they are add-on styles not purchased yet.  If you think that styles that show as N/A should be present press the [Rebuild] button and confirm the path for the drums folder in the Song Generation preferences.

  If this is enabled, RealDrums will play a simpler arrangement without fills.

  Set this if you want to use MIDI drums and want to override a RealDrums that is embedded in the style.

This sets the drums to no RealDrums override for the song, and optionally also forces MIDI drums (i.e. no RealDrums for style either).

When a RealDrums style is picked in the list a descriptive Memo opens.

Click on the heading for any column in the list to sort the list by that column, such as by name, genre, or feel.

The User Comments field is where you can type in and save your own notes about a RealDrum style.

RealDrums styles ending in a caret ^ have Variations available.  These are shown in the list here.  For style names with two variations - such as Brushes, Sticks - the first refers to the “a” substyle and the second is the “b” substyle.

Use these buttons to find compatible RealDrums styles.  The [RD Demo] button loads and plays a demo of the chosen RealDrums style.  A list of demos for the chose style will be displayed.

The [Song Demo] button shows BB styles that will use this RealDrums style.  The song demo for the style will get loaded. 

The [Audition] button doesn’t load the style, but instead uses Media Player to play a demo .WAV file for the style.

Use the [Rebuild] button to build the list of RealDrums styles present in the \drums folder.  If you add new drum styles, press this button to update the list.

Track names for generated non-BB tracks are displayed in green.

Generate RealDrums (Favorites)

This command opens a short list of the most recently used RealDrums for a quick and convenient selection.  Click on your choice in the list to begin generating the RealDrums track. 

 

Regenerate Track

This will regenerate an existing track.  If a track is a non-BB track, but it was generated individually from one of the generation options in Tracks window popup menu, or from one of the generation options on the [Generate] button popup menu, then the track name will be displayed in green.  The track name being displayed in green or blue means that the track can be regenerated using this command.  This feature is useful to regenerate, if you had changed the song’s tempo, or just to generate fresh material.

Generate All will regenerate all Blue and Green tracks automatically.

Freeze Track

You can “freeze” a RealDrums track, just as you can a RealTrack.  This prevents it from being regenerated by functions like re-generate all tracks, or the [BB] button.  To do this, right-click on the track and select Freeze track from Generation.

RealDrums Variations, Fills, and Accents

There are “a” and “b” variations for each RealDrums style.  They are determined by the part markers assigned in the Chords window. 

To assign the substyles for your song, click on the Chords button to open the Chords window and insert “a” or “b” part markers. 

Click on the desired bar numbers to toggle through the a/b selection or to clear a marker.

Rests, shots, and pushes are supported by the RealDrums generation routines.  They are entered in the Chords window.

Rests and shots are set by adding periods to the chord name.

A chord can be specified as a Rest by adding a period after the chord.
  e.g. “C.” indicates a C chord that is a Rest.

A chord can be specified as a Shot by adding two periods after the chord.
  e.g. “C..” indicates a C chord that is a Shot.

Pushes are set by entering carets in front of the chord symbol.
  ^C = 8th push
  ^^C = 16th push

Note:  Rests, shots, and pushes can ONLY be entered in the Chords window.

Recording Audio Tracks

Audio tracks are great for recording live sounds such as a person singing or playing guitar, in a similar manner to tracks on a tape recorder.  You can edit audio data by cutting and pasting in the Bars window or the Audio Edit window.  You can import .WAV files to be inserted into audio tracks.  You can also process audio tracks with effects in the Edit | Audio Effects menu.

Recording will occur over the current track selection, i.e., the track number that is highlighted in the Tracks window.  The track type must be set to “Audio.”

The “Always Record Audio too, if current track is MIDI” setting in the Audio Options dialog (Options | Preferences | Audio) will cause RealBand to record audio even when the current track type is MIDI.  RealBand will offer to keep the audio take on the nearest available blank track.  This can be a “lifesaver” in those situations where you wanted to record audio, but you accidentally selected the current track as a MIDI track.

The “Backup Most Recent Audio Take” setting in the Audio Options dialog, when enabled, will always backup the most recent audio take.  This can be helpful if you accidentally recorded audio onto the WRONG audio track, or you accidentally punched-in instead of recording a regular take.  If this happens you can undo the keeping of the most recent take and then use the File | Audio | Insert Wave File command to insert the recorded audio onto a different track, by importing the RBBAKx.WAV file from the Temporary Audio Directory. 

Setting Audio Levels

There are 2 pairs of VU meters, one pair for audio input, and one pair for audio output.  

The clipping indicator indicates that clipping has occurred.  Try to keep the levels low enough so they’re safely below 0 db, and so that the clipping indicator doesn’t light up.

To be on the safe side, it’s probably a good idea to adjust the levels so that the meters don’t get close to 0 db even if the clipping indicator hasn’t yet lit up.

The VU meters have an automatic peak-hold feature with gradual peak fallback, so it will be easy to see the transient peak levels if you’ve got your eye on the meters.

For the Output, you may have to adjust your mixer settings within RealBand to keep the levels within a reasonable range. 

For the Input, you may have to press the speaker button to launch the Windows Recording Control properties and adjust the input level.

Note:  The appearance of this window is different for different sound cards.  The example shown is for a typical Sound Blaster Audigy card.

In the example shown of the Recording properties, “Microphone” is the selected audio input for a SoundBlaster device and the Volume fader is at 70% of the maximum level.  Different devices will show different consoles.

If the Input meter were too high, either clipping or getting close to 0 db, then lowering the Microphone volume level would correct this.

Start recording by pressing the Record button.

Stop recording by pressing the Stop button or the <SPACE> bar.

When recording is stopped a “Keep Take?” dialog appears that gives you the option to keep or reject the take.

If you choose [Yes] the audio wave file will be saved and you will see an added event in the Events column for the track (Classic view).

Auto Rewind

Auto Rewind is found in the Options menu.  When enabled, RealBand will automatically rewind to the location that playback or recording was started.  The choices are “Recording Only, Playback Only, Both Recording and Playback,” or “Disabled.”

Audio Editing

Any of the forty-eight tracks within RealBand can be designated as either mono audio or stereo audio.  If you edit a stereo track in the Audio Edit window, you will see two channels (waveforms) in the window.

The Audio Edit window lets you edit only the left or right channels of a stereo track instead of always editing both channels.  This lets you Cut/Paste just the left or right channel, or you can apply a non-real time effect (Edit | Audio Effects) to just the left or right channel.

Stereo tracks are normally panned to the center so the stereo signal is centered.

Loop Record

If you record while in Loop mode (which is activated using the loop button) the music will loop when recording is started with the Record button.  The music that is recording during each loop can be put onto individual tracks after recording is finished, or the entire take can be put onto a single

track like an ordinary recorded take.  A dialog will pop up giving you a choice of whether the recorded audio will go on separate tracks or on the same track.  If you choose the latter, the take will be kept the same way an ordinary take is normally kept.  If you choose to have the loops put on separate tracks, the program will put each loop on any available track that is greater than or equal to the Current Track.  For example, if there are 10 audio loops recorded then program will put the takes onto 10 audio tracks.  If you don’t want to overwrite existing tracks, then make sure the current track, and any tracks with a higher number than the current track, are blank before recording.  For example, if the song already has 10 tracks used, then start recording on track 11 and the loops will be placed on track 11 and beyond.  If the program runs out of tracks, it will attempt to put remaining loops onto the last track.

Note:  Loop recording will always begin at the start of a loop. 
Note:  Punch-in mode will automatically be deactivated by the program since it is incompatible with loop recording mode. 

Rendering MIDI Tracks to Audio

The Render menu on the main menu bar has commands to automatically render entire sequences to audio files, or to export selected tracks to WAV files.

Rendering MIDI to audio is virtually automatic when using the DXi/VSTi synthesizer support in RealBand.  Just go to the Render menu and choose Merge Audio and DXi Tracks to Stereo Wave File, or to a WMA file, or to any compressed format (such as .MP3) that is supported by your computer.

Note:  If no audio tracks are present the MIDI tracks will still be rendered to audio using the DXi synthesizer.  This feature requires that you have a DXi software synth assigned to the MIDI track(s) you are rendering.

All levels and effects settings will be rendered exactly as they are in the Tracks and/or Mixer windows.

Export Acid Loop - Highlighted section or entire track to WAV in Loops Folder
This command will render the highlighted section of the current track or the whole track as an ACID Loop and save it to the bb\RealTracks\Loops folder.

Save as UserTrack (highlighted section or whole track)
This command will render the highlighted section of the current track or the whole track as a WAV file and save it to the bb\RealTracks\UserTracks folder.

Export Highlighted Section (or entire track) to wav/wma/mp4/m4a/mp3
This command will export the highlighted section of the current track to a wave file –as long as the track contains audio data.  Drag a section of the track while holding down the left mouse button to select a highlighted section.  Use Ctrl+A to select the whole track, or open the right-click menu and choose Select Whole Track.

Merge Audio and VSTi/DXi Tracks to Stereo Wave File
This is an export command that will merge all the audio tracks to a stereo wave file while simultaneously rendering and merging the MIDI tracks to audio if you have a DXi or VSTi software synth.  When played in a wave file player the file will sound the same as if the audio tracks of the song were being played by RealBand.  The volume, mute, pan, etc. settings of the track will affect the sound of the merged stereo wave file.

Merge Audio and VSTi/DXi Tracks to Compressed File
When you export audio to alternate file formats a standard Windows Audio Format dialog appears.

Use the Format popup menu to select the ACM codec you wish to use, and then select the exact specifications of the file from the choices available in the Attributes popup menu.
If you frequently use a particular combination you can click on [Save As] to name the setting in the Name combo box and save it for future use.
When you press OK, RealBand will export the song to the format you have selected using the ACM codec.

Note:  Most conversions work fine, but not all codecs can save in every format listed.  RealBand does intermediate conversions when necessary (to try to get the job done), but sometimes a codec will report “Conversion not Possible.”  This error is caused by a limitation of the codec rather than RealBand.

Merge Audio and VSTi/DXi Tracks to WMA File
This command works the same as the Render | Merge Audio and DXi Tracks to Stereo Wave File command except that this feature will compress the file using the Microsoft Streaming Media® Compression Technology™.  When you execute this command the program first generates a temporary stereo PCM file (Raw Wave).  A dialog will then pop-up that will let you save the resulting stereo PCM wave file to a .WMA file (Windows Media Audio).

Auto Convert Individual MIDI Track to WAV File

Invoke this command by right-clicking on the track in the Tracks window and easily convert any MIDI track to a .WAV file.  RealBand will automatically render using a DXi or VSTi synth.

Auto Convert Individual MIDI Track to Audio Track

It is easy to convert any MIDI track to an audio track.  RealBand will automatically render using a DXi or VSTi synth.  This command is accessible by right-clicking on the track in the Tracks window.

Manual Rendering of MIDI to Audio

MIDI tracks can easily be rendered (recorded) to audio using your system’s sound card and its onboard MIDI synthesizer or by recording the audio output from an external MIDI device.

To render MIDI tracks to audio with the internal system sound device:

  • Load the source MIDI file into RealBand.
  • In the Tracks window select a blank track and set the track type to stereo audio.
  • In Options | Preferences | MIDI Devices verify that the internal MIDI synthesizer is selected.  This could be the Microsoft GS Wavetable SW Synthesizer, any model of Sound Blaster, or another onboard sound device.
  • Click on the VU Meters button on the Tool Bar.
  • In the VU Meters window click on the Windows mixer button to open the Volume Control (see note following).  To see the Recording Control, select Options | Properties in the Volume Control window.
  • In the Recording Control select the input source by checking the Select checkbox.  Different systems and sound cards use different labels; you might be selecting “MIDI” as the input source, or “What You Hear,” or “Stereo Mix.”  If you aren’t sure which source to choose, start by eliminating the obvious like CD Player, Microphone, or Line In.
  • Play the MIDI file and monitor the levels on the Input VU meter.  Levels can be adjusted in both the Recording Control and the Volume (or Playback) control.  The levels can occasionally go into the yellow zone, and a transient peak in the red zone is OK.  Consistent readings in the red or lighting up the clip indicator means your levels are set too high.
  • Unless you want to record the metronome, check to be sure it is disabled in Options | Metronome.
  • Click on the Record Audio button to record the song.  The Input VU meters will become active during recording.
  • When done, click the Stop button and choose to “Keep Take” when prompted.  A stereo track will have been recorded.

You could then use the menu command Edit | Track | Save Track to File… to save the recorded audio track as a .WAV file.

Note:  RealBand attempts to open the Recording Control panel associated with the Windows mixer.  If you get an error message when the Windows Mixer button is pressed you probably have a sound card with its own control panel and mixer.  In that case, you need to open the sound card’s software separately to adjust the recording properties.  

To render MIDI to audio when you’re using an external synthesizer or sound module you connect its audio output to the Line In of your sound card and select Line In as your input source in the Windows Recording Control.  

Rendering when you’re using an external synthesizer:

  • Load the source MIDI file into RealBand.
  • In the Tracks window select a blank track and set the track type to stereo audio.
  • In Options | Preferences | MIDI Devices verify that the external MIDI driver is selected.  It could be named MPU-401, MIDI Out Port or another name with the word “out” such as SB Live MIDI Out, or MIDI IO (input/output).
  • Click on the VU Meters button on the Tool Bar.
  • In the VU Meters window click on the Windows mixer button to open the Volume Control.  To see the Recording Control select Options | Properties in the Volume Control window.
  • In the Recording Control select “Line In” as the input source by checking the Select checkbox.  Make sure that the audio output of your MIDI synthesizer or sound module is connected to your computer’s Line In jack.
  • Play the MIDI file and monitor the levels on the Input VU meter.  Levels can be adjusted in both the Recording Control and the Volume (or Playback) Control, the levels can occasionally go into the yellow zone, and a transient peak in the red zone is OK.  Consistent readings in the red or lighting up the clip indicator means that your levels are set too high.
  • Unless you want to record the metronome, check to be sure it is disabled in Options | Preferences | Metronome.
  • Click on the Record Audio button to record the song.  The Input VU meters will become active during recording.
  • When done, click the Stop button and choose to “Keep Take” when prompted.  A stereo track will have been recorded.

You could then use the menu command Edit | Track | Save Track to File… to save the recorded audio track as a .WAV file.

Note:  While recording (rendering) the MIDI tracks you can perform real time mixer moves, such as fading volume levels up or down, which will be recorded to the audio track.  These changes cannot be undone, but the tracks could be re-rendered if necessary.

Editing Audio Tracks

Note: By default, the program uses the Windows/Temp directory for temporary audio files created during editing.  You can change the directory in the Options | Preferences dialog under the Audio tab.

You may find that you do much of your audio editing in the Tracks window overview, but the Bars window and the Audio Edit window are also very useful.

Bars Window

The Bars window provides an overview of the data (WAV and/or MIDI) in a song file.  This view makes it easy to select a large region of a track for editing.

Bars view displaying a song with both digital audio and MIDI tracks.

You’ll see that as the song plays the Bars window scrolls along, showing graphical representations of the waveforms that are contained in the individual tracks.  A small cursor at the top of the window indicates the current bar and the numbers indicate the bar numbers of the song.

If the Alt key is held when left-mouse clicking on the overview section of the Bars window the time will be changed without affecting the currently highlighted region.  This lets you quickly adjust the current time without having to worry about accidentally changing the highlighted region.

Audio Edit Window

You can open an Audio Edit window for any track that contains WAV data.  To view the waveforms of the individual tracks click on the track that you want and then click on the Audio Edit toolbar button.

You can also open the Audio Edit window with the menu command Window | New | Audio Edit Window (Ctrl+F2).    

In the Audio Edit window, the Track Name Combo shows the track number in addition to the name for non-blank tracks.

Use this list to change to a view of a different track.

This window lets you view audio data as a graphical representation of the waveforms on the selected track.  It scrolls as the song plays, with a thin red vertical stripe to mark the current song position. 

The number-ruler at the top of the window denotes the bar numbers of the current song.


Small vertical lines are displayed at 8th and 16th note boundaries.  This makes it easier to align audio to correct timing issues.

◄ Left and right ► cursor arrow keys will move the current time forward or backward by 1 beat.

 ►

The dB Scale on the left side of the Audio Edit window gives you a better idea of the level of an audio track.

By clicking on the [+] and [-] buttons you can “zoom” in or out on the waveform to facilitate very precise waveform editing. The large +/- buttons zoom horizontally, the smaller set zooms vertically.

The [Z-Whole] button zooms out to show the entire waveform.

The [Z-Sel] button zooms in on the highlighted section of the waveform.

The [M] button mutes or plays the track.  Red indicates the track is muted, green indicates playing.

The [S] button solos the track.  Bright yellow indicates the track is soloed.

The [Snap] button will cause the highlighted region to snap to the nearest beat when selecting a region with the mouse.

The [Play Selected Area] button will play the highlighted area to let you hear what was selected.

The [Select Whole] button selects the whole audio track.

The current time within the song, if visible within the Audio Edit window, will be shown as a vertical line in red.  This will be drawn in reverse video if the current time is within the selected region.

You can select a region to edit with the mouse by clicking on the waveform and dragging the mouse to the right.  Shift+click (Shift key + left mouse button) support makes it easy to tweak the beginning or end of the highlighted area. 

  • If you Shift+click before the start of the From/Thru range, or after the end of the From/Thru range, the highlighted area will be extended. 
  • If you Shift+click within the From/Thru range, the range will be reduced, and the location you clicked on will become either From or Thru depending on which boundary was closer to where you Shift+clicked the mouse.  
  • If you keep the left mouse button held after the Shift+click, and you move the mouse you can adjust the boundary of the range while moving the mouse.

Alt+click is supported the same way as for the overview section of the Tracks window.  In other words, Alt+click will ONLY move the time marker, which ensures you don't accidentally alter the current selected area. 

After selecting a region, you can then execute Cut, or one of the audio effects in the Edit menu.

Note:  RealBand has support for resolutions as high as 3840 PPQ, which allows for more precise audio editing, since at higher resolutions each tick spans a finer section of audio.  Go to Options | Resolution to make this setting.

The Audio Edit window lets you edit only the left or right channels of a Stereo track instead of editing both channels.  This lets you cut/paste or apply a non-real time effect (Edit | Audio Effects) to just the left or right channel.

RealBand supports drag-and-drop editing in the Audio Edit windows.  Select the highlighted region by holding down the Ctrl key with the left mouse button pressed, and then drag the region to a new location in the song.

Right-Click Audio Edit Menu

The right-click menu in the Audio Edit Window is similar to the right-click menu in the Tracks window.

The Time Stretch and Pitch Shift Audio Track feature allows you to permanently change the duration and pitch of individual audio tracks, or change the speed and pitch of the entire RealBand mix.

Select Whole Track command will select the entire track for editing.

Kill Selected Region will deselect a selected region of an audio (or MIDI) track.

Change Current Time will change the current time without affecting the highlighting of tracks.  This ensures you don’t accidentally de-select a region.

Highlight Current Audio Event makes it easier to select specific audio events, which then could be clicked and dragged (with Ctrl button held down) to a new location, etc.

Copy/Move Current Event (selection) launches the Drag/Drop Edit dialog.

  • If nothing is selected, and you Ctrl+click to drag and drop, it will assume that you want to drag the entire current audio event.
  • Bypassing the dialog for quicker workflow.  If you hold Ctrl+Shift then the drag will move the current event.  If you hold Ctrl+Alt then the drag will copy the current event.  When Dragging/Dropping within the overview section of the Tracks window, you can now drop to a blank track even if the track type wasn't originally set to the correct track type.
  • Drag/Drop will automatically be set to the original time if within 20 ticks (at a PPQ of 120).  So if you drag a region down to a new track, you just need to be “approximate” in the drop location, as the program will snap the time to the same time as the event on the source track.  If you don’t want that behavior, just Ctrl+drag the selection, and the dialog appears with exact values.  In this case, the dialog also has a handy “Set Drop Time to Drag Time” button.
  • The Time field has been added to the Drag/Drop Edit dialog, so you can fine-tune the time for the drop when you drag a selection using Ctrl+drag.
  • Destination Track # added to Drag/Drop Edit dialog when launched from the Tracks window.
  • [Set Drop Time to Drag Time] button has been added to the Drag/Drop Edit dialog
  • Copy/Move Current Event (selection) menu item added to the Tracks window right-click menu
  • When dragging/dropping within the overview section of the Tracks Win, you can drop to blank track even if the track type wasn't originally set to the correct track type.

Audio Effects opens a submenu that is the same as the Edit | Audio Effects window.  This submenu also contains Fade In and Fade Out menu items, which launches a Flash Message w/ instructions, and then launches the GAIN dialog.

The Cut, Copy, Paste, and 1-Track Paste commands apply to the highlighted section of a track(s).  The functions are as described in the Edit Menu topic.

Delete removes the selected section or events.

Tracks Window Editing

Audio edits can also be performed directly in the Tracks window, although the Audio Edit window offers a larger view for precision editing.

Drag and drop audio editing in the Tracks window makes it easy to drag a clip from one track to another.

You can select a highlighted region by holding down the Ctrl key with the left mouse button pressed, and drag the region to a new location in the song.

After releasing the mouse button, you have four options:

  • Move to new location and overwrite.
  • Move to new location and merge.
  • Copy to new location and overwrite.
  • Copy to new location and merge.

There is a right-click menu item in the Tracks window to highlight the current Audio Event.  This makes it easier to select specific audio events, which then could be clicked and dragged (with Ctrl button held down) to a new location, etc.

Note:  An event is defined as an event in the Event List.  If an audio track is a single event, and doesn't have any boundaries shown in the tracks window, then the whole track will be highlighted.

Audio Edit Commands

Audio editing uses the Edit menu commands.  You can Cut, Copy, and Paste audio data just as if it were text.

Each action brings up its own dialog, which can also be launched with the standard Windows keystroke commands Ctrl+X for Cut, Ctrl+C for Copy, and Ctrl+V for Paste.

  The crossfade option when pasting audio smoothes out a paste, so that no audible “clicks” are heard at splice points of pastes.

  Click on the [Help] button in each edit dialog for detailed instructions on the settings and commands.

Audio Effects

This is a submenu that contains all of the permanent audio effects for RealBand. 

The audio effects in this submenu are actually external plug-ins that are transparently integrated with RealBand, but actually aren’t built-in to the program itself.  You’ll be able to use them just as if they were built-in to RealBand.

Unlike the effects that are added in the Mixer window on the FX track insert and the Aux busses, when the effects in the Audio Effects submenu are applied the content of the audio track is permanently altered.  The effect can be removed with the Edit | Undo command. 

Note:  Once the file has been saved the effect cannot be undone.

This command will undo the last edit command executed and restore the track to its previous state.  The number of Undo Levels is adjustable from 1 to 100 in the General section of the Options | Preferences dialog.

Each effect has its own dialog with custom settings and commands.  Click on the [Help] button for a detailed explanation of the settings and a concise tutorial on how to apply the effect.

Time Stretch and Pitch Shift

This feature is available from the Tracks window by right-clicking with the mouse on any audio track.

It allows you to permanently change the duration and pitch of individual audio tracks, or change the speed and pitch of the entire RealBand mix.

If an audio track has been inadvertently recorded too flat or too sharp, you can easily modify the pitch without affecting the track's duration.  If the duration of an audio track is incorrect RealBand can change the tempo of the audio track without affecting the pitch.  Tempo can be adjusted from 1/4 speed to 4X speed.  Pitch can be adjusted +/- one Octave, in one Cent increments (a Cent is 1/100 of a Semitone).

These features are also useful for learning your favorite up-tempo song.  Load the file and play it back at half speed.  If the song is in the key of F but you would rather learn it in Eb, transpose it down 2 semitones and continue playing at half-speed.  As you master the song, you can gradually increase the tempo until you can play along at full speed.

The Time Stretch and Pitch Shift dialog lets you stretch (or reduce) the length of the highlighted section of audio tracks.

Time Stretch (or Reduce)
Enabled:
if checked, then RealBand will change the length based on the following settings:

New Length Percentage:  The new length as a percentage relative to the original length.  For example, a new length percentage of 200% will result in the section being double the original length.

New Speed Percentage: Time stretching (or reduction) will also cause the section to be played faster or slower.  If you are stretching a section of the song, it will play slower.  If you are reducing a section it will play faster.  This setting is the inverse of the New Length Percentage.  For example, a New Speed Percentage of 50% (half speed) will result in a New Length Percentage of 200% (double length).

Old Tempo and New Tempo:  If you specify old and new tempos, this is another way of adjusting the speed, but this method lets you think in terms of a change in tempo rather than a change in speed as a percentage. 

Pitch Shift
Enabled:
  If checked, then RealBand will pitch shift based on the following settings:

Semitones: Amount of semitones to pitch shift up or down.  There are 12 semitones per octave.

Cents: Amount of cents to pitch shift up or down.  There are 100 cents per semitone.

Saving Audio Files

RealBand files are saved in the .SEQ (sequence) file format, which can include both audio and MIDI tracks in the same file.  So you could import a Band-in-a-Box MIDI file into RealBand and then record live parts along with the Band-in-a-Box accompaniment. 

Auto-Backup of .SEQ Files

When you save a file, RealBand now saves a backup of the file in a c:\RealBand\RBBACKUP folder.  This doesn’t add any time to the file-save command, and the number of backups is configurable.  So the next time that you mistakenly overwrite a file when saving, go the backup folder to look for a saved previous copy.

Backup settings are found under the File tab in the Preferences dialog.

When the Create backup file when overwriting a .SEQ file setting is enabled, RealBand will always create a backup file (BKS file) when a .SEQ file is overwritten.  For songs saved into the same hard drive where RealBand is installed, the backups are placed into an RBBACKUP subfolder of the RealBand folder.  For songs that are saved to a different hard drive, the backups are placed in an RBBACKUP folder which is off of the root (e.g. D:\RBBACKUP)   The max backups per song setting determines the maximum number of backups to be kept for each song.  If this limit is reached, then RealBand will delete the oldest backup of the song you are overwriting and create a newer backup.  The “Max backups per hard drive:” setting is the maximum total backups allowed per hard drive.  If this limit is reached, then RealBand will delete the oldest backup file.  There is also on option for moving the older backups into the Recycle Bin instead of deleting them when either of the two limits is reached.

Wave Files

Import Wave File

This command offers to import a wave file into the “current track” of your project.  These audio file formats can be loaded from the Edit | Audio | Insert Wave File menu command.

  • WAV:  Windows wave files, native digital audio files for the Microsoft Windows platform.
  • MP3:  compressed audio files, popular on the Internet.  Requires codec to be present on system.
  • WMA:  Windows Media Audio, a compressed audio format developed by Microsoft.
  • WMV:  Windows Media Video is a compressed video format developed by Microsoft.  RealBand will load the audio from a WMV.
  • CDA:  CD Audio is the file extension used by Windows to make CD audio tracks available for loading into programs like RealBand.  Just put an audio CD into your CD-ROM, and then open a .CDA file from that drive (usually drive D).
Note:  This feature may not work unless running Windows XP or higher.  CDA files may not open in Windows Vista.

This command will also import MultiTrack .WAV files by offering a choice of merging them to mono or placing additional tracks of the wave file onto separate tracks.  For example, if Track 1 is the current track and Track 2 is empty (and you import a Stereo Wave file), RealBand will place the left channel on track 1.  The right channel will be imported to Track 2 on the next available track, which, in this case, is Track 2 since this track is empty.

A dialog will pop up which lets you select the time location to place the wave file(s).  By default, this is the current time (Now:) of a song.

DirectX/VST Configuration

Open DirectX/VST Plugins Configuration
Open the DirectX/VST window to select and edit effects plug-ins.

Open DXi/VSTi Synth Panel Configuration
Opens the DirectX/VST window with the control panel for the current synth.

Audio Chord Wizard

Audio Chord Wizard - Open Audio file (WAV/WMA/MP3/CDA)
Select an audio file to load into the Audio Chord Wizard.

Audio Chord Wizard - Use Existing Song
Load the currently loaded song into the Audio Chord Wizard.

Save Wave File
To make a .WAV file, and even burn a CD of the song, you can render the MIDI tracks to audio and export the whole song to a wave file.
RealBand offers a number of options to save or export audio files in different formats.  These options are found in the Render menu.

Export Acid Loop - Highlighted section or entire track to WAV in Loops Folder…
This command will render the highlighted section of the current track or the whole track as an ACID Loop and save it to the bb\RealTracks\Loops folder.

Save as UserTrack… (highlighted section or whole track)
This command will render the highlighted section of the current track or the whole track as a WAV file and save it to the bb\RealTracks\UserTracks folder.

Export Highlighted Section (or entire track) to wav/wma/mp4/m4a/mp3
This command will export the highlighted section of the current track to a wave file –as long as the track contains audio data.  Drag a section of the track while holding down the left mouse button to select a highlighted section.  Use Ctrl+A to select the whole track, or open the right-click menu and choose Select Whole Track.

Merge Audio and VSTi/DXi Tracks to Stereo Wave File...
This is an export command that will merge all the audio tracks to a stereo wave file while simultaneously rendering and merging the MIDI tracks to audio if you have a DXi or VSTi software synth.  When played in a wave file player the file will sound the same as if the audio tracks of the song were being played by RealBand.  The volume, mute, pan, etc. settings of the track will affect the sound of the merged stereo wave file.

Merge Audio and VSTi/DXi Tracks to Compressed File...
When you export audio to alternate file formats a standard Windows Audio Format dialog appears.

Use the Format popup menu to select the ACM codec you wish to use, and then select the exact specifications of the file from the choices available in the Attributes popup menu.

If you frequently use a particular combination you can save a setting in the Name combo box.

When you press OK, RealBand will export the song to the format you have selected using the ACM codec.

Note:  Most conversions work fine, but not all codecs can save in every format listed.  RealBand does intermediate conversions when necessary (to try to get the job done), but sometimes a codec will report “Conversion not Possible.”  This error is caused by a limitation of the codec rather than RealBand.

Merge Audio and VSTi/DXi Tracks to WMA File
This command works the same as the Render | Merge Audio and DXi Tracks to Stereo Wave File command except that this feature will compress the file using the Microsoft Streaming Media® Compression Technology™.  When you execute this command the program first generates a temporary stereo PCM file (Raw Wave).  A dialog will then pop-up that will let you save the resulting stereo PCM wave file to a .WMA file (Windows Media Audio).

Test Wave File or Compressed File
This command launches your default media player so you can test your file for compatibility and playability with a standard Windows media player.

Launch CD Burner
This command launches the “Miniburn” CD Burner program.  If the current song has audio data, this feature will first offer to merge audio tracks in the current song to a WAV file.  If you say OK to this option, the CD Burner will automatically add the .WAV file to a list of files to be burned onto a CD (burn list).
If necessary, RealBand will convert your file to 16-bit, 44.1 kHz stereo before burning it to an audio CD.

Save all tracks to individual files (WAV MID)
This command will save all tracks to either WAV or MID files depending on the track type.

Save all tracks to WAV files
This command will save all tracks to WAV files.  MIDI tracks will be rendered using DXi.

Acidize this .WAV file
This command will acidize the selected .WAV file.  You can write the Acid information such as tempo, root note, and the tempo signature.

Batch Convert
The command will convert a group of files in a folder over to another file type (.SEQ, .MID, .MP3, .MP4, .M4A, .WAV, .MGU, .SGU). 

This feature is also available from the Batch button.

So let’s say you want to convert your PowerTracks Pro Audio songs to MP4 files.  It’s as easy as entering the location and file type (or all files) for the files that you want to convert and then choosing the output file type and location.  There is also the option to add a suffix to the file names to identify the rendered files.

Input File Type:
The Input File Type combo lists the most common MIDI and audio file formats plus RealBand and Band-in-a-Box file types.  There is also the option to select “All Supported File Types” to convert a folder with more than one type of file.

Input File Path:


This is the location where the files to be converted are found.

 Click on the [Select] button to browse for a folder.



Live Help
Contact Info

PG Music Inc.
29 Cadillac Ave Victoria BC Canada V8Z 1T3

Sales: 800-268-6272, 250-475-2874,
+ 800-4746-8742*

Tech Support: 866-983-2474, 250-475-2708, + 800-4746-8742*

* Outside USA & Canada where International Freephone service is available. Access Codes

Chat online Online now

Need Help?

Customer Sales & Support

Phones (Pacific Time)
1-800-268-6272 1-250-475-2874
Live Chat
OPEN Online Ordering
24/7
OPEN Forums, email, web support
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.
Message from PGMusic.com sales and support team
Hi, have any questions? We're available to text chat.